Message not syncing to iPhone and Mountain Lion - MacRumors Forums
Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 25, 2012, 04:43 PM   #1
philipandrews
macrumors member
 
Join Date: Oct 2011
Location: Richmond, VA
Message not syncing to iPhone and Mountain Lion

I have both my receive messages at set up to the same email, but when I send messages from my iPhone it does not show up on my mac. Not sure if this is just a time delay thing or if I have something set up wrong. Thanks
__________________
15" MacBook Pro, 2.4 GHz, 4 GB RAM, 250 GB HD ; iPhone 5 ; iPod Classic ; Apple TV ; iPad rMini
philipandrews is offline   0 Reply With Quote
Old Jul 25, 2012, 05:29 PM   #2
imswimmin
macrumors regular
 
Join Date: Apr 2011
I'm having the same issue... Can't figure it out. Not getting notifications in notification center.
__________________
2010 i7 740QM HP Envy 14 Beats Edition
2011 13" i5 2557M Macbook Air
2011 iPhone 4S - Black - 64 GB - Verizon
imswimmin is offline   0 Reply With Quote
Old Jul 25, 2012, 05:43 PM   #3
QandnotU
macrumors newbie
 
Join Date: Jul 2012
+1 for the same issue.
QandnotU is offline   0 Reply With Quote
Old Jul 25, 2012, 09:03 PM   #4
SamIchi
macrumors 68030
 
SamIchi's Avatar
 
Join Date: Aug 2004
Booooo, I got the same thing going on. This was one of the few features I was looking forward to use on ML. I'd also rather have my name displayed, than my email. Or my phone number, no one really recognizes my email.

I hope they fix this soon!
SamIchi is offline   0 Reply With Quote
Old Jul 25, 2012, 10:09 PM   #5
bellis1
macrumors 6502
 
Join Date: Feb 2003
Messages not syncing

I missed some important messages today because they were going to my computer but no longer to my phone. I hope there is a solution soon.
bellis1 is offline   0 Reply With Quote
Old Jul 25, 2012, 10:12 PM   #6
momoz
macrumors newbie
 
Join Date: Jun 2010
I might be on to something..

My Messages works perfect. Today I upgraded my MB Air and iMac to ML.
for some reason I updated my apple ID account on the webpage trying to get it to work ( originally it didn't). an imessage sent to my PHONE# sends to ALL devices and when I reply the reply shows up on ALL devices. (MB AIR,iMAC,iPad,iPhone). My iphone uses phone# as callerID, iPad,ML both use AppleID).


My wife's I can NOT make it work.. only when I set all "Caller ID" to her AppleID.

What I noticed was different is on my AppleID account the phone number entries are different.
Mine (working) has the Country code, areacode and phone separated.
Click image for larger version

Name:	Screen Shot 2012-07-25 at 11.03.47 PM.png
Views:	107
Size:	29.4 KB
ID:	349876

Hers does not and does not work..
Click image for larger version

Name:	Screen Shot 2012-07-25 at 11.04.26 PM.png
Views:	65
Size:	25.8 KB
ID:	349877

mike
momoz is offline   1 Reply With Quote
Old Jul 25, 2012, 10:12 PM   #7
philipandrews
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Richmond, VA
I hope this a first for someone to post a question then bring about a solution. First you need to make sure that you have both emails set up for receive messages at. Then depending on the system, you need to first send a message from ML and after that the chat you are in with whomever will update across all devices. Hope this helps.
__________________
15" MacBook Pro, 2.4 GHz, 4 GB RAM, 250 GB HD ; iPhone 5 ; iPod Classic ; Apple TV ; iPad rMini
philipandrews is offline   0 Reply With Quote
Old Jul 25, 2012, 10:12 PM   #8
swordfish5736
macrumors 65816
 
Join Date: Jun 2007
Location: Belle View
Send a message via AIM to swordfish5736
Until iOS 6 is public you won't be able to unify your phone number and apple ID. To receive messages on your computer make sure your email is also an option in send&receive on your iPhone. I found setting my caller ID as my email helped to make sure messages came on all devices
__________________
swordfish5736 is offline   0 Reply With Quote
Old Jul 25, 2012, 10:13 PM   #9
ben824
macrumors regular
 
Join Date: Jul 2012
Location: GA
Having this issue as well! Hope someone has a fix!
__________________
13" MacBook Pro OS X Mavericks ; iPhone 5 32 GB running iOS 7 ; iPad Mini 16 GB Wifi iOS 7 ; Conservative Republican that loves Apple! I know what kind of crazy person am I! haha
ben824 is offline   0 Reply With Quote
Old Jul 26, 2012, 12:41 AM   #10
shalasz
macrumors newbie
 
Join Date: Jun 2007
Mine wasn't working either until...

-I logged into my Apple ID account online and saw that my cell phone wasn't listed on my account.

-Went to Messages>Preferences>Accounts and then logged into my Apple ID from there. Nowhere have I seen anything that tells you to do this. Once I logged in from here, all working fine.

Hope this helps.
shalasz is offline   0 Reply With Quote
Old Jul 26, 2012, 03:01 AM   #11
MacBookPro13"
Banned
 
Join Date: Jan 2011
Location: Ireland
Send a message via MSN to MacBookPro13" Send a message via Skype™ to MacBookPro13"
I had my mobile number one digit incorrect on my Apple ID account so maybe that's why I wasn't getting my messages on my iPhone but was still getting them on my Mac?

I don't like the idea of using 3 different "addresses" to receive iMessage. I want it to be my mobile number across my iPhone, iPad and MacBook Pro - keep it simple.
MacBookPro13" is offline   0 Reply With Quote
Old Jul 26, 2012, 10:38 AM   #12
jttran74
macrumors newbie
 
Join Date: Jul 2010
I set my caller id to my apple id instead of my phone. Also make sure your phone number is correct at appleid.apple.com It didn't work right away, but after about 30 minutes it started syncing just fine.

Last edited by jttran74; Jul 26, 2012 at 11:05 AM.
jttran74 is offline   0 Reply With Quote
Old Jul 26, 2012, 12:06 PM   #13
DoomRider
macrumors newbie
 
Join Date: Jul 2012
I found the following and did it all.
Deleted messages - Turned off iMessage - Turned it back on - Activated Apple ID in Message settings (on iPhone and on Macbook) - Set Caller ID in Message settings on iPhone to email address NOT phone number - Then reset my phone (hold home and power button) and laptop.
Voila! Now they both sync instantly.
Here are the steps...


Fix 1

Activate iMessage on all your iOS5 devices using the same Apple ID. If you already activated iMessage, tap Settings > Messages then turn off iMessage. From there, open by tapping Messages app on the home screen to sign in with your Apple ID to activate iMessage.

Fix 2

Complete this process on each iOS devices you have. Tap Settings > Messages > Receive At. Receiving At settings is your cell phone number on your iPhone by default. Add the same e-mail address on all devices as another “Receive At” location.

Fix 3

Tap Settings > Messages > Receive At > Caller ID and then tap on the Apple ID (same ID on all devices) as your caller ID.
DoomRider is offline   0 Reply With Quote
Old Jul 26, 2012, 12:23 PM   #14
imswimmin
macrumors regular
 
Join Date: Apr 2011
Haha yup! The caller ID method worked for me! Funny how "not-straightforward" it is. Oh well, at least it works!
__________________
2010 i7 740QM HP Envy 14 Beats Edition
2011 13" i5 2557M Macbook Air
2011 iPhone 4S - Black - 64 GB - Verizon
imswimmin is offline   0 Reply With Quote
Old Jul 29, 2012, 05:10 PM   #15
docbigsky
macrumors newbie
 
Join Date: Jul 2012
Location: Big Sky, MT
Worked For Me!

Quote:
Originally Posted by DoomRider View Post
I found the following and did it all.
Deleted messages - Turned off iMessage - Turned it back on - Activated Apple ID in Message settings (on iPhone and on Macbook) - Set Caller ID in Message settings on iPhone to email address NOT phone number - Then reset my phone (hold home and power button) and laptop.
Voila! Now they both sync instantly.
Here are the steps...


Fix 1

Activate iMessage on all your iOS5 devices using the same Apple ID. If you already activated iMessage, tap Settings > Messages then turn off iMessage. From there, open by tapping Messages app on the home screen to sign in with your Apple ID to activate iMessage.

Fix 2

Complete this process on each iOS devices you have. Tap Settings > Messages > Receive At. Receiving At settings is your cell phone number on your iPhone by default. Add the same e-mail address on all devices as another “Receive At” location.

Fix 3

Tap Settings > Messages > Receive At > Caller ID and then tap on the Apple ID (same ID on all devices) as your caller ID.
Doomrider's fix worked for me. Changed return to AppleID, turned iMessage off and back on on phone, restarted everything and voila. Thanks!
docbigsky is offline   0 Reply With Quote
Old Jul 30, 2012, 04:09 PM   #16
ljx718
macrumors 6502
 
Join Date: Dec 2008
Quote:
Originally Posted by DoomRider View Post
I found the following and did it all.
Deleted messages - Turned off iMessage - Turned it back on - Activated Apple ID in Message settings (on iPhone and on Macbook) - Set Caller ID in Message settings on iPhone to email address NOT phone number - Then reset my phone (hold home and power button) and laptop.
Voila! Now they both sync instantly.
Here are the steps...


Fix 1

Activate iMessage on all your iOS5 devices using the same Apple ID. If you already activated iMessage, tap Settings > Messages then turn off iMessage. From there, open by tapping Messages app on the home screen to sign in with your Apple ID to activate iMessage.

Fix 2

Complete this process on each iOS devices you have. Tap Settings > Messages > Receive At. Receiving At settings is your cell phone number on your iPhone by default. Add the same e-mail address on all devices as another “Receive At” location.

Fix 3

Tap Settings > Messages > Receive At > Caller ID and then tap on the Apple ID (same ID on all devices) as your caller ID.
does that mean when someone messages you at your phone number, itll snyc, but then when you respond theyll get a responce from apple id email?
ljx718 is offline   0 Reply With Quote
Old Aug 8, 2012, 06:09 PM   #17
justwright
macrumors newbie
 
Join Date: Sep 2011
Location: San Diego, Ca
Quote:
Originally Posted by ljx718 View Post
does that mean when someone messages you at your phone number, itll snyc, but then when you respond theyll get a responce from apple id email?
bump
justwright is offline   0 Reply With Quote
Old Aug 17, 2012, 08:11 PM   #18
MR1324
macrumors 6502
 
Join Date: Nov 2010
bump this thread because DoomRider's solution is the only one that really works.
MR1324 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
if i uppgrade to mountain lion will both lion and mountain lion be installed? Popis1991 OS X 10.8 Mountain Lion 2 Sep 16, 2012 07:31 AM
Notes not syncing with ipod touch via iTunes running Mountain Lion Levendis OS X 10.8 Mountain Lion 5 Aug 28, 2012 01:04 PM
How do you remove yourself from a group message in Messages in Mountain Lion? neurophysicist OS X 10.8 Mountain Lion 21 Aug 23, 2012 12:02 PM
Problem clean installing Mountain Lion over Mountain Lion! datsmabowl OS X 10.8 Mountain Lion 6 Aug 15, 2012 10:13 PM
Mountain Lion syncing kwiiboy OS X 10.8 Mountain Lion 1 Jul 26, 2012 04:37 PM

Forum Jump

All times are GMT -5. The time now is 08:01 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC