Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 27, 2012, 05:11 AM   #1
618537
Guest
 
Join Date: Sep 2011
SMB Shares Broken

Attempting to connect an iMac to Windows Server 2008 and unable to connect to the shares.

Done a little bit of Googling and there are a few vague reports on the Apple Communities.

Is anyone else experiencing this issue and have they found any solution?

(Only problem I've encountered on ML but a major issue for when at work if we want to roll out ML)
618537 is offline   0 Reply With Quote
Old Jul 27, 2012, 09:07 PM   #2
pianodude123
macrumors 6502a
 
pianodude123's Avatar
 
Join Date: Mar 2005
Location: in the internet
Send a message via Skype™ to pianodude123
Quote:
Originally Posted by eversonj90 View Post
Attempting to connect an iMac to Windows Server 2008 and unable to connect to the shares.

Done a little bit of Googling and there are a few vague reports on the Apple Communities.

Is anyone else experiencing this issue and have they found any solution?

(Only problem I've encountered on ML but a major issue for when at work if we want to roll out ML)
I'm having huge problems with getting connected to my Ubuntu NAS server with SMB. ALl I get is beach balls.
__________________
Mac Pro - 2.66/5GB/2 x 1.5 TB/Dell 3007WFP
Macbook Pro 15" Retina
http://www.stenchinformer.com
pianodude123 is offline   0 Reply With Quote
Old Jul 27, 2012, 10:35 PM   #3
rgarjr
macrumors 603
 
rgarjr's Avatar
 
Join Date: Apr 2009
Location: C a l i f o r n i a
I'm able to connect to my W7 machine (which has 2 SMB drives) just fine on my MB.
rgarjr is offline   0 Reply With Quote
Old Jul 28, 2012, 10:26 AM   #4
eddienyc1
macrumors newbie
 
Join Date: Mar 2011
Location: Brooklyn, NY
Change Computer name to IPAddress to fix SMB shares

I was having the same trouble yesterday once I installed ML but resolved it this morning.
When I tried using my existing "connect to Server" connections which worked fine in Snow Leopard I kept getting an error message that it couldn't connect.
I decided to change the computer name to the actual IPAddress and it worked fine.

old method SMB://UserName@computerName
new method SMB://IPAddress/
which them prompted me to sign in as a register User. I saved the password in my keychain and was successful in connecting to my Windows Computer.
eddienyc1 is offline   0 Reply With Quote
Old Jul 29, 2012, 10:08 PM   #5
callan37
macrumors newbie
 
Join Date: Nov 2011
In Lion, I would type "smb://ipaddress", - this stopped working in ML, however, typing "smb://ipaddress/sharename" is working - there is still an issue that I can't simply connect to the server (there are 4 different share drives on the same server, so I used to be able to simply connect to the server). Also, the server comes up under 'shared', but if I click this it just has a folder that says " /" and the link doesn't connect to anything.

So this workaround worked for me, but still not ideal.
callan37 is offline   0 Reply With Quote
Old Jul 30, 2012, 02:56 AM   #6
618537
Thread Starter
Guest
 
Join Date: Sep 2011
Quote:
Originally Posted by callan37 View Post
"smb://ipaddress/sharename"
Advice coming from Applecare at the moment is this ^.

Not ideal but at least not disastrous.
618537 is offline   0 Reply With Quote
Old Jul 31, 2012, 08:18 PM   #7
BernieC
macrumors newbie
 
Join Date: Jun 2002
I've seen this, as well, and I think I know what's going on. I've opened up a bug report with Apple....

https://discussions.apple.com/message/19117186#19117186
BernieC is offline   0 Reply With Quote
Old Jul 31, 2012, 08:47 PM   #8
gerryf
macrumors newbie
 
Join Date: Jul 2012
Were these pre-connected shares that worked, and then no longer work after an upgrade?

Did you browse to the connection, or just try to direct connect with smb://computer/share?

What OS is the server running?

I haven't had any issue with ML, but I had some periodic issues with Lion....
gerryf is offline   0 Reply With Quote
Old Aug 1, 2012, 01:16 PM   #9
gogg
macrumors newbie
 
Join Date: Nov 2010
Location: Scotland
SMB connect failure

Quote:
Originally Posted by gerryf View Post

I haven't had any issue with ML, but I had some periodic issues with Lion....
Ever since I updated to ML, SMB share to my NAS drive the connection no longer works. The only way I can connect is using a virtual Mac running Lion under Parallels. Seems its an Apple problem, hopefully they release a patch soon.
__________________
Graham
gogg is offline   0 Reply With Quote
Old Aug 1, 2012, 01:47 PM   #10
stucazzo81
macrumors newbie
 
Join Date: Mar 2012
The Fix! - At least for me

I had this same issue after upgrading to ML. I have a Windows 7 server at home with data that I access through SMB. After hours of troubleshooting, I removed the stored usernames/password for the shares in keychain and repaired my disk permissions (from within ML). SMB started working again. Sad how this issue was noticed and reported back when ML first hit developers. Good luck to all, hopefully this fix works for you too!
stucazzo81 is offline   0 Reply With Quote
Old Aug 1, 2012, 03:25 PM   #11
zombiecakes
macrumors regular
 
Join Date: Jul 2012
I can connect fine but it has never automatically detected a network pc, for some reason it seems to work fine at work
zombiecakes is offline   0 Reply With Quote
Old Jan 24, 2013, 02:19 AM   #12
smoledman
macrumors 65816
 
Join Date: Oct 2011
I can't get SMB share working since upgrading to ML. ******* Apple.,
smoledman is offline   0 Reply With Quote
Old Jan 26, 2013, 08:00 AM   #13
itsamacthing
macrumors 6502
 
Join Date: Sep 2011
Check your WINS settings
itsamacthing is offline   0 Reply With Quote
Old Jan 26, 2013, 08:11 AM   #14
costabunny
macrumors 68000
 
costabunny's Avatar
 
Join Date: May 2008
Location: ~/
Send a message via Skype™ to costabunny
Quote:
Originally Posted by smoledman View Post
I can't get SMB share working since upgrading to ML. ******* Apple.,
Yeh I had this too so I disabled File Sharing and installed Samba3 using Macports - so much easier and works like a charm
__________________
Bunny has an iPhone 5C, an iPad Mini Retina, a PC & a MacBook Pro retina

“There is no greater agony than bearing an untold story inside you.”
costabunny is offline   0 Reply With Quote
Old Feb 11, 2013, 10:16 AM   #15
al5x
macrumors newbie
 
Join Date: Feb 2013
Hello,

I found this thread whilst looking for the solution to a slightly different issue which may or may not be related...so apologies if this takes things off track!

I recently migrated some data from a Mac server onto a Windows 2008 server and shared it out via SMB; result was as follows:

1. Windows clients could connect to shares ok and see all file & folders.

2. 10.7.x Mac clients and above were able to connect to the share but some sub folders were missing/invisible.

3. 10.4.x Mac client could see all the contents of the folders within the share.

Turns out that some of the folders had a <space> character following the folder name (which is effectively invisible unless you go to rename a folder). I was unable to rename the folder (removing the space) via Windows explorer as it thinks that 'foldername<space>' and 'foldername' are the same name (I didn't get round to trying to rename it via a command prompt encapsulating the folder in quotes but this may work), however renaming it via the old 10.4.x Mac did the trick, all folders were then visible on all clients.

In one particular case you could see a top-level folder that contained a trailing space but you couldn't see any sub-folders within it (some sub-folders contained spaces, some didn't).

So long story short, if you're connecting ok to an SMB share but can't see certain folders, look for any rogue trailing <space> chars.

Hope this helps anybody else with a similar issue!

Alex
al5x is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Timeout before disconnecting SMB shares HackerJL Mac OS X Server, Xserve, and Networking 6 Jul 25, 2013 01:35 PM
Color Labels and SMB Shares HughMad Mac OS X 10.7 Lion 0 Jan 8, 2013 05:37 PM
NOTHING other than Win7 machines can connect to SMB Shares Namtaro OS X 10.8 Mountain Lion 1 Sep 11, 2012 12:00 AM
Searching SMB shares on ML.. Anyone got a it working? chandler99 OS X 10.8 Mountain Lion 5 Jul 30, 2012 06:24 PM
SMB Shares Omnikurt OS X 10.8 Mountain Lion 3 Jul 26, 2012 12:01 PM

Forum Jump

All times are GMT -5. The time now is 08:41 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC