Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 27, 2012, 04:15 PM   #1
tey112
macrumors member
 
Join Date: Mar 2011
Messages and iPhone

I just upgraded to Mountain Lion from Lion and I have an iPhone. I can send someone a message from Messages on my Mac, but when they respond, it goes to my phone, and not the Messages app.

Any idea why that is happening?

Thanks
tey112 is offline   0 Reply With Quote
Old Jul 27, 2012, 04:30 PM   #2
Julien
macrumors 68040
 
Join Date: Jun 2007
Location: Atlanta
Quote:
Originally Posted by tey112 View Post
I just upgraded to Mountain Lion from Lion and I have an iPhone. I can send someone a message from Messages on my Mac, but when they respond, it goes to my phone, and not the Messages app.

Any idea why that is happening?

Thanks
They are sending to your phonee number and not your email address. This is a well known/documented problem with iOS5 and will be fixed on iOS6 with address/phone number unification.
Julien is online now   0 Reply With Quote
Old Jul 27, 2012, 04:37 PM   #3
lordofthereef
macrumors 603
 
lordofthereef's Avatar
 
Join Date: Nov 2011
Location: Boston, MA
Quote:
Originally Posted by Julien View Post
They are sending to your phonee number and not your email address. This is a well known/documented problem with iOS5 and will be fixed on iOS6 with address/phone number unification.
To expand on this a bit, just set it to go to both your number AND email address. That is what I did, and it works a treat.
__________________
I use iOS and Android daily and, more recently, Windows Phone 8. If what I say upsets you, it's probably because of your brand loyalty.
lordofthereef is offline   0 Reply With Quote
Old Jul 29, 2012, 03:21 PM   #4
Kcid
macrumors newbie
 
Join Date: Jul 2012
How to get all you iMessage devices working in unison

The secret is that the CALLER ID has to be the same on all devices and it CANNOT be a phone number (i.e. your Mac doesn't have a phone#). This is not the caller ID that people you call would see.

It doesn't have to be your apple ID email either, it just has to be an email address and it has to be the same on all your devices.

On your iPad & iPhone go into Settings.
Select Messages.
Tap on Receive At
Tap Add another email and enter the email you are going to use.
Then go down to Caller ID and tap on that email address so it is checked.

On the Mac open the Messages app, select preferences under the Messages menu.
Click on Accounts.
Left column should have Bonjour and your Apple ID. Click on the Apple ID

where it says, you can be reached for messages at:
Click on the + sign and type in the email your going to use.
Press return.
On the Caller ID selection, pull down the menu and select that email address.

Voila, you are done.

Last edited by Kcid; Jul 29, 2012 at 03:23 PM. Reason: fix misspellings
Kcid is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Sent messages from Messages app on Macbook do not show up in OS X or iPhone justbask OS X 10.8 Mountain Lion 0 Aug 9, 2013 04:14 PM
Project Amy Allows Users to Send App.net Private Messages via Messages for OS X MacRumors Mac Blog Discussion 6 Mar 5, 2013 10:31 AM
Mountain Lion Messages app wont let me send text messages EstrlM3 Mac Applications and Mac App Store 7 Jul 28, 2012 12:11 PM
Messages.app doesn't load messages sent by iPhone rodknocker OS X 10.8 Mountain Lion 13 Jul 26, 2012 03:24 PM

Forum Jump

All times are GMT -5. The time now is 05:02 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC