Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 27, 2012, 07:50 PM   #1
Apple...
macrumors 68020
 
Apple...'s Avatar
 
Join Date: May 2010
Location: Sioux Falls, SD, U.S.
Mountain Lion Frustrations?!

Do you have any? I'm still using Snow Leopard...debating wether or not to upgrade. I still have Microsoft Office 2003, so I'd have to replace that somehow. And iMovie 06' should still work right? Anything else I should be aware of? Thanks!
__________________
"Stay Hungry. Stay Foolish." - Steve Jobs

Wishful irony: Apple buys Dell, shuts it down, and gives the $ back to the shareholders. Just because it can.
Apple... is offline   0 Reply With Quote
Old Jul 27, 2012, 08:19 PM   #2
VacantPsalm
macrumors member
 
Join Date: Sep 2010
Mission Control is choppy as HELL when Safari is open. If I hide it with Cmd+H it'll be smooth as butter. Then when I unhide it, super lag-a-muffin. Like the desktop background is all the way back before the windows even move sometimes. I'm on a Retina MBP, Lion didn't do this.

I'm here now checking if there's a thread about it.
VacantPsalm is offline   6 Reply With Quote
Old Jul 27, 2012, 08:20 PM   #3
NotAdvisable
macrumors regular
 
Join Date: Nov 2011
Location: Perth, Australia
Quote:
Originally Posted by Apple... View Post
Do you have any? I'm still using Snow Leopard...debating wether or not to upgrade. I still have Microsoft Office 2003, so I'd have to replace that somehow. And iMovie 06' should still work right? Anything else I should be aware of? Thanks!
I'm absolutely loving Mountain Lion.
I reckon you should move to the latest Office for Mac (or iWork; far better than Microsoft's offering) and also move to the latest iLife. What's stopping you?
__________________
Retina Macbook Pro (Mid 2012, 15", 2.6GHz i7, 8GB / 512GB)
iPad Air (128GB Cellular, Space Grey) & iPhone 6+ (64GB, Space Grey)
NotAdvisable is offline   0 Reply With Quote
Old Jul 27, 2012, 09:03 PM   #4
tillsbury
macrumors 6502a
 
Join Date: Dec 2007
Well make sure you have a good backup. Installation of ML here (on rMBP, so using current Lion) just trashed the machine completely, "there was an error installing OSX". Recovery utilities couldn't repair the disk, reformat and start again job. Bagh...
tillsbury is offline   0 Reply With Quote
Old Jul 27, 2012, 09:09 PM   #5
JS82712
Banned
 
Join Date: Jul 2009
Quote:
Originally Posted by VacantPsalm View Post
Mission Control is choppy as HELL when Safari is open. If I hide it with Cmd+H it'll be smooth as butter. Then when I unhide it, super lag-a-muffin. Like the desktop background is all the way back before the windows even move sometimes. I'm on a Retina MBP, Lion didn't do this.

I'm here now checking if there's a thread about it.
I have a 2010 iMac running a clean-installed ML, and I can confirm that this is an issue. Mission control just lags like crazy when safari is used in full-screen mode.
JS82712 is offline   2 Reply With Quote
Old Jul 27, 2012, 09:17 PM   #6
Apple...
Thread Starter
macrumors 68020
 
Apple...'s Avatar
 
Join Date: May 2010
Location: Sioux Falls, SD, U.S.
Quote:
Originally Posted by tillsbury View Post
Well make sure you have a good backup. Installation of ML here (on rMBP, so using current Lion) just trashed the machine completely, "there was an error installing OSX". Recovery utilities couldn't repair the disk, reformat and start again job. Bagh...
Yikes! That's not good. How do I go about installing the right way? I have over a TB of data.
__________________
"Stay Hungry. Stay Foolish." - Steve Jobs

Wishful irony: Apple buys Dell, shuts it down, and gives the $ back to the shareholders. Just because it can.
Apple... is offline   0 Reply With Quote
Old Jul 27, 2012, 09:18 PM   #7
DWS1187
macrumors newbie
 
Join Date: Nov 2011
Location: Kinston, NC
Send a message via Skype™ to DWS1187
I have a clean install of ML and some of the things that frustrate me are

1. Open mail, indicator light on, close window, indicator light off, app is running under Force Quit....is it on or off???

2. No Safari Only mode anymore? Just a guest account. Disabled the guest account and enabled FMM and it just re-enables the guest account.

Other than that I am rather happy with the new OS X 
__________________
MacBook Pro 15" Early 2011 (OWC Mercury Extreme Pro 6G);iPad 2;iPod Touch 4th Gen;iPod Nano 3rd Gen;
AirPort Express 1st Gen;AppleTV 3rd Gen;Apple iPhone 4s;
DWS1187 is offline   2 Reply With Quote
Old Jul 27, 2012, 09:23 PM   #8
kn1ne
macrumors newbie
 
Join Date: Jul 2012
So far I am very happy with Mountain Lion.. had a minor hiccup getting it to download, but that was probably more to do with launch day glitches. Since its been installed I have noticed a lot of things that were introduced in Lion run much more smoothly than they ever did before, such as Mission Control, Launchpad etc..

Notifications are really cool, and reminders and notes being their own apps now is really cool. My favorite feature by far though is how documents now sync across mac and iOS devices.. for me this is a huge benefit that I am already using with Numbers and Pages, and is making my life much easier.

I haven't had TOO much time with it yet, but so far it hasn't broken any of my 3rd party apps. Air Video, Screens, Mint, Coda, etc. are all working with no hang ups. I think it was well worth the $20 going from Lion, so its a huge update if you are going from Snow Leopard.
__________________
Mac Mini (Late 2009), OS X 10.8, 2.26 GHz, 8 GB RAM
iPad 2, 16 GB Wifi + 3G (Black)
iPhone 4, 32 GB, GSM (Black)
kn1ne is offline   1 Reply With Quote
Old Jul 27, 2012, 09:27 PM   #9
b_scott
macrumors 6502
 
Join Date: Mar 2008
I have an April 2010 MBP High Res

ML has dropped my battery life so low that I don't know if I'll be able to keep it. It's pretty ridiculous. I've used it about 1.5 hours and it's at 41% - and all I've done is web browse.
__________________
Canon EOS 5D Mark II | 17-40 L f4 USM | 50 f1.4 USM | 70-200 L f2.8 IS II USM | 430EX II
b_scott is offline   2 Reply With Quote
Old Jul 27, 2012, 09:40 PM   #10
VacantPsalm
macrumors member
 
Join Date: Sep 2010
Quote:
Originally Posted by JS82712 View Post
I have a 2010 iMac running a clean-installed ML, and I can confirm that this is an issue. Mission control just lags like crazy when safari is used in full-screen mode.
Thing to note, it seems to have gotten a lot better now that I've closed a few tabs. I had like 14 tabs open between 4 windows before, dropping that to 8 between two windows helped quite a bit. Or maybe it's the number of windows open, (probably both) playing around with things now.

Whatever the issue is, closing windows and tabs is just a temporary solution. I can get well into 30 tabs depending on what I'm doing. (Collecting wallpapers = middleclick, middleclick, middleclick, middleclick on thumbnails and look through them later.)

Edit: Ohhh yea, 10 windows open is definitely worse then having 10 tabs in one window. That's like a 3 frame animation there.

Last edited by VacantPsalm; Jul 27, 2012 at 09:47 PM.
VacantPsalm is offline   0 Reply With Quote
Old Jul 27, 2012, 09:43 PM   #11
slrandall
macrumors 6502
 
Join Date: Jun 2011
Quote:
Originally Posted by VacantPsalm View Post
Mission Control is choppy as HELL when Safari is open. If I hide it with Cmd+H it'll be smooth as butter. Then when I unhide it, super lag-a-muffin. Like the desktop background is all the way back before the windows even move sometimes. I'm on a Retina MBP, Lion didn't do this.

I'm here now checking if there's a thread about it.
http://forums.macrumors.com/showthread.php?t=1413062

Noticed it as soon as I upgraded. It's awful.
slrandall is offline   1 Reply With Quote
Old Jul 27, 2012, 09:46 PM   #12
Apple...
Thread Starter
macrumors 68020
 
Apple...'s Avatar
 
Join Date: May 2010
Location: Sioux Falls, SD, U.S.
Quote:
Originally Posted by slrandall View Post
http://forums.macrumors.com/showthread.php?t=1413062

Noticed it as soon as I upgraded. It's awful.
Sounds like this a RMBP issue only?
__________________
"Stay Hungry. Stay Foolish." - Steve Jobs

Wishful irony: Apple buys Dell, shuts it down, and gives the $ back to the shareholders. Just because it can.
Apple... is offline   0 Reply With Quote
Old Jul 27, 2012, 09:48 PM   #13
JS82712
Banned
 
Join Date: Jul 2009
Quote:
Originally Posted by VacantPsalm View Post
Thing to note, it seems to have gotten a lot better now that I've closed a few tabs. I had like 14 tabs open between 4 windows before, dropping that to 8 between two windows helped quite a bit. Or maybe it's the number of windows open, (probably both) playing around with things now.

Whatever the issue is, closing windows and tabs is just a temporary solution. I can get well into 30 tabs depending on what I'm doing. (Collecting wallpapers = middleclick, middleclick, middleclick, middleclick on thumbnails and look through them later.)
Indeed, reducing the number of tabs does seem to improve the whole mission control animation; though for a computer that runs SCII nicely, I find it ridiculous that it's having trouble with a simple system animation.
JS82712 is offline   1 Reply With Quote
Old Jul 27, 2012, 09:49 PM   #14
VacantPsalm
macrumors member
 
Join Date: Sep 2010
Quote:
Originally Posted by slrandall View Post
http://forums.macrumors.com/showthread.php?t=1413062

Noticed it as soon as I upgraded. It's awful.
Cool, hopping over there now.
VacantPsalm is offline   0 Reply With Quote
Old Jul 27, 2012, 09:52 PM   #15
teamrusnac
macrumors newbie
 
Join Date: May 2012
Location: Or-Gone
messages dont work

personally, i cant get iMessages on my phone to work with Messages app. I have seen a lot of other people have this issue. If you are using one apple id for your itunes and a @me.com address for your iCloud, it seems to be causing a lot of the issues.

The only way I can get my stuff to sync is to have the person I am messaging enter my icloud account email address in my contact in their iPhone, erase all current conversations we are having on all devices involved, and then initiate a new conversation from the Message app on my mac and bam every thing is on all devices. This is the only way it will work. I have spent hours on the phone wil Apple Care and they couldnt figure this out and how to actually get it to work properly, like advertised. Obviously, this crap isnt ready and it doesnt "just work". Really disappointed.

If I send a message from my phone first with a NEW conversation, it comes from my phone number. The conversation DOES NOT SYNC with the MAC!

I even tried to do this and then continue the conversation on the MAC and it wouldn't even send the message!

Now if I send a message first on a NEW conversation via my MAC it WILL show up on the phone with the settings described above and sync to BOTH devices. Works great. Problem is it's VIA MY EMAIL! Many people do not want this to happen!!!
teamrusnac is offline   1 Reply With Quote
Old Jul 27, 2012, 09:53 PM   #16
GenesisST
macrumors 65816
 
GenesisST's Avatar
 
Join Date: Jan 2006
Location: Where I live
For me, I had no built-in audio until I rebooted. After that, no issues (yet!), but I don't see much difference so far.

I also had to reinstall the Xcode "command line tools", I was searching for GIT of a long time, I couldn't pull code that was committed during my vacation to see if the old "take 1 week of vacation and come back to twice the work" would hold true...
__________________
Kenmore microwave, Frigidaire oven, Fisher & Paykel fridge, LG washer & Dryer and Crane toilet
GenesisST is online now   0 Reply With Quote
Old Jul 27, 2012, 10:12 PM   #17
tillsbury
macrumors 6502a
 
Join Date: Dec 2007
Quote:
Originally Posted by Apple... View Post
Yikes! That's not good. How do I go about installing the right way? I have over a TB of data.
Don't know. Make sure Time Machine is up to date (I ran it again just before clicking on install, have far too much data that cannot possibly go awol). Took 35 minutes to restore 500Gb from the time machine backup so at least that's one plus point. Will do another before trying again...
tillsbury is offline   0 Reply With Quote
Old Jul 27, 2012, 10:55 PM   #18
ixodes
macrumors 601
 
ixodes's Avatar
 
Join Date: Jan 2012
Location: Pacific Coast, USA
Mountain Lion is wonderful... on someone else's Mac

I've got my rocket ship fast, ultra smooth & reliable 512GB Samsung 830 equipped MBP's loaded with memory & Snow Leopard v 10.6.8

There's no way I would disrupt this terrific setup

If there's one thing I've learned over the years, is newer is not always better.

I'll let someone else live with the bugs & annoyances of Mountain Lion.

Once fully optimized like these 2010 & 2011 i7's are, it's time to sit back & enjoy.

There's _nothing_ better than a well sorted Mac.
__________________
An Ultra Fast Mac Is...My Favorite
ixodes is offline   2 Reply With Quote
Old Jul 27, 2012, 10:57 PM   #19
Ualnosaj
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by VacantPsalm View Post
Mission Control is choppy as HELL when Safari is open. If I hide it with Cmd+H it'll be smooth as butter. Then when I unhide it, super lag-a-muffin. Like the desktop background is all the way back before the windows even move sometimes. I'm on a Retina MBP, Lion didn't do this.

I'm here now checking if there's a thread about it.
Hmm I'm not seeing this with a 2012 i7 MBA (proc perhaps) but do feel it slightly with a mid-2011 i5 MBA though. Wouldn't describe it as lag-a-muffin, but I (we) did come from Lion so maybe already used to mission control quirkiness.
Ualnosaj is offline   0 Reply With Quote
Old Jul 27, 2012, 11:04 PM   #20
M87
macrumors 65816
 
Join Date: Jul 2009
No significant problems here so far. Dictation works great, AirPlay mirroring works great, all of my apps work just fine. Overall very happy!

Quote:
Originally Posted by VacantPsalm View Post
Mission Control is choppy as HELL when Safari is open. If I hide it with Cmd+H it'll be smooth as butter. Then when I unhide it, super lag-a-muffin. Like the desktop background is all the way back before the windows even move sometimes. I'm on a Retina MBP, Lion didn't do this.

I'm here now checking if there's a thread about it.
I'm on a rMBP too and have no such problem with Safari and Mission Control.
__________________
I <3 
M87 is offline   0 Reply With Quote
Old Jul 27, 2012, 11:24 PM   #21
espiritujo
macrumors member
 
Join Date: Sep 2011
Location: columbia, sc
Question

I wish the screen resolution would show up on my menu bar. Where did it go?
__________________
life changes, friends don't


2012 15' MBP High Res AG 2.6 i7 8gb 750gb HD
espiritujo is offline   0 Reply With Quote
Old Jul 27, 2012, 11:24 PM   #22
VacantPsalm
macrumors member
 
Join Date: Sep 2010
Quote:
Originally Posted by M87 View Post
I'm on a rMBP too and have no such problem with Safari and Mission Control.
How many Safari windows do you have open?
VacantPsalm is offline   0 Reply With Quote
Old Jul 28, 2012, 12:20 AM   #23
GodWhomIsMike
macrumors 6502a
 
Join Date: Sep 2007
Airplay. Why the hell is there a 1-2 second audio delay. And the audio cuts out too for a second here and there. I have the latest mid-2012 13" Macbook Pro, and the latest AppleTV. So annoying.
GodWhomIsMike is offline   0 Reply With Quote
Old Jul 28, 2012, 12:30 AM   #24
blatopilot
macrumors regular
 
Join Date: Sep 2011
I had a choppy first day with ML...I installed via the app store and had the same feelings I had when I first installed Lion...I reinstalled with CMD+R as an experiment and it is much much better now...Can't say that will be forever, but the performance is night and day different.
blatopilot is offline   0 Reply With Quote
Old Jul 28, 2012, 12:40 AM   #25
ivnj
macrumors 6502a
 
Join Date: Dec 2006
Biggest frustration is installation. -1:48 minutes.
ivnj is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Resolved: How to do a Clean install of Mountain Lion on Mountain Lion phr33k OS X 12 Feb 6, 2013 10:15 AM
Resolved: Help - How to do a clean install of Mountain Lion on Mountain Lion phr33k Mac Basics and Help 7 Nov 25, 2012 07:13 AM
Snow Leopard Vs Lion Vs Mountain Lion for 2006 2.66x4 Mac Pro cen7779 Mac Pro 9 Oct 3, 2012 03:44 PM
if i uppgrade to mountain lion will both lion and mountain lion be installed? Popis1991 OS X 10.8 Mountain Lion 2 Sep 16, 2012 07:31 AM
Problem clean installing Mountain Lion over Mountain Lion! datsmabowl OS X 10.8 Mountain Lion 6 Aug 15, 2012 10:13 PM

Forum Jump

All times are GMT -5. The time now is 05:43 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC