Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 3, 2012, 12:16 AM   #1
xkmxkmxlmx
macrumors 6502a
 
xkmxkmxlmx's Avatar
 
Join Date: Apr 2011
Any way to turn off notifications?

I do not like the feature. It is intrusive and pointless to me. I hate manually having to delete each one. I have a LOT of items in iCal, for instance. Every day there is at least 5-10 notifications that pop up on the side when I open up my computer. I am going to be using iCal anyway, so what is the point in telling me? It reminds me of Windows with the little pop up notification every time something happens. I think it is awful that it is forced and not optional.

Anyway, I just want to find a way to turn them off.

Anyone have a fix?
xkmxkmxlmx is offline   1 Reply With Quote
Old Aug 3, 2012, 12:34 AM   #2
Ice-Cube
macrumors 6502a
 
Ice-Cube's Avatar
 
Join Date: Jul 2006
Location: Somewhere over the rainbow
You can turn them off individually in system preferences:

__________________
sent from my iPhone.
Ice-Cube is offline   0 Reply With Quote
Old Aug 3, 2012, 10:02 PM   #3
xkmxkmxlmx
Thread Starter
macrumors 6502a
 
xkmxkmxlmx's Avatar
 
Join Date: Apr 2011
Quote:
Originally Posted by Ice-Cube View Post
You can turn them off individually in system preferences:

Image
Where? You can not turn them off completely in "notifications" under sysprefs.
xkmxkmxlmx is offline   0 Reply With Quote
Old Aug 3, 2012, 10:19 PM   #4
iLog.Genius
macrumors 68040
 
iLog.Genius's Avatar
 
Join Date: Feb 2009
Location: Toronto, Ontario
I don't think you can completely disable the "Notification", but you can select "None" in System Preferences. As for the sidebar, don't call it.
__________________
15.4" MacBook Pro 2.4GHz, 4GB RAM, WD Scorpio Blue 500GB HDD, GeForce 9400M + 9600M GT
iPad with Retina Display
iPhone 5S
iLog.Genius is offline   0 Reply With Quote
Old Aug 3, 2012, 10:21 PM   #5
76ShovelHead
macrumors 6502
 
Join Date: May 2010
Location: Connecticut
Quote:
Originally Posted by xkmxkmxlmx View Post
Where? You can not turn them off completely in "notifications" under sysprefs.
Can't you just open the notifications side bar by clicking the icon right of spotlight, scroll up and move the slider "Show Alerts and Banners" to the off position?
__________________
Haswell i5 3 GHz 8 GB Ram 128 GB SSD Mavericks
76ShovelHead is offline   0 Reply With Quote
Old Aug 4, 2012, 09:32 PM   #6
xkmxkmxlmx
Thread Starter
macrumors 6502a
 
xkmxkmxlmx's Avatar
 
Join Date: Apr 2011
Quote:
Originally Posted by 76ShovelHead View Post
Can't you just open the notifications side bar by clicking the icon right of spotlight, scroll up and move the slider "Show Alerts and Banners" to the off position?
That only lasts for 24 hours.
xkmxkmxlmx is offline   0 Reply With Quote
Old Aug 4, 2012, 10:14 PM   #7
Icy1007
macrumors 6502a
 
Join Date: Feb 2011
Location: Las Vegas, NV
Just disable notifications for each app individually in System Prefs. That will effectively disable the Notification Center.
__________________
15" 2011 MacBook Pro, 2.2 GHz i7 Quad, 8GB DDR3, 1GB Radeon HD 6750M, 1TB HDD; 32GB iPhone 5
Icy1007 is offline   0 Reply With Quote
Old Aug 4, 2012, 10:34 PM   #8
xkmkmlmx
macrumors newbie
 
Join Date: Apr 2011
Quote:
Originally Posted by Icy1007 View Post
Just disable notifications for each app individually in System Prefs. That will effectively disable the Notification Center.
I am sorry to be a little blunt, but I have obviously tried that, as per the statements in this thread alone, and it does NOT work.

Do you know your advice to be fact? Or are you just stating what you *think*? Is my computer having problems?
xkmkmlmx is offline   0 Reply With Quote
Old Aug 4, 2012, 10:43 PM   #9
ixodes
macrumors 601
 
ixodes's Avatar
 
Join Date: Jan 2012
Location: Pacific Coast, USA
Apples inclusion of iOS "Features" in OS X has royally mucked it up.

Apple just can't seem to understand that diluting OS X on the desktop by adding elements of iOS doesn't thrill everyone that sees it much less their experienced computer users.

Yet they are determined to ad every gimmick they can think of.

Fischer Price must be so jealous.
__________________
An Ultra Fast Mac Is...My Favorite
ixodes is offline   0 Reply With Quote
Old Aug 4, 2012, 11:17 PM   #10
Icy1007
macrumors 6502a
 
Join Date: Feb 2011
Location: Las Vegas, NV
Quote:
Originally Posted by xkmkmlmx View Post
I am sorry to be a little blunt, but I have obviously tried that, as per the statements in this thread alone, and it does NOT work.

Do you know your advice to be fact? Or are you just stating what you *think*? Is my computer having problems?
No, I know it works. If you disable notifications for every app listed as "In Notification Center" and make sure they are all listed in "Not in Notification Center", you shouldn't receive any notifications.
__________________
15" 2011 MacBook Pro, 2.2 GHz i7 Quad, 8GB DDR3, 1GB Radeon HD 6750M, 1TB HDD; 32GB iPhone 5
Icy1007 is offline   0 Reply With Quote
Old Aug 4, 2012, 11:44 PM   #11
xkmxkmxlmx
Thread Starter
macrumors 6502a
 
xkmxkmxlmx's Avatar
 
Join Date: Apr 2011
Quote:
Originally Posted by Icy1007 View Post
No, I know it works. If you disable notifications for every app listed as "In Notification Center" and make sure they are all listed in "Not in Notification Center", you shouldn't receive any notifications.
Must be just my computer then (I know it isn't though).

I have them all unchecked. If I go in iCal and create a new event, or manually drag an event to another day, or my computer has been off or asleep since the next day change (went to sleep at 10pm on aug 1st and woke up at 3pm on Aug 2nd, for instance), the notifications will pop up no matter what is checked or unchecked.
xkmxkmxlmx is offline   0 Reply With Quote
Old Aug 5, 2012, 12:34 AM   #12
skeleb
macrumors member
 
Join Date: Jan 2011
Quote:
Originally Posted by xkmxkmxlmx View Post
I have them all unchecked.
Do you have them all listed under "Not in Notification Center?"
__________________
Late 2013 Retina MacBook Pro 13" 2.4/8GB/256GB, iPhone 4, iPad Mini 32GB WiFi
skeleb is offline   0 Reply With Quote
Old Aug 5, 2012, 01:31 AM   #13
iLog.Genius
macrumors 68040
 
iLog.Genius's Avatar
 
Join Date: Feb 2009
Location: Toronto, Ontario
If you scroll to the bottom of the left pane in Notifications, there's a section titled "Not in Notification Center". You need to drag whatever app you don't want to send you notifications and drag it under that section.
__________________
15.4" MacBook Pro 2.4GHz, 4GB RAM, WD Scorpio Blue 500GB HDD, GeForce 9400M + 9600M GT
iPad with Retina Display
iPhone 5S
iLog.Genius is offline   0 Reply With Quote
Old Aug 5, 2012, 05:05 AM   #14
Icy1007
macrumors 6502a
 
Join Date: Feb 2011
Location: Las Vegas, NV
Quote:
Originally Posted by xkmxkmxlmx View Post
Must be just my computer then (I know it isn't though).

I have them all unchecked. If I go in iCal and create a new event, or manually drag an event to another day, or my computer has been off or asleep since the next day change (went to sleep at 10pm on aug 1st and woke up at 3pm on Aug 2nd, for instance), the notifications will pop up no matter what is checked or unchecked.
Yes, that must be your computer then. I just tested this with Calendar (the new name for iCal) and made sure it was under the "Not in Notification Center" column and did the things you did and no notifications popped up.
__________________
15" 2011 MacBook Pro, 2.2 GHz i7 Quad, 8GB DDR3, 1GB Radeon HD 6750M, 1TB HDD; 32GB iPhone 5
Icy1007 is offline   1 Reply With Quote
Old Aug 5, 2012, 05:42 AM   #15
ixodes
macrumors 601
 
ixodes's Avatar
 
Join Date: Jan 2012
Location: Pacific Coast, USA
Quote:
Originally Posted by iLog.Genius View Post
If you scroll to the bottom of the left pane in Notifications, there's a section titled "Not in Notification Center". You need to drag whatever app you don't want to send you notifications and drag it under that section.
Somehow I missed that. Now that I followed your advice it killed off notifications. Thanks!
__________________
An Ultra Fast Mac Is...My Favorite
ixodes is offline   0 Reply With Quote
Old Aug 5, 2012, 12:58 PM   #16
xkmxkmxlmx
Thread Starter
macrumors 6502a
 
xkmxkmxlmx's Avatar
 
Join Date: Apr 2011
Quote:
Originally Posted by skeleb View Post
Do you have them all listed under "Not in Notification Center?"
Yes.

Quote:
Originally Posted by iLog.Genius View Post
If you scroll to the bottom of the left pane in Notifications, there's a section titled "Not in Notification Center". You need to drag whatever app you don't want to send you notifications and drag it under that section.
I know this. When you uncheck each selection, as has been suggested by every single person so far, they automatically go to the "not in notification center" group. You do not need to drag them.

Quote:
Originally Posted by Icy1007 View Post
Yes, that must be your computer then. I just tested this with Calendar (the new name for iCal) and made sure it was under the "Not in Notification Center" column and did the things you did and no notifications popped up.
I have recreated it on a friends computer as well. Also, I run into many threads online about it.

Maybe it is a bug that affects more than just mine. Oh well. Thank you for your help. I will submit it to Apple, I guess. Maybe consider doing a fresh install, but that would be tedious.
xkmxkmxlmx is offline   0 Reply With Quote
Old Aug 5, 2012, 01:06 PM   #17
Icy1007
macrumors 6502a
 
Join Date: Feb 2011
Location: Las Vegas, NV
Quote:
Originally Posted by xkmxkmxlmx View Post
Yes.



I know this. When you uncheck each selection, as has been suggested by every single person so far, they automatically go to the "not in notification center" group. You do not need to drag them.



I have recreated it on a friends computer as well. Also, I run into many threads online about it.

Maybe it is a bug that affects more than just mine. Oh well. Thank you for your help. I will submit it to Apple, I guess. Maybe consider doing a fresh install, but that would be tedious.
Try this on your computer. Go into system prefs and select Notifications. Select Calendar and make sure it is under "Not in Notification Center".

Also make sure that the Alert Style is selected as "None". Now go test your event creation/moving. There shouldn't be a banner or alert appear.
__________________
15" 2011 MacBook Pro, 2.2 GHz i7 Quad, 8GB DDR3, 1GB Radeon HD 6750M, 1TB HDD; 32GB iPhone 5
Icy1007 is offline   0 Reply With Quote
Old Aug 6, 2012, 12:57 AM   #18
kocoman
macrumors regular
 
Join Date: Dec 2007
What about disable notifications on System updates? thanks
kocoman is offline   0 Reply With Quote
Old Aug 6, 2012, 01:38 AM   #19
Icy1007
macrumors 6502a
 
Join Date: Feb 2011
Location: Las Vegas, NV
Quote:
Originally Posted by kocoman View Post
What about disable notifications on System updates? thanks
That's something I don't think you can disable.
__________________
15" 2011 MacBook Pro, 2.2 GHz i7 Quad, 8GB DDR3, 1GB Radeon HD 6750M, 1TB HDD; 32GB iPhone 5
Icy1007 is offline   0 Reply With Quote
Old Aug 6, 2012, 03:34 PM   #20
Freežinker
macrumors member
 
Join Date: Aug 2005
Location: northern Virginia
I'm having the same problem

I've done the trick of dragging the Mail app (the only app I use for Mail anyway) to "Not In Notification Center" from the above list, but I still keep getting notifications for Mail messages. I do not want to keep getting a notification from every single email that I receive from an institution. This is driving me nuts.
__________________
2009 Mac Pro, 2.66 GHz Quad-Core Intel Xeon, 16GB RAM, 2 x 3TB Hardrives, 120GB SSD
Freežinker is offline   0 Reply With Quote
Old Aug 6, 2012, 04:22 PM   #21
Hungry&Foolish
macrumors 6502
 
Join Date: Mar 2012
http://osxdaily.com/2012/08/06/disab...bar-icon-os-x/ Disable it completely.
Hungry&Foolish is offline   1 Reply With Quote
Old Aug 8, 2012, 07:25 AM   #22
Freežinker
macrumors member
 
Join Date: Aug 2005
Location: northern Virginia
Thanks for sharing this link. It works.

Quote:
Originally Posted by Hungry&Foolish View Post
Thanks for this. It took care of the problem completely.
__________________
2009 Mac Pro, 2.66 GHz Quad-Core Intel Xeon, 16GB RAM, 2 x 3TB Hardrives, 120GB SSD
Freežinker is offline   0 Reply With Quote
Old Aug 8, 2012, 05:25 PM   #23
xkmxkmxlmx
Thread Starter
macrumors 6502a
 
xkmxkmxlmx's Avatar
 
Join Date: Apr 2011
Quote:
Originally Posted by Hungry&Foolish View Post
Thank you. That worked perfectly.
xkmxkmxlmx is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
How do I turn off iCal notifications? Mildredop OS X 0 Nov 7, 2013 03:02 AM
Turn off notifications? c0venant iPad Tips, Help and Troubleshooting 3 Apr 21, 2013 08:16 AM
Resolved: How do I turn off push notifications? stonyboys iPhone 4 Oct 27, 2012 11:27 PM
Turn off update notifications? klaxamazoo OS X 10.8 Mountain Lion 0 Sep 21, 2012 05:36 PM
Mail Notifications, turn some off?? Jazwire OS X 10.8 Mountain Lion 5 Jul 21, 2012 09:14 PM

Forum Jump

All times are GMT -5. The time now is 07:09 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC