Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 3, 2012, 01:23 PM   #1
spaceballl
macrumors 68030
 
spaceballl's Avatar
 
Join Date: Nov 2003
Location: Silicon Valley
Mail still opens randomly....

My number one pet peeve from Snow Leopard is now back in Mountain Lion. I don't use OS X Mail. Something is triggering it to automatically open up... all the freaking time... sometimes it asks me to set up an account. Sometimes I think it's something from my calendar that triggers it. Any way to stop this from happening?
__________________
Travel Blog: Cloud Commuting | Technology Blog: Not Quite Mainstream | Cashback: BigCrumbs
spaceballl is offline   0 Reply With Quote
Old Aug 3, 2012, 01:33 PM   #2
fisherking
macrumors 68030
 
Join Date: Jul 2010
most email links (on websites, etc) will try to open Mail by default.
it's not a snow leopard or mountain lion issue.

you can change (in Mail preferences) your default reader...to something else.

what ARE you using for email? if you're doing it online, this is perfect...
__________________
mbp@10.10.2 5S@8.1JB
fisherking is offline   0 Reply With Quote
Old Aug 3, 2012, 01:35 PM   #3
spaceballl
Thread Starter
macrumors 68030
 
spaceballl's Avatar
 
Join Date: Nov 2003
Location: Silicon Valley
I just opened Mail to check, and Sparrow is set as my default mail client. I use Sparrow for e-mail, and I'll continue to use it for sometime... of course, with google buying sparrow, sigh......
__________________
Travel Blog: Cloud Commuting | Technology Blog: Not Quite Mainstream | Cashback: BigCrumbs
spaceballl is offline   0 Reply With Quote
Old Aug 3, 2012, 02:59 PM   #4
mikematzdorff
macrumors newbie
 
Join Date: Oct 2011
I think that the Calendar app is actually at fault.

I'm trying this...
http://www.maclife.com/article/howto...ips_and_tricks

look at the tip about calendar notifications.

I tried changing default mail client and a bunch of other stuff.

I hope this works.

I use gmail on the web and google cal as well.


Quote:
Originally Posted by spaceballl View Post
My number one pet peeve from Snow Leopard is now back in Mountain Lion. I don't use OS X Mail. Something is triggering it to automatically open up... all the freaking time... sometimes it asks me to set up an account. Sometimes I think it's something from my calendar that triggers it. Any way to stop this from happening?


----------

NOPE.

Sorry.



Quote:
Originally Posted by mikematzdorff View Post
I think that the Calendar app is actually at fault.

I'm trying this...
http://www.maclife.com/article/howto...ips_and_tricks

look at the tip about calendar notifications.

I tried changing default mail client and a bunch of other stuff.

I hope this works.

I use gmail on the web and google cal as well.
mikematzdorff is offline   0 Reply With Quote
Old Aug 3, 2012, 03:26 PM   #5
mikematzdorff
macrumors newbie
 
Join Date: Oct 2011
progress

it's def a calendar app thing.

I use "fantastical"

I made an entry in fantastical to send an alert and an email

I made another entry directly into google calendar

the fantastical entry(it puts the entry in the calendar program) queued mail to open

the gcal entry did not queue mail to open...

which sucks because i love fantastical.

anyway.

that worked for me.

good luck

Quote:
Originally Posted by spaceballl View Post
I just opened Mail to check, and Sparrow is set as my default mail client. I use Sparrow for e-mail, and I'll continue to use it for sometime... of course, with google buying sparrow, sigh......
mikematzdorff is offline   0 Reply With Quote
Old Aug 3, 2012, 05:10 PM   #6
mikematzdorff
macrumors newbie
 
Join Date: Oct 2011
Solved!!

I talked with a support person named Kent at Flexbits (fantastical)

He suggested fooling with this file to fix...

/System/Library/Frameworks/CalendarStore.framework/Versions/A/Resources/Mail.applescript

because I don't know code, I just moved it out of the directory, but still no fix. BUT, inside the same folder is a "scripts" folder with mail.scpt in it. I moved that file too and all is as it should be.

no calendar.app opening mail.app

not sure of repercussions, but I can always put it back.



Quote:
Originally Posted by spaceballl View Post
My number one pet peeve from Snow Leopard is now back in Mountain Lion. I don't use OS X Mail. Something is triggering it to automatically open up... all the freaking time... sometimes it asks me to set up an account. Sometimes I think it's something from my calendar that triggers it. Any way to stop this from happening?
mikematzdorff is offline   0 Reply With Quote
Old Aug 17, 2012, 12:23 AM   #7
spaceballl
Thread Starter
macrumors 68030
 
spaceballl's Avatar
 
Join Date: Nov 2003
Location: Silicon Valley
thanks for that tip, Mike... I just went ahead and renamed those files... let's see if Mail keeps opening or not. I really hope it works!
__________________
Travel Blog: Cloud Commuting | Technology Blog: Not Quite Mainstream | Cashback: BigCrumbs
spaceballl is offline   0 Reply With Quote
Old Aug 17, 2012, 03:49 AM   #8
nyolc8
macrumors regular
 
Join Date: Jul 2012
For me, Mail window sometimes shows up when OSX starts. "Hide" is checked for Mail in the Login items. Any idea?
nyolc8 is offline   0 Reply With Quote
Old Oct 4, 2012, 09:47 AM   #9
lepromatous
macrumors newbie
 
Join Date: Oct 2012
Try this

I had this same issue and fixed it by removing the apple mail from the notification center. To do this, open system preferences and click notifications. Remove the apple mail icon from the "In Notification Center" portion by unchecking the box "Show in Notification Center".
lepromatous is offline   0 Reply With Quote
Old Oct 4, 2012, 11:20 AM   #10
fat jez
macrumors 65816
 
Join Date: Jun 2010
Location: Glasgow, UK
when I had this, it was down to some calendar entries set to email me a reminder when an event was due.
__________________
'11 MBP 2.3GHz 16GB RAM 240GB SSD 15" Anti-Glare screen OS X 10.10.1
iPhone 6 128GB
fat jez is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mail opens up in iCloud inbox email first??? Imola Ghost iOS 7 5 Sep 26, 2013 11:28 AM
This is BIZARRE - Clicking bookmarked links opens Thunderbird mail app Mac_i_Am OS X 10.8 Mountain Lion 7 Apr 10, 2013 03:27 AM
Mail always opens last viewed message nStyle iOS 6 3 Jan 31, 2013 01:50 PM
iMovie '11 randomly opens capture window dandeco Digital Video 0 Jan 21, 2013 07:37 PM
Mail opens and automatically opens ALL emails! sungrrl Mac Basics and Help 1 Jul 2, 2012 01:11 PM

Forum Jump

All times are GMT -5. The time now is 05:03 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC