Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 5, 2012, 05:51 AM   #1
radu.valeriu
macrumors newbie
 
Join Date: Oct 2008
Location: Bucharest, Romania
ML no sound for new mail

Hello

Just updated to ML and now when I receive a new mail there's no sound playing! I just get the badge and the banner but no sound.

In System Settings / Notifications the settings for mail are "Badges, Sounds, Banners".

Anybody else came across this problem? Any advice?

Thanks
__________________
"I do not fear computers. I fear the lack of them." - Isaac Asimov
radu.valeriu is offline   0 Reply With Quote
Old Aug 5, 2012, 09:36 AM   #2
Weaselboy
macrumors G4
 
Weaselboy's Avatar
 
Join Date: Jan 2005
You have to pick the sound you want in the Mail app preferences, not in Notifications.
Weaselboy is online now   0 Reply With Quote
Old Aug 5, 2012, 10:15 AM   #3
kemo
macrumors 6502a
 
kemo's Avatar
 
Join Date: Oct 2008
isn't the sound picked up by default? I mean I was not setting any sound after installation/upgrading to ML and there was classic "Ding" (in ML its "New Message Sound") once email arrived.
__________________
~ http://tehkemo.com
~ AKG k701 + Nuforce Icon HDP
kemo is offline   0 Reply With Quote
Old Aug 5, 2012, 06:13 PM   #4
Weaselboy
macrumors G4
 
Weaselboy's Avatar
 
Join Date: Jan 2005
Quote:
Originally Posted by kemo View Post
isn't the sound picked up by default? I mean I was not setting any sound after installation/upgrading to ML and there was classic "Ding" (in ML its "New Message Sound") once email arrived.
I think on a default clean install there is a sound. But I do know from tinkering with ML, the Mail sound is set in Mail app prefs.
Weaselboy is online now   0 Reply With Quote
Old Aug 24, 2012, 10:17 PM   #5
dumboa
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by radu.valeriu View Post
Hello

Just updated to ML and now when I receive a new mail there's no sound playing! I just get the badge and the banner but no sound.

In System Settings / Notifications the settings for mail are "Badges, Sounds, Banners".

Anybody else came across this problem? Any advice?

Thanks
There are two solutions that work for me: Applescripts and Repair Permissions (this method need to be repeated overtime)

I. Applescript


The solution is to set a rule in Mail Preference to run an Applscripts if there is new email. This Applescript will play a notification sound of your choice:

tell application "Mail" to if (count of (every message of inbox whose read status is false)) isgreater than 0 then do shell script "afplay '/Applications/Mail.app/Contents/Resources/New Mail.aiff'"

You can change the path /Application/Mail.app/Contents/Resources/New Mail.aiff to any folder that containt an aiff file. For example: /System/Library/Sounds/Glass.aiff (in this folder you can find all the alert sounds of Mac OS)

Applescript Editor

1. Open Applescript Editor in Applications folder

2. Paste the script in after choosing your notification sound path

3. Save in ~/Library/Application Scripts/com.apple.mail (can name it New Mail in my example)

4. Now you can choose the script in Mail Rules setting

For the Mail rules setting

Open Mail Preferences then Rules then Add Rule. The setting like photo

https://www.sugarsync.com/pf/D8942998_67824332_008550

It works like a charm !!!


II. Repair Permissions


1. Quit Mail app

2. Go to Applications folder/Utilities/Disk Ultilities

3. Select Macintosh HD then Repair Dish Permissions

Wait for a couple of minutes, open Mail and try to send yourselft an email again (remember to off the rule to see effect). This method is need to be repeated overtime so I still prefer the Applescript method.
dumboa is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:55 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC