Go Back   MacRumors Forums > Special Interests > Visual Media > Web Design and Development

Reply
 
Thread Tools Search this Thread Display Modes
Old May 18, 2014, 06:29 PM   #1
datrandkidz
macrumors newbie
 
Join Date: May 2014
Troubleshooting Local Apache 404

http://mallinson.ca/post/osx-web-development/ -- trying to follow this guide (and comments for troubleshooting)

My system has an SSD (boot drive, applications, libraries, etc.) and an HDD for primary file storage (called "Storage"). I read through the comments and realized that since I'm using /Volumes/Storage/www rather than /www, I must make a couple changes in the httpd.conf (add path leading up to /ww) and httpd-vhosts.conf (change directory on lines 169 and 197) to match my directories.

Accessing localhost has been showing a "It works!" from the start. Before making these changes, I was receiving a 403 error when going to home.dev/ or *.dev/ for that matter. After making these changes, I seem to be receiving a 404 error instead. I tried adding a simple index.html in /Volumes/Storage/www/sites/home/wwwroot, but this didn't seem to help as the 404 remained. Note that I haven't gotten to the stage of using the local homepage script yet.

Here are the important files:
dnsmasq.conf -- http://pastebin.com/LtRc2Spb
hosts -- http://pastebin.com/0U0KEpAZ
httpd.conf -- http://pastebin.com/ZGGrY1Nn
httpd-vhosts.conf -- http://pastebin.com/xFzt0u4U
DNS Network Settings -- Attached PNG

Would someone provide (a) solution(s)? I'll test it and tell you if it worked, and we'll go on from there. Please respond ASAP. Need to get some projects up locally over the next few days.
Attached Thumbnails
Click image for larger version

Name:	Network Settings.png
Views:	29
Size:	71.0 KB
ID:	472889  
datrandkidz is offline   0 Reply With Quote
Old May 19, 2014, 08:06 AM   #2
JoelTheSuperior
macrumors member
 
Join Date: Feb 2014
Location: London, UK
Apologies in advance if I've missed something obvious but two main things I would check:
1. Is the storage volume mounted?
2. Does Apache have read/write access to the folder you're pointing it to?

Something you can test is just to make sure that the path works using Go -> Go To Folder in Finder.

It most certainly won't be a DNS issue or similar, it is most likely is just down to your Apache config.
JoelTheSuperior is offline   0 Reply With Quote
Old May 19, 2014, 12:34 PM   #3
datrandkidz
Thread Starter
macrumors newbie
 
Join Date: May 2014
1. I believe it is mounted. It's a 2nd hard drive (HDD). I have an HFS+ SSD boot disk and ExFAT HDD.

2. This is where I'm a bit confused. How would I check? Get info just says I can read and write in text without option to change as ExFAT works differently.'


How do my configuration files look?
datrandkidz is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Visual Media > Web Design and Development

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Front page got an error 404 sentiblue Site and Forum Feedback 2 Dec 15, 2013 01:01 PM
apache virtual hosts breaking apache ddragas OS X Mavericks (10.9) 1 Nov 30, 2013 10:54 AM

Forum Jump

All times are GMT -5. The time now is 09:25 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC