Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 6, 2012, 12:27 PM   #1
kirbyrun
macrumors newbie
 
Join Date: Jul 2009
Airplay icon comes and goes in ML

I have an Airplay-capable (mid-2011) iMac running ML. Airplay, though, only works intermittently, with the icon disappearing from the menubar for no apparent reason. When this happens, I check the Displays pref pane, which says "Airplay mirroring: No devices detected."

However my AppleTV (2nd gen) is on and connected to the wifi network. It shows up as an option in iTunes and shows up in Airport Utility. So it's there and it's on and receiving, but Airplay doesn't "see" it for some reason.

Then, randomly, it'll pop back up later.

AppleTV is connected wirelessly. iMac is connected by ethernet to the Airport base station.

Any ideas??? When the icon is in the menubar, everything works perfectly. But it just vanishes for long stretches of time for no reason!
kirbyrun is online now   0 Reply With Quote
Old Aug 9, 2012, 03:27 PM   #2
brueck
macrumors member
 
Join Date: Jun 2010
This happens to me too. I'm using a macbook pro retina and an apple tv 2nd gen. Sigh. Steve Jobs is dead.
brueck is offline   0 Reply With Quote
Old Aug 9, 2012, 09:34 PM   #3
Icy1007
macrumors 6502a
 
Join Date: Feb 2011
Location: Las Vegas, NV
It's because your Mac loses its connection to the AppleTV somehow.
Icy1007 is offline   0 Reply With Quote
Old Aug 9, 2012, 09:46 PM   #4
kirbyrun
Thread Starter
macrumors newbie
 
Join Date: Jul 2009
Well, yeah, sure -- I understand what you mean about losing the connection. But at the same time, iTunes still sees and can play to the AppleTV. So, the Mac hasn't TOTALLY lost the connection. It seems more like whatever specifically makes mirroring work loses track of the AppleTV while the Mac is sleeping and then can't recover...even though the rest of the OS can and does.

Oddly, it sometimes reappears after another sleep cycle, though there's no rhyme or reason to it. Is there maybe a Display preference file I can trash or something?
kirbyrun is online now   0 Reply With Quote
Old Aug 9, 2012, 09:52 PM   #5
Icy1007
macrumors 6502a
 
Join Date: Feb 2011
Location: Las Vegas, NV
Quote:
Originally Posted by kirbyrun View Post
Well, yeah, sure -- I understand what you mean about losing the connection. But at the same time, iTunes still sees and can play to the AppleTV. So, the Mac hasn't TOTALLY lost the connection. It seems more like whatever specifically makes mirroring work loses track of the AppleTV while the Mac is sleeping and then can't recover...even though the rest of the OS can and does.

Oddly, it sometimes reappears after another sleep cycle, though there's no rhyme or reason to it. Is there maybe a Display preference file I can trash or something?
iTunes could be using a different connectivity method than AirPlay. Like iTunes uses the wireless network and AirPlay connects ad hoc.
__________________
15" 2011 MacBook Pro, 2.2 GHz i7 Quad, 8GB DDR3, 1GB Radeon HD 6750M, 750GB HDD; 32GB iPhone 5
Icy1007 is offline   0 Reply With Quote
Old Sep 22, 2012, 11:14 AM   #6
BMNB1tch
macrumors regular
 
Join Date: Jan 2009
I have exactly the same issue word-for-word. I find that I have to enable WiFi on my iMac to guarantee the Airplay Mirroring icon is there

Only happened to me since 10.8.2. Very frustrating.
BMNB1tch is offline   0 Reply With Quote
Old Sep 24, 2012, 10:41 AM   #7
kirbyrun
Thread Starter
macrumors newbie
 
Join Date: Jul 2009
Quote:
Originally Posted by BMNB1tch View Post
I have exactly the same issue word-for-word. I find that I have to enable WiFi on my iMac to guarantee the Airplay Mirroring icon is there

Only happened to me since 10.8.2. Very frustrating.
I'll have to try going wireless with my iMac and see what happens. I've reported this as a bug to Apple with all three iterations of ML thus far. I hope they're working on it...

ETA: It's a very minor bug, true, but an annoying glitch in what was touted as a significant new feature.
kirbyrun is online now   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Tags
airplay mirroring, mountain lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:42 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC