Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 12, 2012, 05:01 AM   #1
L1mera1n
macrumors newbie
 
Join Date: Aug 2012
A minor annoying Apple tv mirroring issue. Anybody?

Lets start with this. I have an early macbook pro 2011 and the newest apple tv. I am able to mirror my macbook through my apple tv, but here is the issue.

My apple tv hibernate when not in use it (this is normal of course).
But when I wake it up from sleep mode, then suddenly Im not able to airplay anymore. The airplay icon is gone on my macbook pro. The icon only returns if i do the following.

I have to restart my apple tv and then, on my macbook pro I have to log off my wifi network, wait a few seconds, log back on, and then the airplay icon pops up ready to use.

This I have to do every time. Its frustrating. Anybody heard of this?

This is so unapplelike! But maybe its just me having this issue. Except for this Im a happy camper. But the airplay feature was the main reason I upgraded to ML.
L1mera1n is offline   0 Reply With Quote
Old Aug 12, 2012, 05:18 AM   #2
Ksh
macrumors member
 
Join Date: Jul 2012
Uhm didn't manage to reproduce the issue, checked now with mba 2012 and atv3, but since you have to renew de wifi session, ┐could not be related with your router settings?.

Just remind me a similar issue I had when multiple devices were connected to wifi network and some of them just woke up from sleep.Finally discovered there was an ip conflict (sleeping device always tried to to assign an existing ip when waking up) so solved using static ip's instead of dynamics Just give it a try,hope this helps.

Regards
Ksh is offline   0 Reply With Quote
Old Aug 13, 2012, 10:29 AM   #3
L1mera1n
Thread Starter
macrumors newbie
 
Join Date: Aug 2012
My biggest fear! Im no computer wiz but I tried to use static and force my mac and atv on the same ip, but no success. Its probably some router settings as you said. I always use standard settings when hooking up my router (d-link) I believe. Probably wouldn't be a problem if I had the Apple router. Hehe

Thanks for the reply
L1mera1n is offline   0 Reply With Quote
Old Aug 13, 2012, 12:25 PM   #4
lostless
macrumors 6502
 
Join Date: Oct 2005
Quote:
Originally Posted by L1mera1n View Post
My biggest fear! Im no computer wiz but I tried to use static and force my mac and atv on the same ip, but no success. Its probably some router settings as you said. I always use standard settings when hooking up my router (d-link) I believe. Probably wouldn't be a problem if I had the Apple router. Hehe

Thanks for the reply
You can't have 2 devices with the same ip address in a network. That will definitely make both devices not work.
lostless is offline   0 Reply With Quote
Old Aug 13, 2012, 02:30 PM   #5
L1mera1n
Thread Starter
macrumors newbie
 
Join Date: Aug 2012
Proves my stupidity. Haha. I have no clue what Im doing. Hoped it would work. Just dont know what Im doing wrong. The macbook and apple tv is on the same wifi and there's no airplay icon. Returns only if I do the above written "fix". Frustrating! Both devices are on dynamic ip by the way.
L1mera1n is offline   0 Reply With Quote
Old Aug 13, 2012, 04:18 PM   #6
Ksh
macrumors member
 
Join Date: Jul 2012
Uhm I'm afraid you tried in the opposite way hehe

Anyway before going further with network settings have a look to official Airplay troubleshooting

Regards.
Ksh is offline   0 Reply With Quote
Old Jun 6, 2013, 04:54 PM   #7
lj1722
macrumors newbie
 
Join Date: Jun 2013
Possible Solution

I have the same problem. I should say had. I believe I have solved it as well. I have a dual band router so it broadcasts 2 networks, one in 2.4 gHz and the second in 5 gHz. I gave them the same name for simplicity sake. Then devices will connect to whichever one they can and there is no guessing. While most of my devices are on the 5 gHz there are a few on the 2.4 gHz network as well. When the ATV3 would connect initially it would connect to the 5 gHz network. If something didn't connect to it than it would drop down to the 2.4 gHz apparently. As they are separate networks then my MBP couldn't see it. The solution is to rename the networks separately. Hope this helps.

Also, if you know how to enable port forwarding, that will speed up your ATV alot! For me the mirroring is almost instant once I set up port forwarding.
lj1722 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Issue with Airplay mirroring to Apple TV doubledge OS X Mavericks (10.9) 0 Oct 25, 2013 04:17 AM
Minor issue with jQuery function fig Web Design and Development 8 Mar 26, 2013 09:37 AM
Minor screen noob issue KhonNan MacBook Air 2 Feb 13, 2013 06:56 AM
AirPlay Mirroring Issue Rushli0n Apple TV and Home Theater 10 Oct 19, 2012 07:55 AM
Minor issue when Flash is full-screen Lenoxus OS X 0 Jun 20, 2012 10:28 PM

Forum Jump

All times are GMT -5. The time now is 12:35 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC