Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 1, 2012, 04:23 AM   #1
MiG123
macrumors newbie
 
Join Date: Aug 2012
Help: rMBP 650M GPU Throttling on BootCamp

Ok, i just got my spanking new rMBP as a portable gaming machine after hearing all the raves about its insane gaming hardware and in particular the highly clocked 650M.

Thus it came as a surprise that games, however smoothly and impressively they run initially, start to jerk and transition between different 'frame rate classes' after a while. For instance in GTA4, i could be cruising on the highway at 40fps and then have frames drop to 20fps for a few seconds before it coming back to a smooth 40fps again(a few secs later this will repeat). Once this 'mode' has been entered(which could be after anything from 10mins to hours of hard gaming), it'll annoyingly stick till the next reboot.

Thoroughly annoyed, I assembled all e gpu diagnostic tools i knew about and did some testing. As in e ss below, i believe i've pinpointed the problem down to GPU throttling even as i'm still unsure what's causing it.



As can be seen, clocks struggled to maintain at the 'advertised' 900mhz speed even for a while after the gpu intensive unigine bench was started. After a while we could see it starting to throttle between 900 and a couple of clock states below it(this could be the state where I witness 'jerking' in games), and finally stabilizing at a not-so-impressive 725mhz clock state.

All the while I've monitored cpu/gpu temps and they are all pretty much 'safe'(both don't go below 80deg). In fact, looking at the log, it seems throttling occured when temps were at their lows, thereby ruling out any temperature related cause.

All in all, I'm amazed that there are others on this forums and the internet who've managed to massively overclock(one even reach an insane 1200/17xx) and reach bench-stable states on this card even as mine is struggling at stock clocks. Perhaps this could be a unique defect with my set or a personal setting/config gone wrong somewhere.

Would be great if the macrumors community could assist in helping me nail down the root cause of this crippling defect, and avoid me having to lug the set down to the store and argue my case.
MiG123 is offline   0 Reply With Quote
Old Sep 1, 2012, 04:34 AM   #2
BB.King
macrumors regular
 
Join Date: Jun 2012
Location: London UK
I've been playing Civilization V for the last week without any problems. Using GPU-Z, the 650m is running at full speed (900MHz/2000MHz).

Why don't you download that tool and use the log option to see if your GPU is working properly.

By the way, GTA4 is widely known to run poorly on PC, so I'd not use that game as a benchmark. I can't get the fps over 40 with with desktop computer at 1900X1200 using HD7950.

P.S. You are playing the game with the machine plugged in to the main power and have good ventilation right?
Attached Thumbnails
Click image for larger version

Name:	Capture.PNG
Views:	120
Size:	41.9 KB
ID:	355382  
BB.King is offline   0 Reply With Quote
Old Sep 1, 2012, 04:41 AM   #3
Serelus
macrumors Demi-God
 
Serelus's Avatar
 
Join Date: Aug 2009
Location: Vm9pZA
You used the bootcamp drivers didn't you? in that case. It's a common problem with MacBook Pro's.
I had it with my 13" and now with my retina 15"

Apple basically provides drivers for the windows version of the 650m, which is weird Apple has a modified 650m build into the rMBP, though only used properly in Mac OS X.

Therefore, you have to modify some infs to make your card work properly in Windows. Laptopvideo2go does this for you:

http://laptopvideo2go.com/drivers/win7x64/305.53

All you have to do is download them and install them, and you're done. Make sure you choose a "clean/fresh install".
Serelus is offline   0 Reply With Quote
Old Sep 1, 2012, 05:00 AM   #4
BB.King
macrumors regular
 
Join Date: Jun 2012
Location: London UK
I'm using the stock Bootcamp driver for the 650m, didn't have to modify any config files.
BB.King is offline   0 Reply With Quote
Old Sep 1, 2012, 05:25 AM   #5
leman
macrumors 68040
 
Join Date: Oct 2008
Just install the latest Nvidia Beta driver, it supports 650m out of box, no modified inf required. Really improves the performance for me.
leman is offline   0 Reply With Quote
Old Sep 1, 2012, 05:56 AM   #6
MiG123
Thread Starter
macrumors newbie
 
Join Date: Aug 2012
@ serelus, leman:

I'm currently using the latest beta drivers 306.02 direct from nvidia, which natively support the 650m and requires no modded inf. Regardless, I've noticed this issue on the stock bootcamp drivers as well.

@ BBKing:

I see ur chip is working without a glitch! congrats and i very much envy it.

anw, gta4 was used just as an example of a demanding game tat easily causes my chip to throttle. In actual fact, I've been noticing this phenomenon across an entire spectrum of games, even in a low taxing game like FIFA12. The jerking is quite obvious even at high fps as it feels like going slow-mo for a few secs.

and yeap i always have it connected to the mains with battery at 100%...

PS: I'm currently in the process of reinstalling bootcamp from scratch in order to rule out any OS or driver faults. Will report back in a couple of hours once that's done...
MiG123 is offline   0 Reply With Quote
Old Sep 1, 2012, 06:19 AM   #7
BB.King
macrumors regular
 
Join Date: Jun 2012
Location: London UK
Quote:
Originally Posted by MiG123 View Post
@ BBKing:

I see ur chip is working without a glitch! congrats and i very much envy it.
Not really, the memory on the 650m can go up to 2500MHz, but I only seen it at start of a game, then it drop down to 2000MHz again.

Hope you have better luck with the re-install.
BB.King is offline   0 Reply With Quote
Old Sep 1, 2012, 10:40 AM   #8
Dyno-Mike
macrumors regular
 
Join Date: Aug 2012
Location: United Kingdom
I have this issue too. But mine seems to be related to the CPU. If i disable turbo on the CPU then games run smoothly and their is no downclocking on the GPU.

Try running Furmark and set affinity to 1 core and use throttlestop to watch the CPU CO% fluctuate every few seconds whilst its running. Everytime the CPU CO% drops, Furmark will stutter briefly. Disable CPU turbo boost and this does not happen.
__________________
Macbook Pro Retina - 2.3/8/256
Dyno-Mike is offline   0 Reply With Quote
Old Sep 1, 2012, 11:23 AM   #9
neostradamus
macrumors newbie
 
Join Date: Aug 2012
How do you disable the turbo?
neostradamus is offline   0 Reply With Quote
Old Sep 1, 2012, 12:04 PM   #10
Dyno-Mike
macrumors regular
 
Join Date: Aug 2012
Location: United Kingdom
You can disable it with throttlestop or you can go to your windows power options, change your current plan settings, click the advanced section, expand the Processor Power Management section, click the Maximum Processor State, and change it to something other than 100% like 95%.

I have my balance proflie set to this so i can switch between high performance (TB enabled) or balanced (TB disabled) easily
__________________
Macbook Pro Retina - 2.3/8/256
Dyno-Mike is offline   0 Reply With Quote
Old Sep 1, 2012, 03:34 PM   #11
DTKblaster
macrumors member
 
Join Date: Aug 2012
Don't let the GPU hit 78 degrees.

Disable turbo (throttle stop).

Max out the fans manually with Lubbosfancontrol (this happens anyway in games, just retardedly slow, so just do it manually to stop early throttling).

Repaste the CPU/GPU with decent paste.

If you want, you can also force P1 in nvidia inspector by making a text file containing "nvidiaInspector.exe -forcepstate:0,1 " and then making it a .bat file and running it in the same folder as the nvidia inspector exe. (this won't get around the temperature based throttling)

(to make a .txt into a .bat in windows 7; open a folder, press alt to reveal the menu, then go tools -> folder options -> view tab -> uncheck "hide known file extentions". Now you can rename the file extention from .txt to .bat)
DTKblaster is offline   0 Reply With Quote
Old Sep 1, 2012, 11:49 PM   #12
njean777
macrumors 6502
 
Join Date: Oct 2009
I have never had this problem, maybe your video card is defective. If anything I would download speedfan and make sure it is not overheating.
njean777 is offline   0 Reply With Quote
Old Sep 2, 2012, 10:58 AM   #13
Suika
macrumors newbie
 
Join Date: Sep 2012
I've been having this problem on any games and on OSs. (I am having mid 2012 model 15.4")

I've tried to play Diablo 3 on both MAC and Windows 7 Ultimate (bootcamp) but it still gives me the same lags every 2-3 seconds no matter where I am or on any setting. Even on some games like Team Fortress 2, Battlefield 2: Bad Company, War of Immortals (actually just wanted to see if I can run it better), Gotham Impostors, pcsx2 game like Persona 3 FES, it still gives me lag every 2-3 seconds If you are talking about my network issue then I can assure you it's NOT. When I looked up into some youtube videos I saw all the guys with older hardware could play games without any lag at all

I also tried many methods as this thread provides like power management, update driver to 306.02, windows updates but the problem never changes. I wonder what is going wrong with my MPR since I only bought it 4 days ago and my technical support didn't help me much at all (there is a guy tried to tell me to get a 64-bits Diablo III!?) and I'm considering to change my MPR to another one.

I admit that I don't really have much knowledge about notebook gaming but what I should know is my mid 2012 MPR 15" (and 650m) could play at least most of games (even on lowest setting) without lagging every 2-3 seconds, right?



This is what GPU-Z sensors tells me the condition of my cpu. As you compare to BB.King's you can see that mine didn't use much power at all and it stills gives me lag every 2-3 seconds on any games I've played.

Edit: I forgot to mention that my MPR is non-Retina display

Last edited by Suika; Sep 2, 2012 at 11:17 AM.
Suika is offline   0 Reply With Quote
Old Sep 2, 2012, 11:02 AM   #14
gentlefury
macrumors 68030
 
Join Date: Jul 2011
Location: Los Angeles, CA
Crysis 2 is the only game I've had throttling on. It goes from 900mhz to 750mhz.....I am going to try throttle stop.
gentlefury is offline   0 Reply With Quote
Old Sep 2, 2012, 11:26 AM   #15
5bjoshua
macrumors newbie
 
Join Date: Sep 2008
Can't say i've had any throttling on my uMBP 650m clocked to 900/2500.

Max temperature the GPU gets too is 80*C.

Then again though, I'm forcing powerstates in nvidiainspector.
5bjoshua is offline   0 Reply With Quote
Old Sep 2, 2012, 01:32 PM   #16
Suika
macrumors newbie
 
Join Date: Sep 2012
This is really weird because I didn't temper with any overclock and even my gpu didn't even hit 900mhz just as you guys saying but my MBP still lags like something is trying to prevent it?
Suika is offline   0 Reply With Quote
Old Sep 3, 2012, 03:18 PM   #17
MagnusB
macrumors newbie
 
Join Date: Jul 2012
I took my rmbp to the apple store and let the people there to take a look at it. They had never heard of the problem. Neither had the people from the apple.com service. So they started testing it in the store and found that something was wrong with the motherboard. They repaired it, but it didn't fix the problem. So i delivered it back to let them test it again. Hopefully they will find a new problem now. In my case i think the problem is in the graphics card or the thermal paste. Because it doesn't downclock until the temperature hits 97 C
MagnusB is offline   0 Reply With Quote
Old Sep 3, 2012, 11:57 PM   #18
ninja2000
macrumors regular
 
Join Date: Dec 2010
Quote:
Originally Posted by Suika View Post
This is really weird because I didn't temper with any overclock and even my gpu didn't even hit 900mhz just as you guys saying but my MBP still lags like something is trying to prevent it?
The mbpc has lower clocks than the retina. Your clocks are correct.
You can force higher clocks using nvidia inspector
ninja2000 is offline   0 Reply With Quote
Old Sep 4, 2012, 12:40 PM   #19
ibebyi
macrumors member
 
Join Date: Aug 2009
Hi there. I was messing with nvidiainspector and made a little discovery which may help with your issues.

OK, when the 650m is put under load, you'll notice the voltage get's pushed up to 1.037mV from .987mV(? working off memory) in nVidiainspectors monitor.

However, I noticed something interesting. If you force the card into P2 state, it operates a little differently. I made a simple .bat file with the following text in the nvidiainspector.exe's folder:

nvidiaInspector.exe -setGpuClock:0,2,900 -setMemoryClockOffset:0,0,300 -setMemoryClock:0,2,2800 -forcepstate:0,1 -setBaseClockOffset:0,0,135

When I executed this, I noticed that the idle voltage for the card was now locked at .950mV. The really interesting part was that when I put the GPU under stress (ie gaming), the card actually lowered its voltage to .925mV, resulting in a pretty large undervolt. This may give you enough thermal headroom to game without too many hiccups.
You may want to give this a try.

P.S. You can increase -setGpuClock:0,2,900 to 1000, which will lock the voltages at 1.025/1.000mV idle/load respectively. This is still a .037mV undervolt + 100mhz gain.

Hope this helps.

Last edited by ibebyi; Sep 4, 2012 at 09:46 PM.
ibebyi is offline   0 Reply With Quote
Old Sep 4, 2012, 01:20 PM   #20
Dyno-Mike
macrumors regular
 
Join Date: Aug 2012
Location: United Kingdom
Quote:
Originally Posted by ibebyi View Post
nvidiaInspector.exe -setGpuClock:0,2,900 -setMemoryClockOffset:0,0,300 -setMemoryClock:0,2,2800 -forcepstate:0,1 -setBaseClockOffset:0,0,135

Hope this helps.
This sounds interesting and certainly worth a try.

How do we return this back to defaults?
__________________
Macbook Pro Retina - 2.3/8/256
Dyno-Mike is offline   0 Reply With Quote
Old Sep 4, 2012, 09:42 PM   #21
ibebyi
macrumors member
 
Join Date: Aug 2009
Quote:
Originally Posted by Dyno-Mike View Post
This sounds interesting and certainly worth a try.

How do we return this back to defaults?
I usually use two profiles (through .bats); one for overclock/gaming, and one for idle/web surfing/movies.

For idle you make a simple .bat with:

nvidiaInspector.exe -forcepstate:0,8

This drops the clocks to 405core/419mem @ 837mV in P8 state (idle state). Movies in 1080p both stored locally and viewed over the internet played just fine for me at these clocks (and terraria played just fine @ 1920x1200). A bonus that I observed was that the computer stayed MUCH cooler.

OH, and Throttlestop is your friend

Last edited by ibebyi; Sep 4, 2012 at 09:48 PM.
ibebyi is offline   0 Reply With Quote
Old Sep 5, 2012, 03:06 AM   #22
dusk007
macrumors 68030
 
Join Date: Dec 2009
The Op seems to be under the impression that 900Mhz ist default and anything below is throttling.

725Mhz is the default clock speed of the 650M with GDDR5.
900 Mhz is the Boost aka Turbo and how much it boosts depends on the workload.

Quote:
As for deciding what clockspeed to step up to, GPU boost determines this based on power consumption and GPU temperature. NVIDIA has on-card sensors to measure power consumption at the rails leading into the GPU, and will only allow the video card to step up so long as it’s below the GPU Boost power target.
GTA4 apparently simply consumes too much. Also the quality of the DIE plays a part. As it measures outside the chip the real power consumption some that got a cold chip will get better Turbo out of it than those with slightly hotter chips. Much the same as some can overclock higher with out problems than others. Also since according to Anandtech power consumption is measured, better cooling won't change too much about it. Heat has some impact on power consumption but only some.

Read up on Trubo boost.
http://www.anandtech.com/show/5699/n...x-680-review/4

What you are experiencing is not throttling just not as great Turbo speeds.


If you don't want to deal with all this just over clock the chip. Adjusting the power target would really be the way to go. I don't have a 650M notebook but maybe some notebook over clocking tools allow it already like on the Desktop. Otherwise just set some custom fixed over clock as suggested, as long as heat stays reasonable and the power supply + battery can handle it.
dusk007 is offline   0 Reply With Quote
Old Sep 8, 2012, 11:30 AM   #23
imperialnavy
macrumors regular
 
Join Date: Jul 2009
When GPU Z shows that 900MHz is the default, then it should indeed be the default and not the turbo boost, right? (Talking about the Retina here)

If i understood all of the discussion right, then you can overcome the whole problem with setting the p states via Nvidia Inspector, right?

What about after gaming? Will it automatically go back to some lower clock?
(If its not heavily used)

Also, could somebody please explain me what exactly this p0,p5, p8 states and so on mean?
imperialnavy is offline   0 Reply With Quote
Old Sep 9, 2012, 02:54 AM   #24
ninja2000
macrumors regular
 
Join Date: Dec 2010
Quote:
Originally Posted by imperialnavy View Post
When GPU Z shows that 900MHz is the default, then it should indeed be the default and not the turbo boost, right? (Talking about the Retina here)

If i understood all of the discussion right, then you can overcome the whole problem with setting the p states via Nvidia Inspector, right?

What about after gaming? Will it automatically go back to some lower clock?
(If its not heavily used)

Also, could somebody please explain me what exactly this p0,p5, p8 states and so on mean?
OK, 900mhz is the default clock but if left to its own devices it seems to use lower clocks if gpu usage are low.

And yes, correct, locking the P-state with nvidia inspector stops the clocks dropping unless you get some seriously high temps (like 100c).

After gaming the clocks will remain at what you set them at as you have locked the P-state. What I do is create a few nvidia inspector shortcuts on my desktop with different clocks so I can change them myself depending on what I am doing.

Finally, the P-states are what nvidia uses to set clocks for your applications (i.e. desktop use, low power 3d and full power 3d etc).
ninja2000 is offline   0 Reply With Quote
Old Sep 9, 2012, 04:00 AM   #25
imperialnavy
macrumors regular
 
Join Date: Jul 2009
Quote:
Originally Posted by ninja2000 View Post
OK, 900mhz is the default clock but if left to its own devices it seems to use lower clocks if gpu usage are low.

And yes, correct, locking the P-state with nvidia inspector stops the clocks dropping unless you get some seriously high temps (like 100c).

After gaming the clocks will remain at what you set them at as you have locked the P-state. What I do is create a few nvidia inspector shortcuts on my desktop with different clocks so I can change them myself depending on what I am doing.

Finally, the P-states are what nvidia uses to set clocks for your applications (i.e. desktop use, low power 3d and full power 3d etc).
Would it also be possible to lets say create a shortcut to switch between locking (overclocking it to 1200/1600) and unlocking (and thus having lower clocks after gaming)?
There is no way that this would happen automatically is there?
imperialnavy is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
How to Prevent rMBP GPU from Throttling in BootCamp? applepie555 MacBook Pro 5 Jun 20, 2014 11:33 AM
Mid 2012 Macbook Pro 15" GT 650m Throttling in Bootcamp macassassin MacBook Pro 9 Jun 20, 2014 11:18 AM
HELP! rMBP GPU throttling down to 65MHz opra2014 MacBook Pro 0 May 24, 2014 11:38 AM
2012 MBP Retina - Bootcamp GPU throttling.. dingobiatch MacBook Pro 0 May 11, 2014 07:07 PM
2012 rMBP Extreme GPU Throttling? bioyuki MacBook Pro 7 Aug 23, 2013 10:22 PM

Forum Jump

All times are GMT -5. The time now is 04:19 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC