Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 13, 2012, 05:44 AM   #1
KeanosMagicHat
macrumors 6502a
 
Join Date: May 2012
Unhappy Problem - Missing Album Artwork with iTunes 10.7 & iOS 6 GM

99% of my album artwork is not syncing after the upgrade - does anyone know of a quick and easy solution to this please?

Apologies for this long winded description, but I figure if someone can help, it's best to have all the facts.

So, I was able to upgrade my iPhone 4S to iOS 6 GM seemingly without issue.

I also upgraded iTunes to 10.7

By the time I'd finished this & had a look around some of the new features, it was already past 2am here in the UK.

Unfortunately, I didn't notice until I was about to go to sleep that 99% of my music was not on the iPhone.

I have ripped (almost) my entire CD music collection into iTunes, which is almost 5000 tracks. There are a few in the library that I don't want to sync, so a long time ago I created a smart playlist called, "iPhone" with some rules which isolated the tracks I didn't want and captured the rest. It auto updates as I add new music.

Anyway, I hadn't manually deselected the playlist, but when I checked this morning, sure enough it was unchecked. No problem I thought and re-synced with the playlist now checked.

This brought over all of the tunes I want to sync, 4887 in total.

Unfortunately, all of the album artwork is missing.

It is in the iTunes library (thankfully) and strangely, when I access the music folder of my iPhone when connected to iTunes and "Get Info" on any of the tracks the artwork shows up there too.

I've tried for the past 90 mins+ to search for a solution and whilst I've found others that had the issue with the move to iOS 5, I can't find any definitive solution.

Can anyone help please?

Cheers.

Last edited by KeanosMagicHat; Sep 13, 2012 at 12:31 PM. Reason: Added Resolved prefix
KeanosMagicHat is offline   0 Reply With Quote
Old Sep 13, 2012, 06:37 AM   #2
alexryans
macrumors newbie
 
Join Date: Nov 2010
I've had this problem since at least iTunes 10.3, and it still hasn't been fixed, even after filing multiple bug reports with Apple.

Do you by any chance have your iTunes converting higher bitrate songs to AAC when putting them on your iOS devices? According to various forums and threads up and down the Internet, this is the problem - unchecking this preference *should* get rid of the issue, but I find I can't fit half as much music on my iPhone if I do this.

I really, really hope this is fixed in iTunes 11, or else I'll be seriously annoyed!
alexryans is offline   0 Reply With Quote
Old Sep 13, 2012, 06:52 AM   #3
KeanosMagicHat
Thread Starter
macrumors 6502a
 
Join Date: May 2012
Quote:
Originally Posted by alexryans View Post
Do you by any chance have your iTunes converting higher bitrate songs to AAC when putting them on your iOS devices?
Sorry to hear that you've had this issue for a long time. It's a first for me after owning the iPhone 3, 3GS and now 4S.

I had read in my research this morning of others believing they had resolved the issue by deselecting the down conversion option you mention, but I've never had that enabled - so it's not the resolution for me unfortunately.

It's disappointing when you have a tech issue and there seems to be no set solution for everyone.

Hopefully someone on the forum will be able to fix this for both of us (and any others affected).
KeanosMagicHat is offline   0 Reply With Quote
Old Sep 13, 2012, 07:27 AM   #4
scottytwo
macrumors member
 
Join Date: Sep 2012
folder relocations.

Quote:
Originally Posted by KeanosMagicHat View Post
Sorry to hear that you've had this issue for a long time. It's a first for me after owning the iPhone 3, 3GS and now 4S.

I had read in my research this morning of others believing they had resolved the issue by deselecting the down conversion option you mention, but I've never had that enabled - so it's not the resolution for me unfortunately.

It's disappointing when you have a tech issue and there seems to be no set solution for everyone.

Hopefully someone on the forum will be able to fix this for both of us (and any others affected).
I can vaguely recall a couple of instances after itunes updates where jbreakers have had issues locating folders after genuine updates.. sometimes they have relocated folders in the newer versions.

having just put my itunes media into a shared folder location (wife n I run separate accounts on the mac @ home), some of my artwork has gone walkabout.

Perhaps have a poke around in explorer / finder and check to see if folders have changed for Album artwork, and consolidate your library by selecting the artwork folder and re dragging it into your specified "itunes media library".

Then try File / Add To Library / *folder where your combines media is kept*

this should get everything into place. if you have duplicates, run singlemizer.
Damm I wish apple would sort this out. Can be such a pain in the ass.
scottytwo is offline   0 Reply With Quote
Old Sep 13, 2012, 10:08 AM   #5
KeanosMagicHat
Thread Starter
macrumors 6502a
 
Join Date: May 2012
Thank you scottytwo, I will look into that.

In the meantime, I thought I'd post an update.

I'd seen a couple of threads on other forums and Apple Support where owners believed they'd resolved the problem by unchecking the Music sync option to remove all the tunes from the phone and sync again. Despite the time consuming nature of this, I did it again.

Anyway, as I was waiting for the transfer of 4800+ tracks, I remembered something that used to happen on my old 3G which had less tracks given the smaller capacity.

If I tried to open the iPod app, as I think it was called then, soon after a sync it would come up saying Updating Library.

Within a few minutes it was working.

Here's an old thread about it;

http://forums.macrumors.com/showthread.php?t=766624

I decided to leave this phone for 20 minutes after syncing to see if it made a difference. It ended up being 45 mins as I was busy with something else.

I don't know whether it's coincidence at this stage, but I now have artwork for all of the artists up to "M".

Nothing has appeared since however.

If I can't find an alternative fix today, I will probably remove the music (yet again) and re-sync before I go to bed tonight and then leave it until morning.
KeanosMagicHat is offline   0 Reply With Quote
Old Sep 13, 2012, 12:23 PM   #6
KeanosMagicHat
Thread Starter
macrumors 6502a
 
Join Date: May 2012
Thumbs up Success !!!!

Quote:
Originally Posted by KeanosMagicHat View Post
.... Anyway, as I was waiting for the transfer of 4800+ tracks, I remembered something that used to happen on my old 3G which had less tracks given the smaller capacity.

If I tried to open the iPod app, as I think it was called then, soon after a sync it would come up saying Updating Library.

Within a few minutes it was working.

Well it could be that I was onto something here, as I've managed to resolve my situation.

I decided there wasn't much to lose by syncing again and it started to transfer the tracks (again) but only those for artists from M onward which were missing the artwork after the previous sync above.

I repeated the process of leaving the phone after the sync, this time for 45 minutes.

When I opened up the Music app, all of the tunes & associated artwork were there.

If it is an issue with larger music libraries similar to the "Updating Library" message I used to get way back on the iPhone 3G, then I wish Apple hadn't removed the alert to that effect.

Anyway, I hope that is the explanation and that this thread helps others.

My recommendation, should anyone find themselves in this position would be to remove all the music from their iPhone, sync it back just before you go to bed - make sure the sync completes and then leave the phone alone whilst you sleep.

Providing you have all of the artwork in your PC / Mac iTunes library, I'd be surprised & disappointed if it wasn't all back to normal on the phone when you awaken.


@ alexryans - As I mentioned all of my music is in full MP3 format rather than aac, but perhaps you should give this another go - good luck.

Last edited by KeanosMagicHat; Sep 13, 2012 at 12:28 PM.
KeanosMagicHat is offline   0 Reply With Quote
Old Sep 23, 2012, 03:47 AM   #7
Foubister217
macrumors newbie
 
Join Date: Sep 2012
Got it!

i have found a fix go on to itunes clear the album art work for the album that is not showing up on iOS device sync it across to iOS device then add album art work and sync again should fix it.
Foubister217 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Simple Fix: missing or incorrect iTunes Match artwork on iOS device JGCode3 iCloud and Apple Services 0 Oct 15, 2013 03:09 PM
iTunes 11 (Album Artwork Gone Except One Song Per Album) leerkeller Mac Applications and Mac App Store 0 Jan 29, 2013 12:19 PM
Missing movie album artwork solved JoeBlow74 Mac Applications and Mac App Store 5 Dec 11, 2012 07:20 AM
iTunes has artwork, phone has been synced - iOS still missing artwork petrucci666 iOS 6 19 Nov 17, 2012 08:10 PM

Forum Jump

All times are GMT -5. The time now is 12:04 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC