Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 19, 2012, 06:12 PM   #51
saxman211
macrumors member
 
Join Date: Jun 2010
I'm guessing this is why my home sharing isn't working after the update?
saxman211 is offline   0 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #52
FourOhFour
macrumors member
 
Join Date: Jul 2011
Quote:
Originally Posted by WordMasterRice View Post
Why the **** are my devices going to an apple website when I connect to my local wifi in the first place?
It's checking to see if the wifi has an internet connection or if it is a captive portal you need to log in to. If the wifi requires a log in, it shows the page it redirects you to even if you aren't in a web browser. Before they added this, you'd be trying to figure out why your app isn't working until you tried safari and got the login page there.

Looks like the server it connects to to test the connection is broken.
FourOhFour is offline   4 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #53
austinguy23
macrumors 6502a
 
Join Date: Oct 2008
Same thing here. iOS 6 and AirPort Extreme.

So many people are experiencing this. How could this have slipped past QA Testing?

Last edited by austinguy23; Sep 19, 2012 at 06:24 PM.
austinguy23 is offline   0 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #54
ejdmoo
macrumors newbie
 
Join Date: Oct 2009
The following page on apple.com is down:

http://www.apple.com/library/test/success.html

This is what iOS uses to detect if you're behind a "captive network." I guess it thinks everyone is behind a non-internet-reachable network right now, so it disconnects.
ejdmoo is offline   5 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #55
dmrowley
macrumors regular
 
Join Date: Aug 2010
Location: Dortches, NC
Yep, same here on iPad 2.... WTF?
__________________
2013 27" iMac i5 3.2Ghz, 16Gig Ram, 3TB Fusion Drive
128G Silver iPhone 6
32G iPad 4
Canon EOS 60D, Canon 24-105 f/4 L, Tokina 11-16 f/2.8 DX II
dmrowley is offline   0 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #56
dead_smed
macrumors newbie
 
Join Date: Jan 2004
I'm also getting this problem on an iPod touch 4th generation. I think I'll hold fire on upgrading my other devices until this has been resolved. Glad I'm not the only one.
dead_smed is offline   0 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #57
Tom2893
macrumors 6502
 
Join Date: May 2012
Location: United Kingdom
same here.. takes me to an unknown apple page
__________________
iPhone 5S 16GB / iPad mini 16GB / MacBook Pro 13" mid 2012
Tom2893 is offline   0 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #58
Kristijan
macrumors member
 
Join Date: Aug 2007
Location: Melbourne, Australia
Same thing happening here

-Kristijan
Kristijan is offline   0 Reply With Quote
Old Sep 19, 2012, 06:12 PM   #59
tpm1999
macrumors member
 
Join Date: Sep 2009
My iPhone 4 just started this too! My iPad 3 is so far unaffected.
tpm1999 is offline   0 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #60
jsadwith
macrumors newbie
 
Join Date: Dec 2007
Happening to everyone in our office that upgraded. We noticed that the phone makes a request to http://www.apple.com/library/test/success.html right before kicking the message. Not sure if it's related, but there's definitely something funky there.

Edit - wow, yea, earlier, we noticed that this file was returning text that said "Success", and now it's returning a 404 page. We're thinking it's some request to see if there is network connectivity or something, and since it's no longer returning "Success", it's causing this WiFi issue.

Edit #2 - Yep - just what we thought. Check this post from 2010: http://erratasec.blogspot.com/2010/0...r-request.html
jsadwith is offline   1 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #61
recharge23
macrumors regular
 
Join Date: Mar 2012
Location: Seoul, South Korea
happening to me too on my 4s. waiting to see what happens on my ipad 3 after it downloads.
__________________
computer: 15-inch rmbp | 2.3 | 16gb | 256gb
tablet: black iPad 3 | 32gb -- nexus 7 | 16gb
phone: white iPhone 4s | 16gb | sk telecom
recharge23 is offline   0 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #62
Tony L
macrumors newbie
 
Join Date: Jul 2011
Same here on iPhone 4S. Need to figure out how to back-out to iOS 5 now...
Tony L is offline   1 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #63
stepheneleven
macrumors member
 
Join Date: Oct 2008
Same here. On the new iPad. Wtf apple.
stepheneleven is offline   1 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #64
GraphicsGeek
macrumors 6502a
 
Join Date: Sep 2008
Happening here too. Which is weird because I installed it yesterday and it was working on my home wifi just fine. But all of a sudden today, I get home and this happens.
GraphicsGeek is offline   0 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #65
kushari
macrumors newbie
 
Join Date: Sep 2009
I am having the same problem, really annoying.
kushari is offline   0 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #66
crisss1205
macrumors 6502a
 
crisss1205's Avatar
 
Join Date: Oct 2008
Location: Long Island, New York
Send a message via AIM to crisss1205
Quote:
Originally Posted by ejdmoo View Post
The following page on apple.com is down:

http://www.apple.com/library/test/success.html

This is what iOS uses to detect if you're behind a "captive network." I guess it thinks everyone is behind a non-internet-reachable network right now, so it disconnects.
I came here exactly to post that link.
Does anyone know if iOS 5 uses the same file and if iOS 5 devices are also having the problem?
__________________
 27" iMac  13" Retina MacBook Pro  iPhone 5s  iPad mini
crisss1205 is offline   1 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #67
ituleb
macrumors newbie
 
Join Date: Sep 2012
Same issue here - did a cursory google search and this problem is popping up all over the place. Hopefully there is a fix soon - I literally cannot connect/stay connected to any Wifi network.
ituleb is offline   0 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #68
ssanders79
macrumors member
 
Join Date: Mar 2009
Location: Tampa, Fl
Question

iPad 2 - OK
iPhone 4 - OK
iPhone 4S - Not connecting to wifi (goes to apple.com login page)

coincidentally, this is the order I updated the devices.
__________________
Scott
MacBook Pro | iPhone 5 32GB Black | iPad 2 WiFi+3G | iPhone 4 32GB & iPhone 3G as iPod Touches
ssanders79 is offline   0 Reply With Quote
Old Sep 19, 2012, 06:13 PM   #69
bigchrisfgb
macrumors 6502a
 
Join Date: Jan 2010
Yeah I'm getting this as well.
bigchrisfgb is offline   0 Reply With Quote
Old Sep 19, 2012, 06:14 PM   #70
bdinardo
macrumors newbie
 
Join Date: Dec 2006
Unhappy Same here

iPhone 4S won't connect -- it gets the strange web Apple login page. I tried turning off cellular data; that didn't work. I tried turning on auto-join; that didn't work. "The New iPad" is still connecting to my home network just fine.

Update 15 minutes later: it's working again.

Last edited by bdinardo; Sep 19, 2012 at 06:44 PM.
bdinardo is offline   0 Reply With Quote
Old Sep 19, 2012, 06:14 PM   #71
pdqgp
macrumors 68000
 
pdqgp's Avatar
 
Join Date: Mar 2010
How can such a thing happen when so many here tested the Gold Master? Did none of them sync via wifi?

Is this an iOS issue or iTunes issue?
__________________
Family Currently uses: iP3g, (2) iPH4s, iPad Mini Retina, iPad Air Latest Generation, Kindle Paper white, Fire & my Galaxy Note 3 & an iPhone 6
pdqgp is offline   0 Reply With Quote
Old Sep 19, 2012, 06:14 PM   #72
NismoRoadster
macrumors regular
 
Join Date: Mar 2011
Location: Cerritos, CA
same here, iphone4 but my ipad2 works tho
__________________
I only use one hand
NismoRoadster is offline   0 Reply With Quote
Old Sep 19, 2012, 06:14 PM   #73
BSoares
macrumors regular
 
Join Date: Jun 2012
Location: USA
Crap! I updated my iPad earlier today, no issues. Then updated my iPhone, no issues. Now I get home and tell my wife it's safe, update yours too. And then this issue! Now she's going to be really mad at me. At least on the cell phone there's 3G, on her wifi only iPad there isn't so now it can't do anything online.

Let's hope they fix this asap. It's not an iOS issue, it's something on their servers down.
BSoares is offline   0 Reply With Quote
Old Sep 19, 2012, 06:14 PM   #74
WesCole
macrumors 6502a
 
Join Date: Jul 2010
Location: Texas
Same here on my iPhone 4S that I just updated to iOS 6.
__________________
2010 15" MacBook Pro, Anti-Glare Hi-Res, 2.4 i5 128 GB SSD & 500GB HDD in optibay; iPhone 5 32GB; ATV3; 2011 Core i7 27" iMac 2GB VRAM; "New" iPad 32GB AT&T 4G; 2012 MacBook Air 13", i7, 8GB, 256GB
WesCole is offline   0 Reply With Quote
Old Sep 19, 2012, 06:14 PM   #75
josephcasey
macrumors newbie
 
Join Date: Sep 2012
dreadful carry on. stayed up
late to update iPhone 4S and iPad 3. now neither can connect to my own home wifi. how could problem this severe get missed?

why does connecting to local wifi depend on apple.com ?
josephcasey is offline   2 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: 7.05 known wifi sync issue resolved in 7.1? Adamsappel iOS 7 6 Mar 12, 2014 05:51 AM
Does iOS 7 fix the 4S Wifi problem? DaveTheRave iOS 7 9 Sep 29, 2013 08:24 PM
iPhone: [RESOLVED] Upgrade iOS 4.3.2 to Newer iOS - Completely Confused DX SpikyiOS3 Jailbreaks and iOS Hacks 17 Apr 7, 2013 01:12 PM
iOS 6.1 Bluetooth Resolved? boto iOS 6 13 Mar 13, 2013 08:18 AM
Resolved: IOS 6.1 installation problem iPhone 4 - RESOLVED Adam7 iOS 6 3 Jan 29, 2013 04:09 AM

Forum Jump

All times are GMT -5. The time now is 06:42 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC