Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 20, 2012, 11:13 AM   #1
savannadavis
macrumors newbie
 
Join Date: Sep 2012
Update iOS 6, now can't send MMS.

I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.
savannadavis is offline   0 Reply With Quote
Old Sep 20, 2012, 11:15 AM   #2
SandboxGeneral
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: The New World
Quote:
Originally Posted by savannadavis View Post
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.
Are you trying to use iMessage or a regular cellular text [SMS/MMS] message?

Go to Settings, then Messages and scroll down. Ensure MMS Messaging is switched on.
__________________
"Gee, I've been on this diet only ten minutes and I've already lost something, my sense of humor."
SandboxGeneral is offline   0 Reply With Quote
Old Sep 20, 2012, 11:18 AM   #3
savannadavis
Thread Starter
macrumors newbie
 
Join Date: Sep 2012
neither work, iMessage and regular text messages. And MMS is switched on.
savannadavis is offline   0 Reply With Quote
Old Sep 20, 2012, 11:21 AM   #4
SandboxGeneral
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: The New World
Quote:
Originally Posted by savannadavis View Post
neither work, iMessage and regular text messages. And MMS is switched on.
Under Settings --> Phone --> My Number, is your correct telephone number there?

Under Settings --> Messages --> Send & Receive --> You can be reached by iMessage at, do you have your telephone number selected as well as an email address?

Under Settings --> Messages --> Send & Receive --> Start new conversations from, is your telephone number selected there?
__________________
"Gee, I've been on this diet only ten minutes and I've already lost something, my sense of humor."
SandboxGeneral is offline   0 Reply With Quote
Old Sep 20, 2012, 02:11 PM   #5
texasbelle9
macrumors newbie
 
Join Date: Sep 2012
Update iOS 6 and still can't send pics

I double checked all those sections and I still cannot send or receive pictures through iMessage either. :-/
texasbelle9 is offline   1 Reply With Quote
Old Sep 20, 2012, 02:33 PM   #6
Ishimaru
macrumors 6502a
 
Join Date: Jun 2009
Location: Los Angeles
Reset network settings. This was a bug in Beta 3. No clue why it came back up now.
Ishimaru is offline   0 Reply With Quote
Old Sep 21, 2012, 07:25 PM   #7
Zakoson2120
macrumors newbie
 
Join Date: Sep 2012
I can't either I've tried several times and it always fails. It worked fine until I updated yesterday to IOS 6. It's getting frustrating.
Zakoson2120 is offline   0 Reply With Quote
Old Sep 21, 2012, 07:35 PM   #8
cyks
macrumors 68020
 
cyks's Avatar
 
Join Date: Jul 2002
Location: Westchester County, NY
Add me to the list of 'Not Delivered' as well.
cyks is offline   1 Reply With Quote
Old Sep 21, 2012, 07:38 PM   #9
Zakoson2120
macrumors newbie
 
Join Date: Sep 2012
I don't know why it's not working it was working flawlessly then I upgraded now nothing can't send pictures in iMessage or in a standard MMS... What a let down.
Zakoson2120 is offline   0 Reply With Quote
Old Sep 22, 2012, 05:24 PM   #10
DenverSteveo
macrumors newbie
 
Join Date: Sep 2012
Quote:
Originally Posted by Ishimaru View Post
Reset network settings. This was a bug in Beta 3. No clue why it came back up now.
Tried this. It works if only sending over cellular. As soon as I set up my local secure wifi connection again, the problem returns.
DenverSteveo is offline   0 Reply With Quote
Old Sep 22, 2012, 10:15 PM   #11
Zakoson2120
macrumors newbie
 
Join Date: Sep 2012
I can't send or recieve them over 3G or WIFI... Which sucks. Any idea when they will update this issue?
Zakoson2120 is offline   0 Reply With Quote
Old Sep 23, 2012, 09:47 AM   #12
Felicide
macrumors newbie
 
Join Date: Dec 2011
Quote:
Originally Posted by SandboxGeneral View Post
Under Settings --> Phone --> My Number, is your correct telephone number there?

Under Settings --> Messages --> Send & Receive --> You can be reached by iMessage at, do you have your telephone number selected as well as an email address?

Under Settings --> Messages --> Send & Receive --> Start new conversations from, is your telephone number selected there?
I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.
Felicide is offline   0 Reply With Quote
Old Sep 23, 2012, 10:07 AM   #13
ndredsox
macrumors newbie
 
Join Date: Sep 2009
Quote:
Originally Posted by Felicide View Post
I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.
Having the same issue. I did an erase iPhone via find my iPhone yesterday and since then it has not allowing imessage or facetime. I am wondering if I have to wait 24 hours after I wiped. I have tried everything, including a restore as a new iPhone.

Did you happen to erase from find my iPhone?
ndredsox is offline   1 Reply With Quote
Old Sep 23, 2012, 10:13 AM   #14
SandboxGeneral
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: The New World
Quote:
Originally Posted by Felicide View Post
I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.
Check your iTunes account on the phone and be sure it's signed it. That's really the last thing I can think of to check, save doing a full restore.
__________________
"Gee, I've been on this diet only ten minutes and I've already lost something, my sense of humor."
SandboxGeneral is offline   0 Reply With Quote
Old Sep 23, 2012, 10:44 AM   #15
Richard A
macrumors member
 
Join Date: Feb 2010
Can't send pictures using iMessage over my wireless network either, but can using LTE. Went to a friends house and was able to send on their network.

For those having this issue, are you using Comcast for your home network? My is and doesn't work, my friends's network is not Comcast and it worked there.
Richard A is offline   0 Reply With Quote
Old Sep 23, 2012, 10:46 AM   #16
komiothebeat
macrumors 6502
 
Join Date: Jul 2008
Location: Corona, CA
my phone seemed to be freaking out yesterday when i got it, not until making a few phone calls (to parents and friends) and then switching LTE on, THEN off again, that my messages and everything started working again
__________________
15" mbp, 2.4GHz 8gbRAM 250GB 32GB Space Grey iPhone5s (no case #naked) idkmybffjill
komiothebeat is offline   0 Reply With Quote
Old Sep 23, 2012, 02:32 PM   #17
ZacNicholson
macrumors 6502a
 
ZacNicholson's Avatar
 
Join Date: Jun 2011
Location: Indiana
Send a message via Skype™ to ZacNicholson
my imessage is working but not the mms. it was working fine on ios 5. but since i updated it doesn't work. i want to be sexting with this girl and she is to poor to have an iphone.
__________________
follow me on twitter @zac_nicholson
watch my youtube www.youtube.com/mrzacnicholson
2011 13" MBP, iPhone 4 (jailbroken), iPad 3 32 GB Verizon(jailbroken), Apple tv 2(jailbroken)
ZacNicholson is offline   0 Reply With Quote
Old Sep 23, 2012, 04:18 PM   #18
Grams452
macrumors newbie
 
Join Date: Sep 2012
Quote:
Originally Posted by savannadavis View Post
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.
My grandsons did that I went to settings then phone then I just saves his number now he can send pics
Grams452 is offline   0 Reply With Quote
Old Sep 24, 2012, 01:38 PM   #19
DenverSteveo
macrumors newbie
 
Join Date: Sep 2012
Quote:
Originally Posted by Richard A View Post
Can't send pictures using iMessage over my wireless network either, but can using LTE. Went to a friends house and was able to send on their network.

For those having this issue, are you using Comcast for your home network? My is and doesn't work, my friends's network is not Comcast and it worked there.
I confirmed that this seems to be the case when I arrived at work this morning. I can send photos via Wi-Fi just fine across my office's "non-Comcast" network. I also had success this morning at Starbucks sending photos via iMessage, MMS, and email.

At this point, it seems as if IOS 6 and Comcast aren't playing well together...

Can anyone else confirm that their issues are limited to connectivity over a Comcast network?
DenverSteveo is offline   0 Reply With Quote
Old Sep 24, 2012, 02:12 PM   #20
Foo4Everlong
macrumors member
 
Join Date: Jun 2010
Yes, I have Comcast as well and ever since the iOS 6 update I have not been able to send MMS through wifi both on my iPad and on my new iPhone 5. I can send text through iMessage but not pictures or videos. I tried rebooting my wifi recently to no avail. I did not reset the wifi I just unplugged for several minutes. I believe here is a reset button on the wifi. Just as extra info I have a Comcast XFinity wifi box. I can send through 4G no problem. And I also was at another place with different wifi and I was able to send both pictures and text from there. This issue is driving me nuts as I enjoy sending pics. Oh, by the way, my iPad 1 which did not get the iOS 6 update can send pictures and videos through wifi. Please any help would be greatly appreciated. Thanks much. Later
Foo4Everlong is offline   0 Reply With Quote
Old Sep 24, 2012, 03:09 PM   #21
DenverSteveo
macrumors newbie
 
Join Date: Sep 2012
Here is a solution that came up on the Apple Support Forum regarding this issue:

"Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was."


I'm guessing that this may be the issue that quite a few of us are experiencing. I hope it helps!
DenverSteveo is offline   0 Reply With Quote
Old Sep 24, 2012, 07:35 PM   #22
Msyspencer
macrumors newbie
 
Join Date: Sep 2012
I have a modem and wireless router not bought from Comcast although I have Comcast Internet service, and I'm unable to text pictures to anyone without iOS 5 or 6. I can't send to them while connected to wifi nor mobile Internet (tmobile so no 3G).
Msyspencer is offline   0 Reply With Quote
Old Sep 25, 2012, 01:36 AM   #23
ITS ME DAVID
macrumors 6502
 
Join Date: Jul 2010
Location: Pasadena, Ca
I'm having the same problems on my new iPhone 5 and 4s with ios6 on the other line with att I reset networks did a hard reset even restored and nothing I have mms enabled my phone # is listed under my phone settings etc
ITS ME DAVID is offline   0 Reply With Quote
Old Sep 29, 2012, 01:33 AM   #24
Illest
macrumors newbie
 
Join Date: Sep 2012
Location: Bay Area, CA.
Quote:
Originally Posted by DenverSteveo View Post
Here is a solution that came up on the Apple Support Forum regarding this issue:

"Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was."


I'm guessing that this may be the issue that quite a few of us are experiencing. I hope it helps!
I'm experiencing the samething. My temporary fix is to turn off WiFi, send the MMS and then turn wiFi back on, but this is only when I'm home.

Does anyone know a better solution?
Illest is offline   0 Reply With Quote
Old Oct 2, 2012, 10:23 PM   #25
CarlosQG
macrumors 6502a
 
CarlosQG's Avatar
 
Join Date: Sep 2012
Sorry to bring this up again but has anyone found a solution for this terrible bug? I can't send photos through WhatsApp, Mail, Facebook (it won't even load new notifications) I can't search on Soundhound, can't share photos on Instagram and can't make FaceTime calls...

This is driving me crazy. First time I'm losing patience with an Apple product...
__________________
Check out my portfolio! https://www.behance.net/CarlosQG
CarlosQG is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Cant send picture/MMS over iMessage, Help iMrNiceGuy0023 iOS 6 4 Apr 9, 2013 01:23 AM
Can't send MMS on Verizon iPhone 5 acousticbiker iPhone 17 Nov 22, 2012 06:35 AM
iPhone 5 won't send MMS LadyX iPhone 3 Oct 12, 2012 10:00 AM
iPhone 5 cant send mms (AT&T) roger1111 iPhone 0 Sep 30, 2012 07:09 PM
MMS Wont Send 1984world iPhone Tips, Help and Troubleshooting 0 Jun 2, 2012 07:04 PM

Forum Jump

All times are GMT -5. The time now is 05:04 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC