Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 21, 2012, 09:52 PM   #1
radco85
macrumors newbie
 
Join Date: Sep 2012
Unhappy iPhone 5 front camera shutter wont open...

I just received my wonderful iphone 5 today but there is a problem. When i open the camera app (or any other time i open the camera in any app), the back camera works fine while the front camera doesn't function. When i switch to the front camera, the shutters remain closed. Like this:

I quit the app, I reboot my phone, I restored my phone (with and without a backup) and I tried every trick in the book (including banging the phone on my palm, hoping it would shake open the shutter). I can't fix it! Is this hardware related, and does anyone else have this problem?
radco85 is offline   1 Reply With Quote
Old Sep 21, 2012, 10:29 PM   #2
thehopscotch
macrumors regular
 
Join Date: Dec 2009
Location: US
I've had this happen before on my 4S, and I would just close out of the app...then double click to show the apps down in the task bar (multitasking bar at the bottom that shows all apps running in the background). Then press and hold the apps until they start jiggling...then click the "x" to close the camera app and stop it from running in the background. After that, reopen it, and it should be fixed. It's always worked for me on the 4S!
__________________
2012 13" MacBook Air (i7, 8GB RAM, 256GB SSD) | Retina iPad Mini 32GB | iPhone 5S 64GB
Flickr Photostream
thehopscotch is offline   0 Reply With Quote
Old Sep 21, 2012, 10:31 PM   #3
dotme
macrumors 6502a
 
Join Date: Oct 2011
Location: Iowa
Quote:
Originally Posted by radco85 View Post
I just received my wonderful iphone 5 today but there is a problem. When i open the camera app (or any other time i open the camera in any app), the back camera works fine while the front camera doesn't function. When i switch to the front camera, the shutters remain closed. Like this:
Image
I quit the app, I reboot my phone, I restored my phone (with and without a backup) and I tried every trick in the book (including banging the phone on my palm, hoping it would shake open the shutter). I can't fix it! Is this hardware related, and does anyone else have this problem?
It can be hardware, yes. If you can't get it working call apple support. They will help you or arrange for a warranty replacement
dotme is offline   0 Reply With Quote
Old Sep 21, 2012, 10:57 PM   #4
katmeef
macrumors 6502
 
Join Date: Jul 2010
What photo app is that? My iPhone 5 has a round shutter button, that looks more like the ios 5 camera app for 4s no?
katmeef is offline   2 Reply With Quote
Old Sep 21, 2012, 10:59 PM   #5
radco85
Thread Starter
macrumors newbie
 
Join Date: Sep 2012
Yeah, I tried closing and opening it... I think it's hardware. If I went to the apple store though, they wouldn't have any replacements around, would they? I'm thinking of just waiting a few months until the phone becomes more available and asking for an exchange (assuming they couldn't fix it, I've literally done all I could think of). I don't use the front camera often at all, but it is a new phone, I still want it to work.

----------

And that is just a stock picture, not the actual picture. like, imagine that shutter on the iOS6 layout, same thing. I just wanted it to make more sense... it's in any app that uses the camera
radco85 is offline   0 Reply With Quote
Old Sep 21, 2012, 11:09 PM   #6
87am
macrumors regular
 
Join Date: Feb 2011
Quote:
Originally Posted by radco85 View Post
Yeah, I tried closing and opening it... I think it's hardware. If I went to the apple store though, they wouldn't have any replacements around, would they? I'm thinking of just waiting a few months until the phone becomes more available and asking for an exchange (assuming they couldn't fix it, I've literally done all I could think of). I don't use the front camera often at all, but it is a new phone, I still want it to work.

----------

And that is just a stock picture, not the actual picture. like, imagine that shutter on the iOS6 layout, same thing. I just wanted it to make more sense... it's in any app that uses the camera
Of course they would have replacements around for launch day.
87am is offline   0 Reply With Quote
Old Sep 21, 2012, 11:17 PM   #7
radco85
Thread Starter
macrumors newbie
 
Join Date: Sep 2012
Hm... maybe I'll have to go check it out. Like I said, not a huge rush. I just think its an odd problem to have...
radco85 is offline   0 Reply With Quote
Old Sep 22, 2012, 08:43 AM   #8
GOLDENi
macrumors newbie
 
Join Date: Sep 2012
I have the same problem. Mine worked fine once I got it and then 5 hours later, it started doing that.

I tried resetting my phone, restoring my phone through iTunes, closing it from the multitask bar, same thing! I can't even switch to the back camera.

I have an appointment at the Genius Bar today, so I'll come back with some results, hopefully I get a replacement, but I just put on my Invisible Shield screen protector! There goes $20..
GOLDENi is offline   0 Reply With Quote
Old Sep 22, 2012, 09:12 AM   #9
bobdigi
macrumors member
 
Join Date: Jun 2010
Location: Baton Rouge, LA
Take it to the apple store. I'm pretty sure they have some set aside for warranty replacements.
bobdigi is offline   0 Reply With Quote
Old Sep 22, 2012, 11:02 AM   #10
tock
macrumors newbie
 
Join Date: Sep 2012
Same problem and more

I have the exact same problem. What's worse for me is that ambient light sensor doesn't work either. So at night, the screen is glaringly bright and I have to manually turn it down. Then, of course, during the day, I can't see the screen and have to manually turn the brightness up again.

I'm restoring the phone right now just in case this is a software issue due to my restoring a backup from my iPhone 4.

If the restore does not fix the issue, I'm taking it to the Apple Store for a warranty replacement.

***Update***
The restore was nice and fast, however it did not resolve the problem. I setup the phone as a new device without restoring from a backup and the front camera and ambient light sensor are still non-functional.

To the Apple Store it goes.

Last edited by tock; Sep 22, 2012 at 11:10 AM. Reason: Update
tock is offline   0 Reply With Quote
Old Sep 22, 2012, 04:55 PM   #11
GOLDENi
macrumors newbie
 
Join Date: Sep 2012
Just got back from the Apple Store & got a replacement in less than 10 mins.
GOLDENi is offline   0 Reply With Quote
Old Sep 22, 2012, 05:25 PM   #12
radco85
Thread Starter
macrumors newbie
 
Join Date: Sep 2012
Quote:
Just got back from the Apple Store & got a replacement in less than 10 mins.
Good to know I'll have to make a trip then at some point to switch it out then.
radco85 is offline   0 Reply With Quote
Old Sep 23, 2012, 08:23 PM   #13
zubins
macrumors newbie
 
Join Date: Jan 2009
this just happened to my brothers phone, too. Did they give you a brand new replacement or was it refurbished? Im thinking iphone 5s are too new to have refurbished units
zubins is offline   0 Reply With Quote
Old Sep 3, 2013, 04:29 PM   #14
Pastor B
macrumors newbie
 
Join Date: Sep 2013
Lightbulb Same prob - solved!

Hey guys,
I had this same problem - iPhone 5 camera suddenly froze on closed shutter or black image. I downloaded the 'flashlight' app and activated the flash. The camera app now magically works.

Hope this helps.
Pastor B is offline   0 Reply With Quote
Old Dec 13, 2013, 06:09 AM   #15
WagonBoss
macrumors newbie
 
Join Date: Dec 2013
Which 'flashlight' specifically was that?
WagonBoss is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:03 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC