Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 21, 2012, 10:26 PM   #1
ipoddin
macrumors 6502a
 
ipoddin's Avatar
 
Join Date: Jan 2004
Location: Los Angeles
Texts or iMessages don't sound alerts or wake up screen on iPhone 5

Phone isn't on vibrate. In notifications settings messages are set to view in lock screen, show preview, tone is set to default. When a text or iMessage comes in the screen doesn't wake up nor does the text tone go off.

If I'm using the phone I see the banner and hear the alert. But if phone is locked I have no idea a message comes in unless I turn the screen on and see the alert.

What am I missing?
__________________
15" MBP 2.4ghz i5, 8gb ram iPad 3 32gb Black TV2
ipoddin is offline   0 Reply With Quote
Old Sep 22, 2012, 10:24 AM   #2
dabigone
macrumors regular
 
Join Date: Jul 2008
I'm having the same problem. Was working fine, but now there are no text sounds at all. But if I'm in the text window I get a sound when I sen a message.
dabigone is offline   0 Reply With Quote
Old Sep 22, 2012, 10:25 AM   #3
solidsnake32292
macrumors regular
 
Join Date: May 2010
Having similar issues here.... hope this get's fixed asap!
solidsnake32292 is offline   0 Reply With Quote
Old Sep 22, 2012, 10:33 AM   #4
J.L.Photography
macrumors 6502
 
Join Date: Feb 2012
Location: South Florida
go to notifications and check the alert style, maybe its set to none.... change it to banner
__________________
Mid2012 15" RMBP 2.3 i7, 16gb RAM, 256gb SSD Mid2012 13" MBA 1.8 i5, 8gb RAM, 128gb SSD
iPad2-W AppleTV3
Samsung Galaxy S4
J.L.Photography is offline   0 Reply With Quote
Old Sep 22, 2012, 11:13 AM   #5
dabigone
macrumors regular
 
Join Date: Jul 2008
Shut down all my apps and reboot. Sounds are back. I'm guessing another app was taking precedence.
dabigone is offline   0 Reply With Quote
Old Sep 22, 2012, 12:27 PM   #6
dtbratt
macrumors 6502
 
Join Date: Feb 2011
Location: Stoney Creek, ON
Quote:
Originally Posted by J.L.Photography View Post
go to notifications and check the alert style, maybe its set to none.... change it to banner
Do this. Its probably turned off in notifications.
__________________
dtbratt is offline   0 Reply With Quote
Old Sep 22, 2012, 12:46 PM   #7
BurntReality
macrumors 6502
 
Join Date: Jun 2010
Location: Tyler, TX
Sounds to me like you have Do Not Disturb Mode enabled. It will not alert you to text messages while phone is locked.

Disable it through settings.
BurntReality is offline   1 Reply With Quote
Old Sep 22, 2012, 12:47 PM   #8
QuarterSwede
macrumors 604
 
QuarterSwede's Avatar
 
Join Date: Oct 2005
Location: Colorado Springs, CO
Quote:
Originally Posted by BurntReality View Post
Sounds to me like you have Do Not Disturb Mode enabled. It will not alert you to text messages while phone is locked.

Disable it through settings.
My thought too.
__________________
“In a world of idiots, the average man is king."

"Next to the Word of God, the noble art of music is the greatest treasure in the world." -- Martin Luther
QuarterSwede is offline   0 Reply With Quote
Old Sep 22, 2012, 12:53 PM   #9
13irregular
macrumors newbie
 
Join Date: Jun 2010
same thing happening to me, i hear a sound but screen shows nothing.
13irregular is offline   0 Reply With Quote
Old Sep 22, 2012, 01:03 PM   #10
DCHoya
macrumors newbie
 
Join Date: Sep 2012
Same problem here. My phone has the vibrate function turned off and it's on silent, so unless I check the lock screen regularly, I have no idea if I'm getting texts or not.

I've also found that a number of my iMessages have been delayed, which makes the problem even more troublesome.
DCHoya is offline   0 Reply With Quote
Old Sep 22, 2012, 02:18 PM   #11
ipoddin
Thread Starter
macrumors 6502a
 
ipoddin's Avatar
 
Join Date: Jan 2004
Location: Los Angeles
Quote:
Originally Posted by BurntReality View Post
Sounds to me like you have Do Not Disturb Mode enabled. It will not alert you to text messages while phone is locked.

Disable it through settings.
Ok, it was DND mode, but I don't know why it was doing this. I set it up as a scheduled DND from Midnight to 8am. Then in settings I enabled DND thinking I had to for the schedule to run. Maybe that was a mistake. However, it still should have let the texts come through b/c I was missing texts from my gf who is setup as a favorite. I allowed favorites to come through in DND.

When I turned DND off, texts popped up again. But still don't know why a person who was set as a favorite didn't come through. She's set as a favorite in my phone contacts, is there somewhere else to set favorites for DND?
__________________
15" MBP 2.4ghz i5, 8gb ram iPad 3 32gb Black TV2
ipoddin is offline   0 Reply With Quote
Old Sep 23, 2012, 09:35 AM   #12
cypress822
macrumors regular
 
Join Date: Jun 2012
same problem here...only a small partial percentage of my text messages are coming with alerts.
cypress822 is offline   0 Reply With Quote
Old Sep 23, 2012, 10:28 AM   #13
cypress822
macrumors regular
 
Join Date: Jun 2012
this is driving me nuts...cant believe more people are not having this problem...not much at all on internet about it
cypress822 is offline   0 Reply With Quote
Old Sep 23, 2012, 10:54 AM   #14
Codepiink
macrumors regular
 
Join Date: Jun 2010
Location: Westchester County, NY
Quote:
Originally Posted by ipoddin View Post
Ok, it was DND mode, but I don't know why it was doing this. I set it up as a scheduled DND from Midnight to 8am. Then in settings I enabled DND thinking I had to for the schedule to run. Maybe that was a mistake. However, it still should have let the texts come through b/c I was missing texts from my gf who is setup as a favorite. I allowed favorites to come through in DND.

When I turned DND off, texts popped up again. But still don't know why a person who was set as a favorite didn't come through. She's set as a favorite in my phone contacts, is there somewhere else to set favorites for DND?


The same thing was happening to me. I realized that of you have a scheduled DND, DO NOT flip the setting to "on" in the general settings. Turning this on will immediately turn on DND and you will not get notifications. Whatever time you schedule DND, it will turn on by itself during those hours. I found this out the hard way when I turned this setting on and I missed an important phone call while the phone was in my hand.

Last edited by Codepiink; Sep 23, 2012 at 11:10 AM.
Codepiink is offline   0 Reply With Quote
Old Sep 23, 2012, 11:02 AM   #15
pbrooks
macrumors regular
 
Join Date: Jul 2008
Quote:
Originally Posted by Codepiink View Post
The same thing was happening to me. I realized that of you have a scheduled DND, DO NOT flip the setting to "on" in the general settings. Turning this on will immediately turn on DND and you will not get notifications. Whatever time you schedule DND, it will turn on by itself during those hours. I found this out the hard way when I turned this setting on and I missed an important phone call while the phone was on my hand.
I was initially confused by what seemed like a redundant set of controls for DND mode, but it does make sense. The top-level DND button under Settings is a quick-access control. The DND settings in Settings>>Privacy is for scheduling which I imagine is something you wouldn't need frequent access to under typical use.
__________________
27" iMac, 15" MacBook Pro, iPad 4, iPhone 5, Mac user since 1985
pbrooks is offline   0 Reply With Quote
Old Sep 23, 2012, 11:18 AM   #16
cbr09123
macrumors newbie
 
Join Date: Aug 2010
Under notifications, also check to see if it is set to show on lockscreen. That'll make it so it wakes the screen.

Also, I'm having a small similar issue. When I get a notification (like email or sms), I here the notification (+vibration), but the actual notification wont shop up as a banner for like a split second later.

On my 4S with iOS5, they both sounded and showed the notification simultaneously. Small quirk, I am sure it's just a bug issue.
cbr09123 is offline   0 Reply With Quote
Old Sep 23, 2012, 11:31 AM   #17
ipoddin
Thread Starter
macrumors 6502a
 
ipoddin's Avatar
 
Join Date: Jan 2004
Location: Los Angeles
Quote:
Originally Posted by Codepiink View Post
The same thing was happening to me. I realized that of you have a scheduled DND, DO NOT flip the setting to "on" in the general settings. Turning this on will immediately turn on DND and you will not get notifications. Whatever time you schedule DND, it will turn on by itself during those hours. I found this out the hard way when I turned this setting on and I missed an important phone call while the phone was in my hand.
Yeah, that's it. Also realized that in dnd, only calls from favorites will come through. Messages will not. Wish they did though.
__________________
15" MBP 2.4ghz i5, 8gb ram iPad 3 32gb Black TV2
ipoddin is offline   0 Reply With Quote
Old Sep 23, 2012, 11:33 AM   #18
MacBoy88
macrumors regular
 
Join Date: Feb 2003
Location: Illinois
Send a message via AIM to MacBoy88
Quote:
Originally Posted by ipoddin View Post
... However, it still should have let the texts come through b/c I was missing texts from my gf who is setup as a favorite. I allowed favorites to come through in DND.

When I turned DND off, texts popped up again. But still don't know why a person who was set as a favorite didn't come through. She's set as a favorite in my phone contacts, is there somewhere else to set favorites for DND?
That only applies to calls, not text messages.
__________________
Late 2012 13" rMBP | iPad 3 | iPad mini | VZW iPhone 5 Black
MacBoy88 is offline   0 Reply With Quote
Old Sep 23, 2012, 07:27 PM   #19
klrgoten
macrumors newbie
 
Join Date: Sep 2012
I'm having similar problems with my iPhone 5. I'm not getting text notifications and my DND is not on. I've tried restoring my phone, powering off and on... no dice. It seems that the first few texts that come through give me a sound alert correctly, then they stop. I have then change the alert tone to something different and change it back to the one I want for them to start working again... very annoying
klrgoten is offline   0 Reply With Quote
Old Sep 23, 2012, 07:53 PM   #20
DirtySocks85
macrumors Demi-God
 
DirtySocks85's Avatar
 
Join Date: Mar 2009
Location: Wichita, KS
Was having a similar issue, changed the text tone and it seemed to fix it, for now. We'll see if this continues to be a persistent issue.

EDIT: On the bright side, it was time to give it a change. I've been using the mockingjay call from The Hunger Games since last December or so. A good ol' TARDIS vworp vworp it is.
__________________
13"MacBook Pro (mid 2010) iPhone 5 32GB Black/Slate iPod Classic 80GB
• Canon EOS Rebel T3i • Nexus 7
JStiles Photography Website JStiles Photography on Facebook
DirtySocks85 is offline   0 Reply With Quote
Old Nov 7, 2012, 11:00 AM   #21
lilmisskrany
macrumors newbie
 
Join Date: Nov 2012
Thumbs up

Quote:
Originally Posted by BurntReality View Post
Sounds to me like you have Do Not Disturb Mode enabled. It will not alert you to text messages while phone is locked.

Disable it through settings.
Thank you! I never would have never thought to change that and didn't realize it affects alerts too!
lilmisskrany is offline   0 Reply With Quote
Old Feb 27, 2013, 10:58 AM   #22
El indio
macrumors member
 
Join Date: Jul 2009
By any chance are you using any other 3rd party text message app?
El indio is offline   0 Reply With Quote
Old Jul 26, 2013, 10:16 PM   #23
Arfdog
macrumors 6502
 
Join Date: Jan 2013
ok my problem is similar, but it's not DND.

I am in a convo in iMessage. Lock the phone with convo still on the screen. Convo still occurring, with my friend or friends replying and stuff. But I don't hear a single text alert.

Now I unlock phone, exit convo or go to home screen. Lock phone again. Now I hear text alerts from that same convo.

wtf?
Arfdog is offline   0 Reply With Quote
Old Jul 26, 2013, 10:57 PM   #24
C DM
macrumors G4
 
Join Date: Oct 2011
Quote:
Originally Posted by Arfdog View Post
ok my problem is similar, but it's not DND.

I am in a convo in iMessage. Lock the phone with convo still on the screen. Convo still occurring, with my friend or friends replying and stuff. But I don't hear a single text alert.

Now I unlock phone, exit convo or go to home screen. Lock phone again. Now I hear text alerts from that same convo.

wtf?
There are some other threads about this particular issue. Essentially if you are still on the conversation then alerts for it won't be showing up--you have to at least exit the conversation if not the whole messages app to hear/see alerts related to conversations.
C DM is offline   0 Reply With Quote
Old Sep 13, 2013, 06:23 PM   #25
gariepy13
macrumors newbie
 
Join Date: Sep 2013
I had the same problem. The alert wouldn't come through on time or at all unless I unlocked the phone. My DND was off and the notifications for iMessages was on with "view in lock screen" on. I solved it by going to notifications, click "Sort apps: Manually" then move iMessages to the top. This makes it the most prioritized alert. This solved the problem for me, hope it works for you guys too.
gariepy13 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Texts and iMessages in general (iOS any version) parajba iPhone 3 May 1, 2014 03:32 AM
iMessages not automatcally sending as texts Bugeyeblue iOS 7 23 Oct 6, 2013 10:39 AM
New unread texts sometimes don't appear in lock screen? TH55 iPhone 6 Feb 24, 2013 10:23 AM
iPhone 4S - texts don't come through until I turn the screen on dbrewer80221 iPhone Tips, Help and Troubleshooting 0 Feb 12, 2013 09:07 PM
Alerts don't always work on iPhone 5 lovedakota iOS 6 8 Nov 8, 2012 09:36 AM

Forum Jump

All times are GMT -5. The time now is 09:32 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC