Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 22, 2012, 12:34 PM   #1
lokiju
macrumors 6502
 
Join Date: Jun 2008
Mail showing incorrect unread count after doing search. Sort of solved other issue

Edit: solved my 1st issue, it was a change to where to look for the purchased movies and shows that doesn't follow Apples own posted instructions from iOS 5.x.

If anyone is wondering, you go to the iTunes app on my iOS 6 device, then More on the bottom right then select Purchased to view your iCloud accessible movies and TV shows you already paid for.

I'll leave the original format of my questions below the same in case it helps others identify their issue.

Also, while I have found a way to get the movies and shows I've downloaded, I still cannot click on the Purchased section of the App Store app and have it load my prior App purchases. It will still crash the App Store app each time.

====================

These are two issues I'm having.

1: If I open up the App Store app, go to updates then click on purchased, my data transfer status circle to the right of the time will run for about a minute then stop, nothing shows up then the App Store app crashes/closes.

I have another iTunes account from long ago that I don't use much and it only has a handful of purchases in its history, if I switch to this account from my primary account, it will laud my purchase history fine.

Genius does work for my primary account, which from what I understand requires looking at your purchase history.

I have easily hundreds of purchases in my primary accounts history FWIW.

2: If I do a search in my mail app for something, afterwards, one of my mail accounts list around 35 unread messages only in the notification count above the mail app icon. There are no actually unread messages in my mail app.

I even tried going into another mail account that's not showing an invalid unread count and searching within that and it still caused the other account to again show about 35 unread messages over the mail app icon only.

I cannot make it stop showing the incorrect unread count until I remove and re-add the account.

I've tried rebooting the phone, sending myself a new message to that account the reading it and doing a refresh after and also tried just marking a read message as unread, refreshed then marked as read and refreshed again.

Nothing makes the incorrect count go away except for removing and reading the account.

It's a Exchange account for my work. They're running Exchange 2007 FWIW.

Has anyone run into either of these issues and found a solution?

Last edited by lokiju; Sep 22, 2012 at 01:46 PM.
lokiju is offline   0 Reply With Quote
Old Sep 23, 2012, 07:37 AM   #2
Jstevens75
macrumors newbie
 
Join Date: Sep 2012
I am having exactly the same problem with phantom unread email counts. I imagine its a bug. Hope Apple is watching.
Jstevens75 is offline   0 Reply With Quote
Old Sep 27, 2012, 10:34 PM   #3
findjh
macrumors newbie
 
Join Date: Sep 2012
Go to settings/mail/exchange - turn off mail and turn on again - fixed it for me
findjh is offline   1 Reply With Quote
Old Sep 27, 2012, 10:53 PM   #4
heathpitts
macrumors member
 
Join Date: Jun 2003
I had the same mail issue with 5.1.1. Looks like it isn't fixed
heathpitts is offline   0 Reply With Quote
Old Sep 28, 2012, 07:43 AM   #5
Jstevens75
macrumors newbie
 
Join Date: Sep 2012
It only fixes it until you search the server again. Not a good solution in my book.
Jstevens75 is offline   0 Reply With Quote
Old Oct 1, 2012, 08:19 AM   #6
bushwoodgopher
macrumors newbie
 
Join Date: Oct 2012
I tried a trick that I got from another forum and it worked for me. I am running enterprise 2010 on my work computer (pc) and iOS 6.

Go into your Outlook account on your computer and mark your entire inbox as unread. Wait a minute or two for your iPhone's mail to update to show all email as unread. Now select all of your email on your computer and mark it as read. In another minute or two, you should have zero unread messages on your iPhone's Exchange account.

This worked for me anyway. Hope it helps.
bushwoodgopher is offline   0 Reply With Quote
Old Oct 1, 2012, 08:43 AM   #7
nitramcuthbert
macrumors newbie
 
Join Date: Oct 2012
I was using Outlook 2013 and had a draft reply to an email unfinished. Because of the way Outlook 2013 now stores the drafts along with the original message it showed up on my device as an unread message, but hidden. As soon as I sent the message the message count corrected itself.

iOS does not seem to be fully compatible with Outlook 2013. We also have problems with calender entries that use the new Show as: "Working Elsewhere" option. Obviously there is a bit of time until it is released, so you have to expect these issues.
nitramcuthbert is offline   0 Reply With Quote
Old Oct 4, 2012, 07:40 AM   #8
Jstevens75
macrumors newbie
 
Join Date: Sep 2012
22,000 unread and read emails later...still not working
Jstevens75 is offline   0 Reply With Quote
Old Oct 5, 2012, 05:55 PM   #9
tofucat
macrumors newbie
 
Join Date: Oct 2012
thanks

Quote:
Originally Posted by findjh View Post
Go to settings/mail/exchange - turn off mail and turn on again - fixed it for me
This worked for me too. How annoying it was.
tofucat is offline   0 Reply With Quote
Old Dec 11, 2012, 06:37 PM   #10
Duffer13
macrumors newbie
 
Join Date: Nov 2011
iPhone 5 & iPad 4 not agreeing on unread emails

I am also experiencing the phantom unread emails, but, only on my new iPad 4. My iPhone 5 has never experienced this issue and I resolved it once on my iPad by deleting my Exchange account entirely and then recreating it. Now, just a couple of days later, I am showing 1 more unread message on my iPad than on my iPhone.

Very strange!
Duffer13 is offline   0 Reply With Quote
Old Dec 11, 2012, 07:05 PM   #11
Duffer13
macrumors newbie
 
Join Date: Nov 2011
iPhone 5 & iPad 4 not agreeing on unread emails

Thought I would try some of the fixes on the post. Did the read/unread thing in Outlook...still showed one more unread message on my iPad than my iPhone, but, it didn't exist. Checked all folders to be sure that there was nothing there that I didn't know about.

Then I moved all my inbox messages in Outlook to archives. I now show '0' unread messages on my iPhone and '1' phantom unread message on my iPad. It just doesn't exist anywhere. I realize that I can just delete my Exchange account on my iPad and start over each time, but, that would be a constant occurrence.
Duffer13 is offline   0 Reply With Quote
Old Dec 12, 2012, 10:02 PM   #12
obooker
macrumors newbie
 
Join Date: Dec 2012
Another way to get rid of unread messages

I found this, and it worked for me....

Apple iPhone shows unread messages
Posted by Jeremy Slater on 17 October 2012 09:40 PM
[URL=http://helpdesk.mysyapps.com/Knowledgebase/Article/View/21/0/apple-iphone-shows-unread-messages[/URL]

On an iPhone running iOS 6 there are instances where the mail icon will show that there are unread messages when in reality there are no unread messages.

To clear the unread messages counter, do the following:

Select Settings from the iPhone home screen
Select Mail, Contacts and Calendar
Select the mail account that is showing the incorrect unread messages icon
Click on the Mail setting which is currently set to ON. Change the option to OFF.
Select the Mail button in the top left hand corner
Hold the lock button down for 5 seconds and power off your iPhone
After 30 seconds, turn your iPhone back on
Select Settings from the iPhone home screen
Select Mail, Contacts and Calendar
Select the mail account that was showing the incorrect unread messsages icon
Click on the Mail setting which is currently set to OFF. Change the option to ON.
Select the Mail button in the top left hand corner
Exit to the iPhone home screen
Click on Mail and load your mailbox

Your unread messages icon should now show the correct amount of unread e-mails.
obooker is offline   1 Reply With Quote
Old Dec 29, 2012, 11:22 PM   #13
Sheldonsmith
macrumors member
 
Join Date: May 2011
Quote:
Originally Posted by obooker View Post
I found this, and it worked for me....

Apple iPhone shows unread messages
Posted by Jeremy Slater on 17 October 2012 09:40 PM
[URL=http://helpdesk.mysyapps.com/Knowledgebase/Article/View/21/0/apple-iphone-shows-unread-messages[/URL]

On an iPhone running iOS 6 there are instances where the mail icon will show that there are unread messages when in reality there are no unread messages.

To clear the unread messages counter, do the following:

Select Settings from the iPhone home screen
Select Mail, Contacts and Calendar
Select the mail account that is showing the incorrect unread messages icon
Click on the Mail setting which is currently set to ON. Change the option to OFF.
Select the Mail button in the top left hand corner
Hold the lock button down for 5 seconds and power off your iPhone
After 30 seconds, turn your iPhone back on
Select Settings from the iPhone home screen
Select Mail, Contacts and Calendar
Select the mail account that was showing the incorrect unread messsages icon
Click on the Mail setting which is currently set to OFF. Change the option to ON.
Select the Mail button in the top left hand corner
Exit to the iPhone home screen
Click on Mail and load your mailbox

Your unread messages icon should now show the correct amount of unread e-mails.
This seemed to work for me as well. Using Exchange on Office 365.

Thanks for posting,

-Sheldon
__________________
Sheldon Smith
www.minus4plus6.com
Sheldonsmith is offline   0 Reply With Quote
Old Jan 3, 2013, 01:47 PM   #14
selliott
macrumors newbie
 
Join Date: Mar 2010
Location: Vegas
Quote:
Originally Posted by bushwoodgopher View Post
I tried a trick that I got from another forum and it worked for me. I am running enterprise 2010 on my work computer (pc) and iOS 6.

Go into your Outlook account on your computer and mark your entire inbox as unread. Wait a minute or two for your iPhone's mail to update to show all email as unread. Now select all of your email on your computer and mark it as read. In another minute or two, you should have zero unread messages on your iPhone's Exchange account.

This worked for me anyway. Hope it helps.
This worked for me, Exchange 2010 & Iphone 5 with iOS 6.0.2
__________________
15" MBP Retina, 2.3 i7 Quad, 16GB ram, 512 GB SSD;
13" MBP 2.3 i5 Dual, 4GB ram, 500 GB HD;
Iphone 5 32GB White, Iphone 5C 32GB;
Ipad Retina 32GB White, Ipad Mini 16GB Black
selliott is offline   0 Reply With Quote
Old Jan 11, 2013, 12:03 PM   #15
haliaetus
macrumors newbie
 
Join Date: Jan 2010
I've had the same problem on my iphone and ipad. I think the problem is allowing an unread mail to sit around so long that it makes it out of the phone's 100 recent mails or however long you have the phone's mail set to sync. I use iMail on my MBA, so it's not just Outlook. I think the phone doesn't sync the unread count back any earlier than however long you have it set to sync the account, so any action (turning mail on and off, or doing the all unread-all read thing) forces a full resync and updates the count.
haliaetus is offline   0 Reply With Quote
Old Feb 7, 2013, 08:52 PM   #16
Chellspecker
macrumors newbie
 
Join Date: Feb 2013
Solution to Phantom Email Count

This works:

(Home Screen) Settings --> Mail, Contacts and Calendars --> Gmail (or whatever your Exchange email is. It should say Exchange at the top). Down the page a bit to "Mail Folders to Push" and I had only set it to "Inbox." I added all the subfolders in that Gmail account (14 of them in my case: Trash, Drafts, Spam, every one) by checking each one. Waited a couple seconds. Checked the home screen badge icon. Voila! No more phantom email. Problem solved.

I didn't need to power down the phone or remove and then re-enter my account or anything. This really worked. I then switched it back to just pushing the Inbox. I'm not sure what effect, if any, pushing those subfolders would have. I figured the less pushing the better. I don't need Spam pushed to my phone. I guess if you start drafts on one device and finish them on another you could push your Drafts folder. It's a useful setting for determining what messages you want to instantly appear on your phone.

Last edited by Chellspecker; Feb 7, 2013 at 09:19 PM. Reason: Brevity
Chellspecker is offline   0 Reply With Quote
Old Feb 21, 2013, 10:08 AM   #17
ExecTech24
macrumors newbie
 
Join Date: Oct 2011
Quote:
Originally Posted by haliaetus View Post
I've had the same problem on my iphone and ipad. I think the problem is allowing an unread mail to sit around so long that it makes it out of the phone's 100 recent mails or however long you have the phone's mail set to sync. I use iMail on my MBA, so it's not just Outlook. I think the phone doesn't sync the unread count back any earlier than however long you have it set to sync the account, so any action (turning mail on and off, or doing the all unread-all read thing) forces a full resync and updates the count.
You're onto something with this. (Exchange account)
1) I set all my emails to read.
2) I set my exchange account on iPad to to only synch 1 month (from no limit). I left the option to synch 1000 messages on.
3) I opened the mail app and let the emails adjust.
4) Then I searched for a term and now I have (23) unread messages that aren't there.

Part 2

1) I turned off the mail for Exchange and back on. The (23) are still there.
2) I switched from 1 month (in mail settings) back to no limit and let it sync again and the (23) is gone.

It seems like as long as the criteria for emails you're searching for are within your mail device setup, you don't have an issue.
But if the device is synching only 1 month, and I search for John Doe, and I have emails from John Doe that go beyond 1 month, it will index them as new, even though the device isn't set to be able to read them.

There's a disconnect between the data the device has access to via server search and the device options for mail.

Last edited by ExecTech24; Feb 21, 2013 at 10:13 AM.
ExecTech24 is offline   0 Reply With Quote
Old Jun 2, 2013, 01:24 AM   #18
dajatsu
macrumors newbie
 
Join Date: Jun 2013
Quote:
Originally Posted by findjh View Post
Go to settings/mail/exchange - turn off mail and turn on again - fixed it for me
Worked. I turned off both my Exchange and iCloud acct. then restarted and phantom unread mail count is gone. Thanks.
dajatsu is offline   0 Reply With Quote
Old Jun 6, 2013, 08:07 AM   #19
Johngaltwho
macrumors newbie
 
Join Date: Jun 2013
You people are so smart! Turning off exchange, powering off then on again worked for me. Phantom unread messages annoyed me for weeks and with a visit here, 'twas fixed in minutes. Thanks
Johngaltwho is offline   0 Reply With Quote
Old Jun 17, 2013, 12:01 PM   #20
RHA
macrumors newbie
 
Join Date: Oct 2011
Location: Chicagoland
Smile Phantom Count

New i could find the solution here. That is so annoying. Glad to take the three minutes to find the answer. Worked perfectly!
RHA is offline   0 Reply With Quote
Old Jun 22, 2013, 05:47 PM   #21
Trickysax
macrumors newbie
 
Join Date: Jun 2013
Quote:
Originally Posted by Chellspecker View Post
This works:

(Home Screen) Settings --> Mail, Contacts and Calendars --> Gmail (or whatever your Exchange email is. It should say Exchange at the top). Down the page a bit to "Mail Folders to Push" and I had only set it to "Inbox." I added all the subfolders in that Gmail account (14 of them in my case: Trash, Drafts, Spam, every one) by checking each one. Waited a couple seconds. Checked the home screen badge icon. Voila! No more phantom email. Problem solved.

I didn't need to power down the phone or remove and then re-enter my account or anything. This really worked. I then switched it back to just pushing the Inbox. I'm not sure what effect, if any, pushing those subfolders would have. I figured the less pushing the better. I don't need Spam pushed to my phone. I guess if you start drafts on one device and finish them on another you could push your Drafts folder. It's a useful setting for determining what messages you want to instantly appear on your phone.
This worked straight away! Took a few seconds to check all the newly selected folders and has solved the problem! Thanks!!
Running an iPhone 4S with 6.1.3 and Mail.
Trickysax is offline   0 Reply With Quote
Old Jul 14, 2013, 03:44 AM   #22
Dmax83
macrumors newbie
 
Join Date: Jul 2013
Quick fix for the phantom email problem!

Simply go into the folder that's showing your phantoms, click Edit.

Mark your top email so that it's ticked as if about to be marked unread.

Press and hold that ticked mail while simultaneously pressing Mark, bottom right.

Mark as unread, click your (now) single unread mail.

Restart phone.

Sorted

Last edited by Dmax83; Jul 14, 2013 at 04:05 AM. Reason: Refining
Dmax83 is offline   0 Reply With Quote
Old Aug 19, 2013, 09:10 AM   #23
dmp1910
macrumors newbie
 
Join Date: Aug 2013
Smile Fixed! for the moment al least

This worked for me, although did not search in the server again yet.

"To clear the unread messages counter, do the following:

Select Settings from the iPhone home screen
Select Mail, Contacts and Calendar
Select the mail account that is showing the incorrect unread messages icon
Click on the Mail setting which is currently set to ON. Change the option to OFF.
Select the Mail button in the top left hand corner
Hold the lock button down for 5 seconds and power off your iPhone
After 30 seconds, turn your iPhone back on
Select Settings from the iPhone home screen
Select Mail, Contacts and Calendar
Select the mail account that was showing the incorrect unread messsages icon
Click on the Mail setting which is currently set to OFF. Change the option to ON.
Select the Mail button in the top left hand corner
Exit to the iPhone home screen
Click on Mail and load your mailbox

Your unread messages icon should now show the correct amount of unread e-mails."
dmp1910 is offline   0 Reply With Quote
Old Sep 11, 2013, 06:49 AM   #24
Fuzzie010
macrumors newbie
 
Join Date: Sep 2013
This worked for me more than once:

(Home Screen) Settings --> Mail, Contacts and Calendars --> [my Exchange account] (It should say Exchange at the top). Down the page a bit to "Sync e-mail".
Set this to 1 day. Go back to your mail. (Wait a minute, maybe do a refresh). Go back to the same settings and set it back to your preferred value. The unread mail counter is now correct.

I hope this solves this issue for at least some of you.
Fuzzie010 is offline   0 Reply With Quote
Old Sep 24, 2013, 09:39 AM   #25
Samwellington
macrumors newbie
 
Join Date: Sep 2013
Permanent cause and solution found!

Basically, say you search for an email from "joe" and your messages are programmed to keep 2 weeks. If you select continue search on server, it will download into a hidden folder the headers of all emails from "joe" and display them. If any are unread, it will rack-up the unread counter. You can either mark all search results as read and eliminate the problem, or if you forget, try the following:
Search again for emails from "joe", and mark unread messages as read.
Or
If you forget what you searched for, search for emails to "yourself". Do not continue search on server. Scroll down list containing emails to you from the keep period PLUS search results! Find unread and mark as read.

Works every time

If apple would give us visibility to a search result folder it would be easier...
Samwellington is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
10.9.2 Apple Mail Unread Count Error JavaWizKid OS X Mavericks (10.9) 3 Apr 16, 2014 09:04 PM
Mail Showing 1 Unread Message, but Nothing is there aheying7 iOS 7 23 Oct 30, 2013 04:43 PM
Mail not showing unread msgs count bruleke OS X 10.8 Mountain Lion 1 Dec 27, 2012 06:48 AM
Unread Mail Count and Mail Rules kjs862 iPhone Tips, Help and Troubleshooting 0 Oct 21, 2012 12:40 AM
Mail showing unread mail where there isn't any Taegre Mac Applications and Mac App Store 0 Jun 2, 2012 07:12 PM

Forum Jump

All times are GMT -5. The time now is 02:19 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC