Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 25, 2012, 09:15 AM   #1
OberTiger
macrumors newbie
 
Join Date: Sep 2012
Location: SE USA
Exclamation iMessage won't send messages on iPad via bluetooth tether

I tether my iPad to my iPhone5 for use during the day and around town. Prior to the iPhone 5 I was tethering to my 4 via a jailbroken tether app. Now that I have the mobile share plan, I have gone legit and am using the built in tether capabilities. When I tether over wifi, I have no problems, but when I tether over bluetooth, my iMessage can't send or receive messages. I also think there may be an issue receiving notifications while tethered over bluetooth.

Everything else works fine, safari, facebook, etc.

Any help/suggestions?
OberTiger is offline   0 Reply With Quote
Old Sep 25, 2012, 09:41 AM   #2
Ashwood11
macrumors 65816
 
Join Date: Nov 2010
Location: WA
Are you still JB?
Ashwood11 is offline   0 Reply With Quote
Old Sep 25, 2012, 11:07 AM   #3
OberTiger
Thread Starter
macrumors newbie
 
Join Date: Sep 2012
Location: SE USA
Quote:
Originally Posted by Ashwood11 View Post
Are you still JB?
No, I'm on the iPhone 5 now. I only JB'd because I wanted tethering with my old plan.
OberTiger is offline   0 Reply With Quote
Old Sep 26, 2012, 05:41 AM   #4
crowl85
macrumors newbie
 
Join Date: Sep 2012
Same probleme !!!

I have the same problem on my iPod touch !!! With Bluetooth iMessage is KO... on WIFI... no problem !
crowl85 is offline   0 Reply With Quote
Old Sep 26, 2012, 08:52 AM   #5
OberTiger
Thread Starter
macrumors newbie
 
Join Date: Sep 2012
Location: SE USA
I spoke to Apple

I spoke to Apple last night and it sounds like iMessage just doesn't know to look for a server connection through bluetooth. In other words, while safari or facebook etc will check for internet connectivity through 3G, WiFi or Bluetooth, iMessage isn't programed to look for bluetooth. Therefor iMessage thinks there is no internet connection present.

Hopefully this is something they will correct in the future because there are no techincal hurdles on why iMessage shouldn't be allowed to connect to it's servers via bluetooth tethering.
OberTiger is offline   0 Reply With Quote
Old Oct 11, 2012, 06:09 PM   #6
aquariusrick
macrumors newbie
 
Join Date: Sep 2009
I'm having the same problem with my iPad 2 WiFi, and my wife's "new" iPad (iPad 3) Wifi. The problem will occur when tethering via bluetooth, but not when tethering via WiFi. I prefer to tether via bluetooth because I can start the tethering from the iPad without having to do anything on the iPhone. To start tethering via WiFi you must go into settings and open up Personal Hotspot on the iPhone so you're WiFi access point becomes discoverable.

Here's what I tried:
First I tried resetting only the network settings, that didn't help. Then I tried a full restore, and set up as a new iPad. That also didn't work.

Other observations:
It seems like the problem isn't just limited to iMessage, but Apple and iCloud in general. For instance, after restoring the iPad and setting up as new, I used the iPhone Personal Hotspot (tethering) to connect the iPad so I could enable iMessage (so I could test). First I had to enter my apple ID and password. This part failed, presumably because it couldn't connect to Apple or iCloud at all. I also use iCloud to sync iBooks (bookmarks, notes, last page read, etc), and noticed these weren't syncing either. It seems that most (if not all) iCloud features cease to work when tethering the iPad 2 over bluetooth.

Last edited by aquariusrick; Nov 28, 2012 at 10:26 AM.
aquariusrick is offline   0 Reply With Quote
Old Oct 13, 2012, 05:45 PM   #7
jnixon02
macrumors newbie
 
Join Date: Oct 2012
Unhappy Also Notifications...

Yes I have noticed the same behavior on my iPod Touch gen 4, iPad 2, and with the latest iPod Touch Gen 5. And this only started when upgraded to iOS 6. It is clearly a bug with iOS 6 and bluetooth tether. The most annoying thing I have experienced is the notifications not working. Once I connect to WiFi then bam all the notifications come in.

I hope they fix it soon... or else I might just return this iPod Touch gen 5 and wait til they get the iOS 6 issues hammered out.
jnixon02 is offline   0 Reply With Quote
Old Nov 2, 2012, 12:13 PM   #8
aquariusrick
macrumors newbie
 
Join Date: Sep 2009
Fixed in iOS 6.0.1

It seems that this is now fixed in iOS 6.0.1!

Edit: still not working... I iMessaged myself and that worked for some reason, but otherwise, it's still as broken as ever.

Last edited by aquariusrick; Nov 7, 2012 at 08:17 PM. Reason: Incorrect
aquariusrick is offline   0 Reply With Quote
Old Nov 7, 2012, 07:48 PM   #9
pto2k
macrumors newbie
 
Join Date: Nov 2005
6.0.1 still not working for me on touch 5g
pto2k is offline   0 Reply With Quote
Old Nov 8, 2012, 11:57 AM   #10
aquariusrick
macrumors newbie
 
Join Date: Sep 2009
Feedback to Apple

I just submitted this to Apple, please do the same.
http://www.apple.com/feedback/ipad.html

Thanks!
aquariusrick is offline   0 Reply With Quote
Old Dec 3, 2012, 06:38 AM   #11
alan4k
macrumors newbie
 
Join Date: Dec 2012
Quote:
Originally Posted by aquariusrick View Post
I just submitted this to Apple, please do the same.
http://www.apple.com/feedback/ipad.html

Thanks!
Submitted today too, hurry iPad team.
alan4k is offline   0 Reply With Quote
Old Dec 3, 2012, 07:04 AM   #12
pommie82
macrumors regular
 
Join Date: Jan 2011
Location: uk
Going slightly off the topic i read a some where on the internet but when tethering you are unable to do Face-time calls while tethering either.

At the moment i'am unable to tether because the new update 6.0.1 has done something to the bluetooth connection i'am unable to get hotspot sorted out
When i connect both devices together the bluetooth hotspot blue banner doesn't appear.
pommie82 is offline   0 Reply With Quote
Old Jul 26, 2013, 12:13 PM   #13
aquariusrick
macrumors newbie
 
Join Date: Sep 2009
iOS 6.1.3 - Still broken

The problem is still not fixed in the latest version of iOS (6.1.3). Here's hoping for an iOS 7 fix!
aquariusrick is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:44 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC