Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 6, 2012, 12:00 PM   #1
Gemütlichkeit
macrumors 65816
 
Gemütlichkeit's Avatar
 
Join Date: Nov 2010
Question iMessage change in 10.8.2 between iPhone/Mac?

Am I crazy, or did text alerts stop going to the phone if messaging through Messages on OSX?

From the beta up to the release of 10.8 if you received a message via OSX it would also alert you on your phone. At least your phone would make the text sound (or vibrate).

I've been doing some tests this morning and no alerts have been arriving on my phone when chatting via Message from OSX.
__________________
"It does me no injury for my neighbor to say there are twenty gods, or no God." -Thomas Jefferson
Gemütlichkeit is offline   0 Reply With Quote
Old Oct 6, 2012, 12:30 PM   #2
iThinkergoiMac
macrumors 68030
 
Join Date: Jan 2010
Location: Terra
Mine always arrive to both my iPhone and my Mac. Are you using the latest software on both?
__________________
13" 2009 MBP, 2.26 GHz C2D, 8 GB RAM, 320 GB HDD; 2.2 GHz C2D MB, 6 GB RAM, 160 GB HDD; 32 GB iPod Touch 3G
-FWIW, my handle is iThink_ergo_iMac. There seems to be some confusion on this issue.-
iThinkergoiMac is offline   0 Reply With Quote
Old Oct 6, 2012, 12:33 PM   #3
Gemütlichkeit
Thread Starter
macrumors 65816
 
Gemütlichkeit's Avatar
 
Join Date: Nov 2010
Quote:
Originally Posted by iThinkergoiMac View Post
Mine always arrive to both my iPhone and my Mac. Are you using the latest software on both?
Yep, 10.8.2 and 6.0.

I actually like it this way and feel it should of been like this from the start. iMessage should detect that I'm using the OSX client and not alert my phone and visa versa.

Edit: never mind, for some reason they're now coming to my phone too. Bummer, it wasn't doing that for about an hour this morning.
__________________
"It does me no injury for my neighbor to say there are twenty gods, or no God." -Thomas Jefferson
Gemütlichkeit is offline   0 Reply With Quote
Old Oct 6, 2012, 12:44 PM   #4
iThinkergoiMac
macrumors 68030
 
Join Date: Jan 2010
Location: Terra
In some ways I agree. But then, I'd want those messages on my phone too. If Apple could have it so your phone DOESN'T notify you, but still receives the messages, that would be ideal. But, then, what happens if you leave Messages running on your Mac but you aren't at home?

It's a conundrum, and I think the current solution is probably best.
__________________
13" 2009 MBP, 2.26 GHz C2D, 8 GB RAM, 320 GB HDD; 2.2 GHz C2D MB, 6 GB RAM, 160 GB HDD; 32 GB iPod Touch 3G
-FWIW, my handle is iThink_ergo_iMac. There seems to be some confusion on this issue.-
iThinkergoiMac is offline   0 Reply With Quote
Old Oct 6, 2012, 12:49 PM   #5
Gemütlichkeit
Thread Starter
macrumors 65816
 
Gemütlichkeit's Avatar
 
Join Date: Nov 2010
Quote:
Originally Posted by iThinkergoiMac View Post
In some ways I agree. But then, I'd want those messages on my phone too. If Apple could have it so your phone DOESN'T notify you, but still receives the messages, that would be ideal. But, then, what happens if you leave Messages running on your Mac but you aren't at home?

It's a conundrum, and I think the current solution is probably best.
easy fix, notify both when OSX messages is idle so if you leave it on at home it will come to your phone too.

It seems a simple if/then statement could fix this. But I have a gut feeling Apple messages doesn't differentiate between messages being sent from iChat or iMessage.

This is basically the only thing I see missing from this setup. Plus it would save a little juice in my phone from not having to turn the screen on every time I get a reply on my Mac.
__________________
"It does me no injury for my neighbor to say there are twenty gods, or no God." -Thomas Jefferson
Gemütlichkeit is offline   0 Reply With Quote
Old Oct 6, 2012, 12:57 PM   #6
iThinkergoiMac
macrumors 68030
 
Join Date: Jan 2010
Location: Terra
Quote:
Originally Posted by Gemütlichkeit View Post
easy fix, notify both when OSX messages is idle so if you leave it on at home it will come to your phone too.
True, but you might still miss some messages if, for example, it takes 15 minutes for Messages to go idle.

Quote:
It seems a simple if/then statement could fix this. But I have a gut feeling Apple messages doesn't differentiate between messages being sent from iChat or iMessage.
iChat can't access the iMessage messages, only AIM, Jabber, and a few others. So there is a differentiation.

Quote:
This is basically the only thing I see missing from this setup. Plus it would save a little juice in my phone from not having to turn the screen on every time I get a reply on my Mac.
Yeah, it would save some juice, but I think it might be negligible.

There's definitely a solution, and I think you might be on to something with your first idea.
__________________
13" 2009 MBP, 2.26 GHz C2D, 8 GB RAM, 320 GB HDD; 2.2 GHz C2D MB, 6 GB RAM, 160 GB HDD; 32 GB iPod Touch 3G
-FWIW, my handle is iThink_ergo_iMac. There seems to be some confusion on this issue.-
iThinkergoiMac is offline   0 Reply With Quote
Old Oct 6, 2012, 06:01 PM   #7
kronborg
macrumors member
 
Join Date: Apr 2011
Location: Copenhagen
I get the same thing, and it's sweet. On iOS 5, my iPhone and iPad would go crazy with alerts when I was texting via Messages on my Mac. Some of the alerts would get cut off halfway through the sound, likely while receiving a 'read' update on the message.

A possible solution: When a device detects a new iMessage, wait a short moment for a possible 'read' update, and if received, don't alert the user. This has the downside of delaying the messages a bit, though.

I don't know if Apple implemented something similar with iOS 6, but now my iPhone and iPad are silent when I'm texting via my Mac. They of course still receive all messages. But, I can imagine that this system would fail when the service is unstable (and slow), like it is pretty often.
__________________
MacBook Air 13" (mid 2012) 1.8GHz, 128GB SSD, 8GB RAM · iPhone 6 64GB Space Gray · iPad 2 16GB Wi-Fi Black · ATV 3
kronborg is offline   0 Reply With Quote
Old Oct 6, 2012, 06:24 PM   #8
mrsir2009
macrumors 604
 
mrsir2009's Avatar
 
Join Date: Sep 2009
Location: Melbourne, Australia
Quote:
Originally Posted by Gemütlichkeit View Post
Yep, 10.8.2 and 6.0.

I actually like it this way and feel it should of been like this from the start. iMessage should detect that I'm using the OSX client and not alert my phone and visa versa.

Edit: never mind, for some reason they're now coming to my phone too. Bummer, it wasn't doing that for about an hour this morning.
Haha tell me about it - They all come through at once for me, making my iPhone sound like a demented robot

[EDIT: I'm on iOS5, so that'll probably be why]
mrsir2009 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
how do i change iMessage and FaceTime settings in OS X? dewthedru Mac Basics and Help 2 Mar 14, 2014 11:19 PM
ios7 iMessage number change? Packtrick iOS 7 0 Sep 19, 2013 02:54 PM
iMessage Color change fawey OS X 10.8 Mountain Lion 2 Mar 11, 2013 08:44 AM
iPad: Change phone number in iMessage on iPad? lthompson iPad 0 Dec 12, 2012 09:45 AM
No iMessage sound change? imac wannabe iOS 6 2 Sep 21, 2012 08:47 AM

Forum Jump

All times are GMT -5. The time now is 01:23 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC