Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 18, 2012, 06:13 PM   #1
dusk007
macrumors 68030
 
Join Date: Dec 2009
Terrible Mission Control performance

I wonder if anybody else has this or a similar problem.
My Mission Control animation is not just choppy the first time I use it (after some longer no use period of I don't know 30 mins) it needs about 2 seconds and has nothing that could be called a fluid animations. Immediately repeating the same thing 3-5 times and I get a fluid animation.
It is as if it was optimizing the animation when needed and only then loading generating the preview windows that initial run.

There is also a huge difference between when a full screen VM (VMWare 4 Win8) is running, even if it is on a difference space and in stand by(which means only a big black nothing).
Also not combining the windows to apps seems to be terribly optimized much slower and bad arrangement.

I once tried creating a new user with new setting but that only initially seemed to help. With the same load it did just the same.

I use a 15" MBP 2010 HD (256MB 330M) with a 1080p external screen.

I works well enough if I shutdown the VM and frequently trigger the MC. That way it doesn't unload but simply redo the prepared animation. However typ a little in word and only use Chrome on the other window and ignore MC for a while and the next use is seriously annoying again.
It is the same to a not so incredibly slow degree with left right desktop switching or crtl+1..4 direct jump.

I never did a clean install because I got so many settings and stuff that not transferring any settings would take me 2 weeks to be back to normal again. Finding the responsible OSX only settings is real hard and user settings didn't seem to cut it.

I wonder if anybody else has similar problems and somehow resolved them, or if people just not really tax the system, all have newer systems, or just take it as normal that MC needs a warm up.

Snow Leopard never had any such problem. App Exposť was always fast, spaces never stalled for a millisecond and normal exposť wasn't choppy either. I have more or less stopped using MC because it is so slow and only switch via Alfred or Dock between Apps. App Exposť is something I really liked to to switch between Windows of one app. Alfred is no help and alt+tab isn't efficient.
dusk007 is offline   0 Reply With Quote
Old Oct 26, 2012, 08:38 PM   #2
sshhoott
macrumors 6502
 
Join Date: Feb 2010
Quote:
Originally Posted by dusk007 View Post
I wonder if anybody else has this or a similar problem.
My Mission Control animation is not just choppy the first time I use it (after some longer no use period of I don't know 30 mins) it needs about 2 seconds and has nothing that could be called a fluid animations. Immediately repeating the same thing 3-5 times and I get a fluid animation.
It is as if it was optimizing the animation when needed and only then loading generating the preview windows that initial run.

There is also a huge difference between when a full screen VM (VMWare 4 Win8) is running, even if it is on a difference space and in stand by(which means only a big black nothing).
Also not combining the windows to apps seems to be terribly optimized much slower and bad arrangement.

I once tried creating a new user with new setting but that only initially seemed to help. With the same load it did just the same.

I use a 15" MBP 2010 HD (256MB 330M) with a 1080p external screen.

I works well enough if I shutdown the VM and frequently trigger the MC. That way it doesn't unload but simply redo the prepared animation. However typ a little in word and only use Chrome on the other window and ignore MC for a while and the next use is seriously annoying again.
It is the same to a not so incredibly slow degree with left right desktop switching or crtl+1..4 direct jump.

I never did a clean install because I got so many settings and stuff that not transferring any settings would take me 2 weeks to be back to normal again. Finding the responsible OSX only settings is real hard and user settings didn't seem to cut it.

I wonder if anybody else has similar problems and somehow resolved them, or if people just not really tax the system, all have newer systems, or just take it as normal that MC needs a warm up.

Snow Leopard never had any such problem. App Exposť was always fast, spaces never stalled for a millisecond and normal exposť wasn't choppy either. I have more or less stopped using MC because it is so slow and only switch via Alfred or Dock between Apps. App Exposť is something I really liked to to switch between Windows of one app. Alfred is no help and alt+tab isn't efficient.
I experience a similar problem. MC is choppy for the first time you use it and then gets better. Furthermore if I leave my MBP 13" 2010 on for days, the animations get very choppy and start to stutter. The graphic cards we have should be easily able to create fluid animations. Apple should realize that this is not a cheap iPhone, Macs deserve to be kept up to date for at least 5 years with proper performance, its an expensive machine after all.

The only way to fix this is to "pressure" Apple, so they can make better drivers for Macs with Nvidia graphics.

Give them feedback here:

http://www.apple.com/feedback/macosx.html
sshhoott is offline   1 Reply With Quote
Old Oct 27, 2012, 05:18 AM   #3
colloc
macrumors member
 
Join Date: Jul 2012
Quote:
Originally Posted by dusk007 View Post
I wonder if anybody else has this or a similar problem.
My Mission Control animation is not just choppy the first time I use it (after some longer no use period of I don't know 30 mins) it needs about 2 seconds and has nothing that could be called a fluid animations. Immediately repeating the same thing 3-5 times and I get a fluid animation.
It is as if it was optimizing the animation when needed and only then loading generating the preview windows that initial run.

There is also a huge difference between when a full screen VM (VMWare 4 Win8) is running, even if it is on a difference space and in stand by(which means only a big black nothing).
Also not combining the windows to apps seems to be terribly optimized much slower and bad arrangement.

I once tried creating a new user with new setting but that only initially seemed to help. With the same load it did just the same.

I use a 15" MBP 2010 HD (256MB 330M) with a 1080p external screen.

I works well enough if I shutdown the VM and frequently trigger the MC. That way it doesn't unload but simply redo the prepared animation. However typ a little in word and only use Chrome on the other window and ignore MC for a while and the next use is seriously annoying again.
It is the same to a not so incredibly slow degree with left right desktop switching or crtl+1..4 direct jump.

I never did a clean install because I got so many settings and stuff that not transferring any settings would take me 2 weeks to be back to normal again. Finding the responsible OSX only settings is real hard and user settings didn't seem to cut it.

I wonder if anybody else has similar problems and somehow resolved them, or if people just not really tax the system, all have newer systems, or just take it as normal that MC needs a warm up.

Snow Leopard never had any such problem. App Exposť was always fast, spaces never stalled for a millisecond and normal exposť wasn't choppy either. I have more or less stopped using MC because it is so slow and only switch via Alfred or Dock between Apps. App Exposť is something I really liked to to switch between Windows of one app. Alfred is no help and alt+tab isn't efficient.
I recommend you upgrade your Mac to an SSD. I experienced the same issue as you before upgrading my Mac's HDD to an SSD, and yes I can agree with you it was freaking annoying, it destroys everything gestures were meant to be in the first place: ease of access. After upgrading to an SSD everything is now snappy.
I would say that ML and subsequent OS X versions will be more geared for SSD-powered Macs (like the newly introduced retina MacBooks)
colloc is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mission Control not working rtan OS X Mavericks (10.9) 0 Feb 6, 2014 08:03 AM
Mission Control response sonicrobby OS X Mavericks (10.9) 8 Oct 14, 2013 02:11 AM
OS X: 10.8.2 Terrible Performance Sambo110 Mac and PC Games 5 Oct 27, 2012 03:18 PM
Mac crashes when using control panel, expose or mission control AdamTwosleeves Mac OS X 10.7 Lion 1 Aug 21, 2012 11:17 PM
Mission Control & Command-Control Key Swap Babyboi Windows, Linux & Others on the Mac 0 Aug 2, 2012 11:58 PM

Forum Jump

All times are GMT -5. The time now is 03:10 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC