Go Back   MacRumors Forums > iPhone, iPod and iPad > iPod

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 6, 2012, 04:03 PM   #1
AT101ET
macrumors 6502
 
Join Date: Jun 2012
Location: UK (London)
iPod Nano 3G 8GB Help???

Hi,
I need some help with my iPod Nano 3G.
It doesn't seem to power up, but when I put in in my PC, it detects a storage device has been put in. iTunes automatically opened up and it said that the iPod needed recovery so I clicked OK, and it said the process had began, and the status bar showed it was complete.
However, now my iPod still doesn't work and doesn't show in iTunes.
Any suggestions?

Thanks
AT101ET is offline   0 Reply With Quote
Old Nov 17, 2012, 04:20 PM   #2
yateseyd1991
macrumors regular
 
Join Date: Jun 2011
Location: UK
Sounds like a logic board problem, I'd take it to Apple and see what they say, I believe they still have these in stock to replace, but at OOW price (about 65).

I notice you're a bit of an iPod collector from another thread, is this iPod brand new?

iPhone 5 32GB White, iPad 3 16GB Black, iPhone 2G Sealed, iPod Video 5.5G 120GB, Shure SE425's
yateseyd1991 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPod

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump

All times are GMT -5. The time now is 12:05 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC