Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 14, 2012, 04:42 PM   #1
panda bear
macrumors 68000
 
panda bear's Avatar
 
Join Date: Apr 2010
Messages on iMac

Hi, I have been using the Messages app on my iMac for quite some time now with minimal problems. I'd have a hiccup here or there, but as of late, I can't use it at all.

I recently purchased an iPad Mini and I have an iPhone 5 and iMessage works seamlessly across these two devices.

Now it won't work on my iMac.

I have tried to go through all the help articles. I made sure all my devices are logged in with the same Apple ID. I have a separate ID for my iTunes account (@gmail) and my iCloud (@me).

I want all 3 devices to ONLY use my phone number. I do not want my email to be used in any instance, which I thought would make it easier, since I know that some people have problems because they have various emails they use for iMessage.

Please help me . I have been spoiled by being able to text some people via my computer and i'm getting fed up to the point that I may take my iMac in to the Apple Store just so they can set it up for me

Last edited by panda bear; Nov 16, 2012 at 03:05 PM.
panda bear is offline   0 Reply With Quote
Old Nov 15, 2012, 02:42 AM   #2
satcomer
macrumors 68040
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
Are you using the same iTunes account on all the devices? Did you go into the Message app Preferences, Accounts and set it up properly?
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is online now   0 Reply With Quote
Old Nov 15, 2012, 09:06 AM   #3
panda bear
Thread Starter
macrumors 68000
 
panda bear's Avatar
 
Join Date: Apr 2010
Yes, I logged out of all 3 devices and actually logged back in. I am definitely using the same Apple ID on all 3. And the phone number is the only "address" that can be used to contact me, so there is no discrepancy there.
panda bear is offline   0 Reply With Quote
Old Nov 16, 2012, 11:35 AM   #4
satcomer
macrumors 68040
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
Then open Messages and the go to Messages menu item "Preferences". In Messages Preferences click on the 'Accounts' mini-tab and then put a checkmark in what account boxes you want to use in that Messages app.
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is online now   0 Reply With Quote
Old Nov 16, 2012, 02:48 PM   #5
panda bear
Thread Starter
macrumors 68000
 
panda bear's Avatar
 
Join Date: Apr 2010
Quote:
Originally Posted by satcomer View Post
Then open Messages and the go to Messages menu item "Preferences". In Messages Preferences click on the 'Accounts' mini-tab and then put a checkmark in what account boxes you want to use in that Messages app.
I did that as well. There is only a check mark next to my phone number.

I even get the message on my iPhone that says my iMac is using my phone number.

Still doesn't work.
panda bear is offline   0 Reply With Quote
Old Nov 16, 2012, 02:54 PM   #6
satcomer
macrumors 68040
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
Then choose you email. Plus do you have cell numbers in Contacts of the person sending you the Messages? Plus put a checkmark in you email Address with iCloud. Then tell people sending you messages to use your iCloud account. This should fix your problem.
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is online now   0 Reply With Quote
Old Nov 16, 2012, 03:04 PM   #7
SandboxGeneral
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: Great Lakes State
Maybe you need someone to send you a message from their Mac to yours to get it to work!
__________________
Magnificent Seventh
SandboxGeneral is online now   0 Reply With Quote
Old Nov 16, 2012, 03:05 PM   #8
panda bear
Thread Starter
macrumors 68000
 
panda bear's Avatar
 
Join Date: Apr 2010
Quote:
Originally Posted by satcomer View Post
Then choose you email. Plus do you have cell numbers in Contacts of the person sending you the Messages? Plus put a checkmark in you email Address with iCloud. Then tell people sending you messages to use your iCloud account. This should fix your problem.
I don't want to use my email. I want to only use my phone number.

BUT

My nice friend SandboxGeneral simply asked me if i've restarted my computer since i've had the problem.. so I did. And now it works.

Thanks for your help, satcomer. I knew it was all set up correctly, so it was really irritating me that it wasn't working.
panda bear is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:44 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC