Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 8, 2012, 07:15 PM   #1
Ohlias
macrumors newbie
 
Join Date: Sep 2011
2011 MBA MagSafe slow to begin charging...

I've noticed lately that when I plug my magsafe connector, it can take anywhere from 5 to 10 minutes (sometimes more) before the little orate/green light will come and an actually begin charging. This issue is sporadic and can happen when the battery is at 3% or 100%.

Is this normal?

The connector is not damaged, and sits flush.
Ohlias is offline   0 Reply With Quote
Old Nov 8, 2012, 07:37 PM   #2
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Quote:
Originally Posted by Ohlias View Post
I've noticed lately that when I plug my magsafe connector, it can take anywhere from 5 to 10 minutes (sometimes more) before the little orate/green light will come and an actually begin charging. This issue is sporadic and can happen when the battery is at 3% or 100%.

Is this normal?

The connector is not damaged, and sits flush.
It's normal for there to be a slight delay before it begins charging, but 5-10 minutes or longer doesn't sound right. Have Apple check it out to make sure your adapter isn't defective.

The link below should answer most, if not all, of your battery/charging questions. If you haven't already done so, I highly recommend you take the time to read it.
Apple Notebook Battery FAQ
GGJstudios is offline   0 Reply With Quote
Old Nov 12, 2012, 12:25 PM   #3
SandPebble
macrumors member
 
Join Date: Oct 2012
I had the same issue. I unplugged the charger from the wall for a few hours. My MBA now starts charging a few seconds after attaching the magsafe.
__________________
iPhone 4s, iPad 2, MBA 11"
SandPebble is offline   1 Reply With Quote
Old Nov 12, 2012, 01:12 PM   #4
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Clean the power connector at both ends. Use a compressed air can first.
Mrbobb is offline   0 Reply With Quote
Old Nov 16, 2012, 09:26 AM   #5
Ohlias
Thread Starter
macrumors newbie
 
Join Date: Sep 2011
Thumbs up

Quote:
Originally Posted by SandPebble View Post
I had the same issue. I unplugged the charger from the wall for a few hours. My MBA now starts charging a few seconds after attaching the magsafe.
Did this, seems to have solved the issue for several days now. Thanks!
Ohlias is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:51 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC