Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 15, 2012, 10:19 AM   #1
robob
macrumors newbie
 
Join Date: Nov 2012
HP C4400 printer reset issues

I have a iMac using Mac OS X 10.6.

I reset my HP C4400 printer in the Print & Fax directory of System Preferences, because it was showing as offline and i thought this might solve the problem. When i went back to try and add the printer again it doesn`t show up anywhere. I tried uninstalling and reinstalling the latest Hp drivers and software, i also did the usual mac maintenance, but my mac still doesn`t recognize it.

Any suggestions?
robob is offline   0 Reply With Quote
Old Nov 15, 2012, 11:38 AM   #2
Knoodles
macrumors 6502
 
Join Date: Feb 2003
Location: Gone to the Beach
Power cycle the printer.
Power cycle the Mac.
Try a different USB cable.
Try a different USB port.
Knoodles is offline   0 Reply With Quote
Old Nov 15, 2012, 07:44 PM   #3
JediMeister
macrumors 68040
 
Join Date: Oct 2008
Is your printer set up through USB or as a network/Wi-Fi printer? If the printer isn't recognized through USB-connection, you may either have a bad port on the Mac, need to replace the USB cable itself, or the printer has given up the ghost. If it's a network printer, do you know if its Bonjour-compatible? If not, you may need to add it by IP address. You can usually pull the IP of the printer somewhere in the menus or by printing a configuration page.

Mac OS X supports Internet Printing Protocol (IPP), Line Printer Daemon (LPD), and HP JetDirect (Socket). You can try each in succession, but make sure that OS X doesn't use the Generic PostScript Printer driver, it should be matched with the HP C4400 series. You can manually select the driver by clicking the drop-down and choosing Select Printer Software and filtering the available results. If you can't find your particular model in the list, try downloading the latest drivers from HP's website.
JediMeister is offline   0 Reply With Quote
Old Nov 16, 2012, 04:38 AM   #4
robob
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Problem solved!

Replaced the cable and all is fine now. Thanks for your help guys!
robob is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:54 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC