Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 17, 2012, 05:16 AM   #1
Washac
macrumors 68000
 
Join Date: Jul 2006
Better Graphics Card Worse Results

Firstly the machine specs

Mac Pro 2009 4,1
Mountain Lion 10.8.2
Quad-Core Intel Xeon 2.66 GHZ
Memory 6 GB
XFX Radeon HD6870 card

Yesterday I swapped out the Radeon HD4870 card for the 6870 and updated the kext file, before I did this I could play GW2 at medium settings with good results now the game lags all the time, IE: When moving through the game world its all speed up slow down not good at all.

Same machine but running the game under Windows 7 in Bootcamp and it all runs fine with higher settings.
__________________
Mac Pro 2.66 Ghz Quad-Core Intel Xeon 6 GB RAM 24inch ACD Mavericks 10.9.4/XFX Radeon HD 6870, HD-687A-ZDFC-20inch Alu iMac Snow Leopard 10.6.8

Last edited by Washac; Nov 17, 2012 at 06:37 AM.
Washac is offline   0 Reply With Quote
Old Nov 19, 2012, 11:38 AM   #2
ActionableMango
macrumors 68040
 
ActionableMango's Avatar
 
Join Date: Sep 2010
Sounds like HW acceleration (QE/CI) is not working in OS X, so you have a driver issue.
ActionableMango is offline   0 Reply With Quote
Old Nov 20, 2012, 03:06 PM   #3
MacVidCards
macrumors 603
 
Join Date: Nov 2008
Location: Hollywood, CA
 
Quote:
Originally Posted by Washac View Post
updated the kext file

???

What did you do and where did you read about it?
MacVidCards is offline   0 Reply With Quote
Old Nov 21, 2012, 11:09 AM   #4
Washac
Thread Starter
macrumors 68000
 
Join Date: Jul 2006
Quote:
Originally Posted by MacVidCards View Post
???

What did you do and where did you read about it?
Here - http://www.groths.org/?p=431

But I only used the ATY_Init.kext file and the Kext Helper b7 to install it.

The ATI Graphics Update.pkg I left well alone.
__________________
Mac Pro 2.66 Ghz Quad-Core Intel Xeon 6 GB RAM 24inch ACD Mavericks 10.9.4/XFX Radeon HD 6870, HD-687A-ZDFC-20inch Alu iMac Snow Leopard 10.6.8
Washac is offline   0 Reply With Quote
Old Nov 21, 2012, 11:43 AM   #5
Asgorath
macrumors 6502a
 
Join Date: Mar 2012
Weren't you the guy who initially said he didn't want to mess with non-standard cards, and thus ruled out a modern NVIDIA card? You realize that a Fermi or Kepler generation card would've worked right out of the box, no need for third party hacks or custom drivers? Can't help but think it would've been easier to just get a GTX 680 or something.

I don't know anything about AMD cards so hopefully someone else can help you figure this out.
Asgorath is offline   0 Reply With Quote
Old Nov 21, 2012, 12:30 PM   #6
ActionableMango
macrumors 68040
 
ActionableMango's Avatar
 
Join Date: Sep 2010
OP, I noticed you had a thread about flashing your 6870. ATY_init should not be used with flashed cards.

Quote:
Originally Posted by Asgorath View Post
Weren't you the guy who initially said he didn't want to mess with non-standard cards, and thus ruled out a modern NVIDIA card? You realize that a Fermi or Kepler generation card would've worked right out of the box, no need for third party hacks or custom drivers? Can't help but think it would've been easier to just get a GTX 680 or something.
As I recall, one of his requirements was to have boot screens maybe?
ActionableMango is offline   0 Reply With Quote
Old Nov 21, 2012, 12:32 PM   #7
Washac
Thread Starter
macrumors 68000
 
Join Date: Jul 2006
Quote:
Originally Posted by Asgorath View Post
Weren't you the guy who initially said he didn't want to mess with non-standard cards, and thus ruled out a modern NVIDIA card? You realize that a Fermi or Kepler generation card would've worked right out of the box, no need for third party hacks or custom drivers? Can't help but think it would've been easier to just get a GTX 680 or something.

I don't know anything about AMD cards so hopefully someone else can help you figure this out.
why I did not buy a GTX 680, the cost.

----------

Quote:
Originally Posted by ActionableMango View Post
OP, I noticed you had a thread about flashing your 6870. ATY_init should not be used with flashed cards.
I have NOT flashed the card.
__________________
Mac Pro 2.66 Ghz Quad-Core Intel Xeon 6 GB RAM 24inch ACD Mavericks 10.9.4/XFX Radeon HD 6870, HD-687A-ZDFC-20inch Alu iMac Snow Leopard 10.6.8
Washac is offline   0 Reply With Quote
Old Nov 21, 2012, 12:47 PM   #8
Loa
macrumors 65816
 
Join Date: May 2003
Location: Québec
Hello,

I have the 6870 in my 2009MP, and it's working very well. I simply plugged it in and booted up. No drivers, no nothing. Try it with the init file removed.

Loa
Loa is offline   0 Reply With Quote
Old Nov 21, 2012, 12:48 PM   #9
ActionableMango
macrumors 68040
 
ActionableMango's Avatar
 
Join Date: Sep 2010
Quote:
Originally Posted by Washac View Post
I have NOT flashed the card.
Probably ATY_init was not installed properly then. Try playing a DVD in DVD player. If it doesn't work, that's your problem.
ActionableMango is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Sonnet TB2 card upgrade results dysert Mac Pro 8 Feb 15, 2014 12:54 AM
7 weeks later, those animations are getting worse and worse. TC03 iOS 7 86 Nov 12, 2013 09:12 PM
OS X: Graphics Card Benchmarks - post your results here Jethryn Freyman Mac and PC Games 6 May 11, 2013 10:59 PM
rMBP Mountain Lion Graphics UI Performance Worse mattkidd MacBook Pro 55 Jul 31, 2012 09:21 PM
Mountain Lion has nice graphics results! BlindSoul OS X 10.8 Mountain Lion 12 Jul 15, 2012 10:09 AM

Forum Jump

All times are GMT -5. The time now is 08:30 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC