Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > Mac mini

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 22, 2012, 01:07 AM   #1
Rob.G
macrumors 6502
 
Join Date: Jan 2010
Location: NW Oregon
2012 Mini SSD Installation Successful

Tonight I finally decided to put the SSD drive in my new Mini that showed up on Monday. I had been humming and hawing about it, debating between doing it and going with a USB 3.0 enclosure. I called the local Apple store and asked them very specifically, "if I put another hard drive in my Mini, will it void my warranty?" The guy put me on hold and went to ask the techs. He came back and said no, it won't void the warranty; it just won't cover the hard drive you put in. Naturally. So, I decided to go for it.

I used the OWC video as my guide. I had it playing on my iPad as I worked, so I could pause/rewind as needed. The entire process took about 20 minutes.

Now, these super-duper fragile connectors everybody is talking about. They aren't that fragile. I mean, yeah, they're fragile, but if you follow the video exactly and use the little plastic pry tool, they all come off easily enough, and go back on plenty easy as well. Just take your time. With the exception of the power supply connector, they all pop UP, so getting them loose is really quite simple.

I decided to move the 1TB drive to the bottom bay (which in hindsight was probably a dumb idea). To get everything to fit, I had to put the OWC cable on the 1TB drive and the original cable on the new drive (a Samsung 840 Pro 256 GB SSD). I also had to move the "pins" from the old drive to the SSD. Those suckers are in TIGHT (with blue Lock-tite no less). I used a 5/16" box-end wrench on the end of the T8 torx tool to pop 'em loose.

When installing the rubber grommets into the second drive bracket, be very careful when working on the side of the bracket near the IR sensor. It's very easy to bump it.

That's pretty much it. Once done, I booted up from the original drive, ran Carbon Copy Cloner, and cloned it over to the SSD (after partitioning it). That took about a half hour, as I only had 60 gig of stuff on it so far.

Rob
__________________
Late 2012 Mac Mini 2.6 i7/16gb/256gb SSD/1tb HD
Late 2013 rMBP 13 i5/16gb/512gb SSD
Galaxy Note 3 32gb AT&T
Rob.G is offline   1 Reply With Quote
Old Nov 22, 2012, 02:22 AM   #2
ibizan
macrumors newbie
 
Join Date: Nov 2012
Quote:
Originally Posted by Rob.G View Post
I decided to move the 1TB drive to the bottom bay (which in hindsight was probably a dumb idea).
I was hoping to do this same operation soon; was wondering why you felt switching the drive order was a bad idea? Was it because of the SATA cables or did switching the HD and SSD affect the Mini's performance somehow?
ibizan is offline   0 Reply With Quote
Old Nov 22, 2012, 03:24 AM   #3
antithema
macrumors member
 
Join Date: Jan 2010
If you thing that ssd stays cooler when the hdd warms its probably better to keep the hdd closer to the fan. That was my thought actually + if you want to replace the hdd with a second ssd in the future you will have to do the whole thing again.
antithema is offline   0 Reply With Quote
Old Nov 22, 2012, 09:05 AM   #4
kobyh15
macrumors 6502a
 
Join Date: Jan 2011
Quote:
Originally Posted by Rob.G View Post
Tonight I finally decided to put the SSD drive in my new Mini that showed up on Monday. I had been humming and hawing about it, debating between doing it and going with a USB 3.0 enclosure. I called the local Apple store and asked them very specifically, "if I put another hard drive in my Mini, will it void my warranty?" The guy put me on hold and went to ask the techs. He came back and said no, it won't void the warranty; it just won't cover the hard drive you put in. Naturally. So, I decided to go for it.

I used the OWC video as my guide. I had it playing on my iPad as I worked, so I could pause/rewind as needed. The entire process took about 20 minutes.

Now, these super-duper fragile connectors everybody is talking about. They aren't that fragile. I mean, yeah, they're fragile, but if you follow the video exactly and use the little plastic pry tool, they all come off easily enough, and go back on plenty easy as well. Just take your time. With the exception of the power supply connector, they all pop UP, so getting them loose is really quite simple.

I decided to move the 1TB drive to the bottom bay (which in hindsight was probably a dumb idea). To get everything to fit, I had to put the OWC cable on the 1TB drive and the original cable on the new drive (a Samsung 840 Pro 256 GB SSD). I also had to move the "pins" from the old drive to the SSD. Those suckers are in TIGHT (with blue Lock-tite no less). I used a 5/16" box-end wrench on the end of the T8 torx tool to pop 'em loose.

When installing the rubber grommets into the second drive bracket, be very careful when working on the side of the bracket near the IR sensor. It's very easy to bump it.

That's pretty much it. Once done, I booted up from the original drive, ran Carbon Copy Cloner, and cloned it over to the SSD (after partitioning it). That took about a half hour, as I only had 60 gig of stuff on it so far.

Rob
I've read of some 840 Pros bricking. I'm pretty sure 2 of Anand's review samples bricked. He seems to think it is a firmware issue. Just be careful and make sure you have a backup plan.

Last edited by kobyh15; Nov 22, 2012 at 09:38 AM.
kobyh15 is offline   0 Reply With Quote
Old Nov 22, 2012, 10:01 AM   #5
xlii
macrumors 68000
 
xlii's Avatar
 
Join Date: Sep 2006
Location: Millis, Massachusetts
Quote:
Originally Posted by Rob.G View Post
Now, these super-duper fragile connectors everybody is talking about. They aren't that fragile. I mean, yeah, they're fragile, but if you follow the video exactly and use the little plastic pry tool, they all come off easily enough, and go back on plenty easy as well. Just take your time. With the exception of the power supply connector, they all pop UP, so getting them loose is really quite simple.

When installing the rubber grommets into the second drive bracket, be very careful when working on the side of the bracket near the IR sensor. It's very easy to bump it.
Rob
Rob, thanks for posting this. I got my ssd yesterday and the OWC kit is due in tomorrow. I won't be able to do this install until Monday. My biggest concern was the connectors... thanks for your insight. I was thinking if I should move the HDD to the bottom but after reading this thread I will keep it where it currently is installed.

I'm most likely to do the installation and use command +R to initialize as a fusion drive and start the installation. I will then use my time machine backup to reinstall all my stuff (650 gbytes).
xlii is offline   0 Reply With Quote
Old Nov 22, 2012, 10:55 AM   #6
Rob.G
Thread Starter
macrumors 6502
 
Join Date: Jan 2010
Location: NW Oregon
I'm actually glad now that I moved the hard drive... since it's now closer to the fan.

Actually the reasoning at the time was that the boot drive should be on the first SATA connector. But after doing the install and booting, it took the original partition as the default anyway, so I thought well, maybe it didn't need it. And so yeah, I figured crap, if I have to replace the HD, I have to do the whole job over. But now that it was pointed out that the HD is closer to the fan, it's a good thing.

Thanks for the tip on the 840's bricking. I just CCC'd the drive over to my USB 3.0 external. I'll keep that up to date. Any idea how long these things last before they quit? Like, if it gets past 30-60 days, it's fine?


Oh... a tip on the logic board I forgot to include earlier... while it is in kinda tight, it really isn't that bad. Again, just be slow and careful. When putting it back in, as you get close to all the way in, pay special attention to the back panel (where the ports are) -- there are some tabs or clips or whatever you want to call them, on the edges, that need to go into place for the board to go in all the way. This wasn't mentioned in the video or printed instructions.

Rob
__________________
Late 2012 Mac Mini 2.6 i7/16gb/256gb SSD/1tb HD
Late 2013 rMBP 13 i5/16gb/512gb SSD
Galaxy Note 3 32gb AT&T
Rob.G is offline   0 Reply With Quote
Old Nov 22, 2012, 11:16 AM   #7
Rob.G
Thread Starter
macrumors 6502
 
Join Date: Jan 2010
Location: NW Oregon
It was still taking the original boot drive (the 1 TB) as the primary, even with the SSD installed and cloned properly. After rebooting to test my cloned backup on my USB 3 external, I rebooted again regularly, and was disappointed that the SSD didn't seem faster. Then I went to Disk Utility to wipe the 1 TB drive, and it wouldn't let me. D'oh. It booted from the HD. So I had to reboot again and specifically select the SSD. Then it FLEW. Then I was able to wipe the 1 TB drive.

Is there a way to specify a particular drive or partition as the default when there are multiple bootable drives for the computer to choose from?

Rob
__________________
Late 2012 Mac Mini 2.6 i7/16gb/256gb SSD/1tb HD
Late 2013 rMBP 13 i5/16gb/512gb SSD
Galaxy Note 3 32gb AT&T
Rob.G is offline   0 Reply With Quote
Old Nov 22, 2012, 11:23 AM   #8
Dduval
macrumors member
 
Join Date: Nov 2012
Go to preferences, then start up disk, select the one you want to boot from.
__________________
------------------------------------------------
2011 27" iMac 3.1ghz 256gb SSD, iPad Air, iPad 2, iPad 3, iPhone 4,
iPod Touch, iPod mini.
Dduval is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > Mac mini

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Clone retina MBP SSD to a Samsung SSD to use in a 2012 Mac Mini? RTF Mac mini 3 Dec 24, 2013 08:00 PM
Adding a second SSD to 2012 Mini -- Boot from OEM SSD or 840 Pro? ombudsman Mac mini 5 Jun 23, 2013 02:25 AM
2012 Mini 2.6 Internal SSD and USB3 External SSD speed test propower Mac mini 44 Jan 21, 2013 03:29 PM
2012 cMBP + M4 SSD = unbelievably slow ML installation dops7107 OS X 10.8 Mountain Lion 4 Sep 6, 2012 09:29 AM

Forum Jump

All times are GMT -5. The time now is 05:30 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC