Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread Display Modes
Old Nov 27, 2012, 01:25 PM   #1
Join Date: Nov 2012
iPhoto and iMovie won't update

Ok so I purchased a new Macbook Air but under updates it says I need to update iPhoto and iMovie but whenever i try to update it, it says its under a different account? I tried googling how to resolve it but so for nothings worked. Anyone had this issue?
Steevie is offline   0 Reply With Quote
Old Nov 27, 2012, 02:56 PM   #2
Weaselboy's Avatar
Join Date: Jan 2005
Location: California
It sounds like you are logged in to the App store with a different AppleID than the one used to do the original DL of those apps.
Weaselboy is online now   0 Reply With Quote

MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhoto, iMovie, GarageBand, ect... Update in Mavericks qnssekr OS X Mavericks (10.9) 0 Oct 22, 2013 06:56 PM
iMovie and iPhoto won't install on iPhone 3GS with iOS 6.1 Zendokan iPhone Tips, Help and Troubleshooting 2 Feb 25, 2013 08:46 AM
iPhoto & iMovie Update Aragorn234 OS X 0 Jul 28, 2012 05:07 AM
iPhoto, Aperture and iMovie - won't update Freis968 OS X 10.8 Mountain Lion 4 Jul 28, 2012 01:46 AM
can i update iPhoto/ iMovie? aPple nErd iMac 1 Jun 29, 2012 10:24 AM

Forum Jump

All times are GMT -5. The time now is 01:15 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2015, MacRumors.com, LLC