Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread Display Modes
Old Feb 22, 2009, 03:56 PM   #1
macrumors 65816
madog's Avatar
Join Date: Nov 2004
Location: Korova Milkbar
Single-User Mode, Input Problem

I'm attempting to run the fsck command in single-user mode as part of my random maintenance (cause I'm too lazy to find my Leopard disk), but ran into a slight problem.

When I plug in my USB keyboard for this (otherwise I use BT) the keyboard works fine. As far as I can tell every key works when the system is running, and there is no problem getting into single-user mode at startup. However, the keyboard no longer works once in single-user mode. I can't type anything in or use the stop process command (something like ctrl or alt and Z or X or C, I couldn't remember so I tried them all).

I thought maybe the computer was frozen in single-user mode, but here's the strange thing, it's 'working'. If I unplug my external BT card, some error will report on the screen about the connection, and the same if I plug it in if it wasn't to begin with.

So basically, I can boot into SU mode, the machine does not crash, but I can't type anything in.

I don't have another USB keyboard atm, as the one I have is the backup to the BT,

I do have a USB 2.0 PCI card which I tried with the keyboard plugged into it, as well as directly into the original USB ports,

I tried unplugging all my peripherals except the PCI card (and keyboard).

Any insight to this would be much appreciated! Thanks,

EDIT: I don't know how, or why, but after attempting it again while using a powered USB hub (before the keyboard was plugged directly into the tower, no hub) I was able to successfully input commands with my keyboard in SU mode. Other than that, the only thing that has changed was a power outage which lead me to reset the PMU on my logic board. Strange and possibly unrelated, but I thought I'd mention it.
CLEAN INSTALL - Format your hard drive, install your operating system of choice, install applications, and manually copy over personal data. For a good, clean feeling that lasts.

Last edited by madog; Apr 6, 2009 at 01:33 AM.
madog is offline   0 Reply With Quote
Old Feb 22, 2009, 04:14 PM   #2
macrumors 601
BlueRevolution's Avatar
Join Date: Jul 2004
Location: Montreal, QC
I can't help you with the keyboard issues, but the stop process combo in UNIX is ^C.
PIRATE PARTY OF CANADA Information leadership for the 21st century
BlueRevolution is offline   0 Reply With Quote
Old Feb 22, 2009, 04:33 PM   #3
Moderator emeritus
angelwatt's Avatar
Join Date: Aug 2005
Location: USA
System Preferences > Bluetooth > Advanced

There's a check box for "Open Bluetooth Setup Assistant at startup when no device is present." It's possible there's a conflict going on here between the Bluetooth ad USB devices. I would try unchecking the box to see if it improves the situation. No guarantees, but worth a shot.
angelwatt is offline   0 Reply With Quote
Old Apr 23, 2011, 08:49 PM   #4
macrumors newbie
Join Date: Apr 2011
Has anyone figured out a solution to this problem>? I have a few imacs and i find it is with the ones operating 10.6 or higher, i am using a dell keyboard. it also seems to happen on the late 2009 and early 2010 a1331 imac , it works on the 2008 line of imacs... The signle user starts up when i hold the Windowes key + S at the same time but when it comes time to input text its as if the keyboard no longer works, but if i unplug the keyboard and plug it back in the command prompt sees that.... Any suggestions? I would love to be able to solve this problem. Thank you

Last edited by ravemeover; Apr 23, 2011 at 08:55 PM.
ravemeover is offline   0 Reply With Quote
Old Nov 28, 2012, 01:48 PM   #5
macrumors newbie
Join Date: Nov 2012
you need an older keyboard!

Believe it or not the new thin silver keyboards will not allow text entry at the single user window on an older (2007 and earlier I think) Mac. If you have an older white plastic apple keyboard use that. It will work!
falconneil is offline   0 Reply With Quote

MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Disable the root account using single user mode Mcgode OS X 10.8 Mountain Lion 0 Feb 24, 2014 12:43 AM
How to get into single user mode on new macbook air Pie13 Mac Basics and Help 11 Oct 16, 2013 03:40 AM
Disabling Single User Mode 10.6.8 Macman671 Mac Basics and Help 3 Oct 15, 2013 09:15 AM
Single user mode in MAC OS X omni1787 OS X 5 Mar 21, 2013 11:07 AM
Need help in Single User Mode - Avast crashed my computer Cynelle Mac Basics and Help 6 Mar 1, 2013 07:09 PM

Forum Jump

All times are GMT -5. The time now is 02:32 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2015, MacRumors.com, LLC