Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 30, 2012, 08:21 PM   #1
jbsmithmac
macrumors regular
 
Join Date: Sep 2011
Unable to Restore ATV2

When I plug in my ATV2 via USB only and click restore, Itunes tells me "device cannot be found". It doesn't give any error number or anything...just this popup window with that message.

Itunes seems to see the ATV, but it won't restore it. Any ideas how to fix this?

I'm running Itunes 11 and the ATV is jailbroken with Firecore (atvFlash) from about a year ago...I'm trying to get back to factory Apple settings (un-jailbreak).
jbsmithmac is offline   0 Reply With Quote
Old Dec 2, 2012, 09:19 PM   #2
jbsmithmac
Thread Starter
macrumors regular
 
Join Date: Sep 2011
SOLVED...in case someone comes across this. While I believe it is an iTunes 11 issue, I was able to restore it by downloading the appropriate ipsw file and option+click the restore button in iTunes. This allows you to select the ipsw to use durning the restore.
jbsmithmac is offline   0 Reply With Quote
Old Dec 3, 2012, 07:03 AM   #3
foiden
macrumors 6502a
 
Join Date: Dec 2008
Thanks for the advice. And yes, this was an iTunes 11 issue. My ATV3 refused to update with the Wireless method, so I had to use iTunes and the USB restore method. Thing is, iTunes 11 would give me that exact same error. My solution, at the time, was to use a machine with iTunes 10 still on it and it worked.

Nice to know that some file and Option click method works for iTunes 11 users. Of course, this is a couple of steps too far for average users of the unit. So I would expect a couple of fixes will be made to make ATV software upgrades easier.
foiden is offline   0 Reply With Quote
Old Dec 5, 2012, 03:28 AM   #4
macfrus
macrumors newbie
 
Join Date: Dec 2012
windows, new ispw

Hey,
Thanks guys, I had the same problem trying to restore a atv2 that was jailbroken sometime ago. It would not restore in atv2 menu's, and gave the same "device cannot be found" error. I then experienced a 3194 error (I think because i was using an old ispw).

This is the ispw that I worked for me today (ATV2):
http://appldnld.apple.com/AppleTV/04...e_Restore.ipsw

I found it at
theiphonewiki.com/wiki/index.php?title=firmware
; using a google cached version of the page, as it was not loading
webcache.googleusercontent.com/search?q=cache:xAHpGz-dRZ4J:theiphonewiki.com/wiki/index.php%3Ftitle%3Dfirmware+&cd=2&hl=en&ct=clnk&gl=ca&client=firefox-a

SHA1 hash:
a3f8e3955f460786d88b879f10be69a9858f1688

When using itunes in a Windows enviroment, hold down the shift key and press the "restore" button in itunes to load your choice of ispw

Finished!

As a side note I would really recommend checking hash codes when possible. The first time i downloaded the file there was an irregularity in the progress bar, and when I checked the hashes, they did not match. I saved myself a lot of frustration tonight by downloading it again, getting an uncorrupted file and matching hashes.
To make it easy with firefox, I used the "MD5 rebourned hasher" firefox add-on.
I have no relation to the sites or add-on mentioned above and recommend searching checksum or hash sum to learn more.
macfrus is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: Unable to Restore Jumpie Jailbreaks and iOS Hacks 9 Feb 23, 2014 06:26 PM
Restore ATV2 to old firmware. rotarypower101 Apple TV and Home Theater 3 Sep 24, 2013 01:18 PM
iPhone: unable to restore firmware 6.1.3,5.1.1 drugdealer Jailbreaks and iOS Hacks 7 Aug 8, 2013 02:32 PM
iPhone: Unable to restore 6.1.2 philstone Jailbreaks and iOS Hacks 1 Jun 10, 2013 04:54 AM
Unable to restore my 3GS. The Dimak iPhone Tips, Help and Troubleshooting 6 Dec 16, 2012 05:40 PM

Forum Jump

All times are GMT -5. The time now is 11:05 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC