Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 10, 2012, 08:31 AM   #1
Cebuano1976
macrumors regular
 
Join Date: Oct 2012
Location: Verrado, Buckeye, Arizona
After 2 months, iPhone 5 says "NO SERVICE".

I have a Verizon iPhone 5 on T-Mobile. Purchased it full price. It worked without a hitch the 2 months I've had it.

Today, it shows "No Service" while all my other iPhones (4 & 4S) show T-Mobile still.

Should I do a restore? Back-up or New?

Thanks for the advice.
Cebuano1976 is offline   0 Reply With Quote
Old Dec 10, 2012, 08:32 AM   #2
r2shyyou
macrumors 68000
 
r2shyyou's Avatar
 
Join Date: Oct 2010
Location: Paris, France
Quote:
Originally Posted by Cebuano1976 View Post
I have a Verizon iPhone 5 on T-Mobile. Purchased it full price. It worked without a hitch the 2 months I've had it.

Today, it shows "No Service" while all my other iPhones (4 & 4S) show T-Mobile still.

Should I do a restore? Back-up or New?

Thanks for the advice.
I'd recommend (until one works): a restart, then a reset, then a restore (first as new, then from backup).
__________________
"kkkkkkkk ....ok" - iphone4s16gb
r2shyyou is offline   1 Reply With Quote
Old Dec 10, 2012, 11:51 AM   #3
John T
macrumors 68020
 
John T's Avatar
 
Join Date: Mar 2006
Location: UK.
Is the SIM card ok? To check, try the SIM card in your iPhone in another phone.
John T is offline   0 Reply With Quote
Old Dec 10, 2012, 01:27 PM   #4
jkauff
macrumors member
 
Join Date: Oct 2012
I had that problem on my VZ iPhone 5 the other day (got a "Cannot find SIM card" message--duh). Also, sometimes I get 3G in LTE zones. A reboot fixes the problem, but it's annoying when it happens.
jkauff is offline   0 Reply With Quote
Old Dec 10, 2012, 01:43 PM   #5
Jalopybox
macrumors 6502
 
Join Date: Nov 2012
Quote:
Originally Posted by jkauff View Post
I had that problem on my VZ iPhone 5 the other day (got a "Cannot find SIM card" message--duh). Also, sometimes I get 3G in LTE zones. A reboot fixes the problem, but it's annoying when it happens.
Been getting the INVALID SIM message where the Verizon logo should be. A reboot fixes it temporarily, but while displayed the phone will not receive calls or texts. Very annoying.
Jalopybox is offline   1 Reply With Quote
Old Dec 10, 2012, 01:54 PM   #6
AFDoc
macrumors 68000
 
Join Date: Jun 2012
Location: Colorado Springs USA for now
Is it not common knowledge the first thing you should do if having issues with an iPhone is restart it?
Then if the issue continues the next step is to reinstall firmware and set up as a new phone.... these actions typically fix the issue.
AFDoc is offline   0 Reply With Quote
Old Dec 10, 2012, 07:18 PM   #7
lelisa13p
macrumors 65816
 
lelisa13p's Avatar
 
Join Date: Mar 2009
Location: Atlanta, GA USA
If resetting the iPhone doesn't fix it, don't dismiss the notion that your SIM might be hinky. We had a phone that suddenly stopped making calls and ATT checked it, discovering that the SIM had inexplicably failed. SIM was replaced at no charge to us and everything was fine after that.
lelisa13p is offline   0 Reply With Quote
Old Dec 12, 2012, 12:17 PM   #8
Jalopybox
macrumors 6502
 
Join Date: Nov 2012
Took my Invalid SIM card to Verizon. They replaced the SIM card-not very willing and problem is solved. It got to the point that a reboot/reset/etc. was not helping and it rendered the phone useless. All is well.
Jalopybox is offline   0 Reply With Quote
Old Dec 12, 2012, 12:51 PM   #9
lelisa13p
macrumors 65816
 
lelisa13p's Avatar
 
Join Date: Mar 2009
Location: Atlanta, GA USA
Congratulations on getting it sorted.

FWIW, when our SIM failed, it had never happened to us or to anyone that we knew. When we called ATT customer service about the problem, the tech recommended that we take the phone into an ATT store. Glad to hear that you insisted on Verizon replacing yours.

I do love a happy ending.
lelisa13p is offline   0 Reply With Quote
Old Dec 12, 2012, 12:54 PM   #10
Jalopybox
macrumors 6502
 
Join Date: Nov 2012
Thanks. I had called Apple and all they did was tell me to reboot, turn airplane mode on/off, etc. It didn't help. The Verizon employee was a bit stumped but I insisted Apple said it's a SIM problem and they finally replaced it. Be persistent.
Jalopybox is offline   0 Reply With Quote
Old Dec 12, 2012, 12:59 PM   #11
lelisa13p
macrumors 65816
 
lelisa13p's Avatar
 
Join Date: Mar 2009
Location: Atlanta, GA USA
Funny about Apple suggesting turning Airplane mode ON/OFF. My son's phone was the one that failed and it happened when he turned Airplane mode OFF when getting off a flight. It rendered him unable to call me to tell me where to pick him up in the airport & me unable to tell him where I was waiting. He had to find a pay phone.
lelisa13p is offline   0 Reply With Quote
Old Dec 12, 2012, 01:01 PM   #12
Jalopybox
macrumors 6502
 
Join Date: Nov 2012
Quote:
Originally Posted by lelisa13p View Post
Funny about Apple suggesting turning Airplane mode ON/OFF. My son's phone was the one that failed and it happened when he turned Airplane mode OFF when getting off a flight. It rendered him unable to call me to tell me where to pick him up in the airport & me unable to tell him where I was waiting. He had to find a pay phone.
Strange. Are there even pay phones around these days?
Jalopybox is offline   0 Reply With Quote
Old Dec 12, 2012, 01:13 PM   #13
lelisa13p
macrumors 65816
 
lelisa13p's Avatar
 
Join Date: Mar 2009
Location: Atlanta, GA USA
Yep, a few. They take debit/credit cards. It was ridiculously pricey for one call. Luckily, he was traveling on business. (Lesson learned re: CC & payphones. )

Last edited by lelisa13p; Dec 12, 2012 at 01:50 PM. Reason: Added link as warning for others. Stupid payphone.
lelisa13p is offline   0 Reply With Quote
Old Dec 12, 2012, 01:20 PM   #14
swervinsuburban
macrumors regular
 
Join Date: Nov 2012
My phone was shipped with a faulty SIM card, I've heard this is a common problem I went to Verizon and got a new one and haven't had a problem since but I also got the no sim messages and no service
swervinsuburban is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:08 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC