Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 16, 2013, 04:00 AM   #1
RobertoooMac
macrumors newbie
 
Join Date: Jan 2013
Question 2012 iMac Wi-Fi Problems

Hi guys,

I've just received my brand new 2012 27" inch iMac, and I'm having some problems. Although, it could be something that I'm missing...I don't know.

It connects to the Wi-Fi box fine, everything says good signal and whatever. I then try to load up a page and it's unbelievably slow. The thing is, it can't be my actual internet because when my Dad is using the internet without my iMac turned on, he's getting around 6MBps which is our normal internet speed. Is there any reason why my iMac should do this? Does it take up an unusual amount of bandwidth to operate? Are there any settings I need to tinker with? Would it maybe be a good idea to get an AirPort Express?

Thanks a lot for your time. This is my first apple computer and I'm finding all of this unbelievably disheartening.

Kind Regards,

Rob
__________________
27" iMac, 3.4 Ghz i7, NVIDIA GeForce GTX 680MX 2GB, 1TB Fusion Drive; 13" Macbook Pro (Late 2013), 2.4Ghz i5, 256GB SSD; iPhone 4S 32GB.
RobertoooMac is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:27 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC