Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 16, 2013, 05:00 AM   #1
RobertoooMac
macrumors newbie
 
Join Date: Jan 2013
Question 2012 iMac Wi-Fi Problems

Hi guys,

I've just received my brand new 2012 27" inch iMac, and I'm having some problems. Although, it could be something that I'm missing...I don't know.

It connects to the Wi-Fi box fine, everything says good signal and whatever. I then try to load up a page and it's unbelievably slow. The thing is, it can't be my actual internet because when my Dad is using the internet without my iMac turned on, he's getting around 6MBps which is our normal internet speed. Is there any reason why my iMac should do this? Does it take up an unusual amount of bandwidth to operate? Are there any settings I need to tinker with? Would it maybe be a good idea to get an AirPort Express?

Thanks a lot for your time. This is my first apple computer and I'm finding all of this unbelievably disheartening.

Kind Regards,

Rob
__________________
27" iMac, 3.4 Ghz i7, NVIDIA GeForce GTX 680MX 2GB, 1TB Fusion Drive; 13" Macbook Pro (Late 2013), 2.4Ghz i5, 256GB SSD; iPhone 4S 32GB.
RobertoooMac is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iMac 2012 ghosting problems again Dor Levy iMac 5 Aug 20, 2013 01:02 AM
Colour problems with late 2012 iMac OwenMeasures iMac 1 Mar 18, 2013 04:02 PM
2012 iMac problems? Dave26 iMac 24 Jan 13, 2013 10:58 AM
The new 2012 imac problems Hab299 iMac 14 Dec 24, 2012 10:04 PM
No Problems w/ New 2012 27" iMac! DerekS iMac 24 Dec 20, 2012 07:02 PM

Forum Jump

All times are GMT -5. The time now is 08:33 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC