Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 16, 2012, 08:18 PM   #1
Glockenklang
macrumors newbie
 
Join Date: Dec 2012
An elusive external hard drive

Hello all,

My problem centers around a 2 TB external hard drive: a Rocketfish RF USB 3.0 3.5" SATA Hard Drive (RF-HD3035)

I have a 17" MacBook Pro running OS X Lion 10.7.5.
I have a 13" MacBook Air running OS X Lion 10.7.4.

The Air can read the external hard drive. The Pro cannot. On the Pro, the hard drive appears in the finder, but when I click on the folders within, they present as empty.

When I run Disk Utility, it tells me the drive needs to be repaired. When I click "repair disk", it says "Error: Can't Unmount Disk".

Again, no problems to speak of on the Air running 10.7.4.

This all MAY have begun when I updated the Pro to 10.7.5. (can't remember which happened first, the hard drive problem or the update.)

I tried this but it didn't help.

Do you think the update might have caused the problem?

Thank you in advance for your help, folks!

All the best,

Glockenklang
Glockenklang is offline   0 Reply With Quote
Old Dec 16, 2012, 11:11 PM   #2
mankar4
macrumors 6502a
 
mankar4's Avatar
 
Join Date: Aug 2007
Location: USA
I had a similar problem and ended up having to reformat
mankar4 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Extend built-in hard drive with external hard drive? booyahbooyah OS X Mavericks (10.9) 3 Dec 4, 2013 09:37 AM
Turning Internal Hard drive into External Hard Drive - Help Please Ne0the1 iMac 33 Jan 8, 2013 01:02 PM
Make external hard drive default hard drive utahman130 PowerPC Macs 4 Dec 26, 2012 09:51 AM
Use external hard drive as time machine and external hard drive Cubeeless MacBook Pro 4 Aug 20, 2012 04:00 PM
Dead hard drive - need temporary external hard drive solution Gwenyn iMac 20 Jun 14, 2012 06:15 AM

Forum Jump

All times are GMT -5. The time now is 08:14 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC