Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 18, 2012, 10:07 PM   #1
traycraycray
macrumors newbie
 
Join Date: Oct 2012
iMessage & Phone Number

Hey everyone,

So I got a new phone today and I restored it with my iCloud backup and I'm trying to send iMessages.. however it keeps sending from my e-mail even though it says my phone number is verified already and there is a check mark next to both my number and email...

However, my number is greyed out.. so I don't know what to do...
traycraycray is offline   0 Reply With Quote
Old Dec 18, 2012, 10:39 PM   #2
CosmoPilot
macrumors 65816
 
CosmoPilot's Avatar
 
Join Date: Nov 2010
Location: South Carolina
Wirelessly posted

Settings > imessage > Send & Recieve.

Ensure "start new conversation" is marked next to your phone number. Now, start a new conversation, don't 'reply' to an old one.

If this doesn't work, turn iMessage off, restart the iPhone, then turn iMessage back on and recheck the above settings.
__________________
2011 27" 2.7GHz iMac 2012 2.5GHz 13" MBP iPhone 6 / iPhone 5S / iPhone 5 iPad Air AppleTV / AEBS 802.11ac
CosmoPilot is offline   0 Reply With Quote
Old Dec 19, 2012, 12:48 AM   #3
Dechter
macrumors member
 
Join Date: Jul 2010
I also don't have the option to designate my number or AppleID for "start a new conversation." Weird. My iMessage settings page is exactly as OP described.

Edit: I tried toggling iMessage off and back on and after re-enabling my AppleID, I now have the option to "start a new conversation from:" at the bottom of the iMessage settings page. Weird.
Dechter is offline   0 Reply With Quote
Old Dec 19, 2012, 05:14 AM   #4
traycraycray
Thread Starter
macrumors newbie
 
Join Date: Oct 2012
Quote:
Originally Posted by CosmoPilot View Post
Wirelessly posted

Settings > imessage > Send & Recieve.

Ensure "start new conversation" is marked next to your phone number. Now, start a new conversation, don't 'reply' to an old one.

If this doesn't work, turn iMessage off, restart the iPhone, then turn iMessage back on and recheck the above settings.

this worked! thanks!!
traycraycray is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Phone number iMessage help Merackon iPhone 6 May 5, 2014 10:29 AM
iMessage and phone number da-vid iPhone Tips, Help and Troubleshooting 2 Dec 8, 2012 08:41 PM
Can I use an old phone number with imessage vistadude iPhone 4 Oct 27, 2012 01:22 AM
iPhone: iMessage Help - Phone number timek4 iOS 6 2 Oct 15, 2012 02:20 AM
New Phone Number and iMessage iRooney iPhone 5 Aug 15, 2012 12:11 AM

Forum Jump

All times are GMT -5. The time now is 06:10 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC