Go Back   MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 15, 2012, 10:59 PM   #1
neal.young
macrumors member
 
Join Date: Jul 2009
Location: Irvine, California
Problems with GTX 660 + 2009 Mac Pro + Apple Cinema Display

Hey everyone,

I just bought this (http://www.amazon.com/gp/product/B00...ls_o00_s00_i00) Gigabyte GTX 660 graphics card to use with my early 2009 Mac Pro and 27'' Cinema Display, using this (http://www.amazon.com/gp/product/B00...ls_o00_s00_i01) Displayport to Mini Displayport adapter to connect the display to the card. Unfortunately, after plugging everything in, I got... nothing. After turning on the computer (set to boot into Windows by default), the display didn't turn on at all, even after waiting 5+ minutes for the computer to boot (I know there is no boot screen unless your card is flashed, mine isn't). Then, I tried plugging in an LCD monitor I had laying around into the DVI port, which turned on as expected while Windows was loading. I was able to use Windows normally and install the Nvidia drivers using my DVI monitor. However, when I tried to restart into OS X, nothing appeared on screen. Does anyone know what could be causing these issues, or have any troubleshooting advice? Thanks!
__________________
UCIrvine Anteaters
neal.young is offline   0 Reply With Quote
Old Nov 15, 2012, 11:22 PM   #2
phoenixsan
macrumors 65816
 
phoenixsan's Avatar
 
Join Date: Oct 2012
Maybe.....

this link can be helpful:

http://forums.macrumors.com/showthre...1440150&page=5

__________________
Mac Pro 2012 3.06 Westmere version, 12 Core 64 GB RAM, 4 TB , iPhone 5 (black), Moto G 8 GB (black)
phoenixsan is offline   0 Reply With Quote
Old Nov 16, 2012, 04:14 AM   #3
neal.young
Thread Starter
macrumors member
 
Join Date: Jul 2009
Location: Irvine, California
After booting into OS X with the stock card, I found out that the system had kernel panicked on every boot with the 660, so I tried installing the Mac drivers. Now, I can boot into Windows or OS X reliably, but only through the DVI port. Anyone have any other ideas on how to connect the cinema display?
__________________
UCIrvine Anteaters
neal.young is offline   0 Reply With Quote
Old Nov 19, 2012, 07:04 PM   #4
neal.young
Thread Starter
macrumors member
 
Join Date: Jul 2009
Location: Irvine, California
Bump, I got a new DP-MiniDP adapter, and the card still will not output video to the Cinema display. Could the DisplayPort output on the card somehow be defective?
__________________
UCIrvine Anteaters
neal.young is offline   0 Reply With Quote
Old Nov 20, 2012, 11:31 AM   #5
Asgorath
macrumors 6502a
 
Join Date: Mar 2012
What OS are you running? What driver are you using? Is there anything with "NVDA" in /var/log/system.log?
Asgorath is offline   0 Reply With Quote
Old Dec 26, 2012, 08:56 AM   #6
Vmaatta
macrumors regular
 
Join Date: Nov 2007
I'm in the same boat. The exact same GTX 660, MacPro4,1, Cinema Display 24" , OS X 10.8.2 (12C60).

I've got the stock NVIDIA GeForce GT 120 in slot 1 for boot and backup. And the GTX 660 in Slot 2. I installed the 304.00.05f02 web drivers before installing the card.

The only NVDA log messages I've seen are in boot saying the NVDANV50Hal and NVDAGK100Hal kexts are loaded. 50Hal for GT 120 and 100Hal for GTX 660.

There's a TX-SR578 amp connected to the HDMI on 660 and working fine (with audio using the NVAudio kext). I've tested with the same amp and a DVI-D to HDMI adapter that the DVI-D on the GTX 660 is also active and produces an image to the amp.

So, using an DisplayPort to Mini DisplayPort adapter the GTX 660 does not provide an image to the Cinema Display. At least on OS X. I don't have a Boot Camp install so I can't test in Windows but I'm guessing there it might work.

Looking at the log when disconnecting the Cinema Display from GT 120 and connecting to the 660 there are WindowServer messages which would suggest a screen is recognised as connected to the DisplayPort but the port is not active / activated / is active but just does not produce image.
26.12.12 2:54:52.221 PM WindowServer[167]: Received display connect changed for display 0x3f0040
26.12.12 2:54:52.221 PM WindowServer[167]: Received display connect changed for display 0x424c491
I suppose 0x003f0040 is the DisplayPort and 0x3f0041 is the Mini display port on the GT 120.

So I'm thinking the DVI-D and HDMI on the GTX 660 are working out-of-the-box with the current web drivers for OS X. Using the DVI-D with the Cinema Display would be an option using an active adapter.

Another possibility might be to somehow edit the kexts or otherwise modify something to activate the DP with the OS X drivers. I've been trying to research this as at least with Radeons some have been able to activate the DP by modifying the ATIX000 kexts.

But so far I haven't found anything worth trying. Any ideas? I already have the active adapter on order but I would much rather cancel that and use the DP if someone can think of a way to activate it in OS X.
Attached Files
File Type: txt WindowServerDump.txt (16.0 KB, 32 views)
__________________
“Any sufficiently advanced technology is indistinguishable from magic.” — Arthur C. Clarke —
since 2006.
Vmaatta is offline   0 Reply With Quote
Old Dec 27, 2012, 06:57 PM   #7
Vmaatta
macrumors regular
 
Join Date: Nov 2007
I installed Windows 8 Release Preview in Bootcamp and in fact the DisplayPort wasn't working there either. Latest drivers from Nvidia and nothing. Cinema Display connected to the GT 120 mini DP worked just fine but the DP port on GTX 660 didn't give anything. Gigabyte's @BIOS also didn't recognise either of the cards so I dunno…

Now I'm thinking the adapter(s) could be one way: Mini DP -> DP. Meaning it would work with e.g. a Macbook Pro with Mini DP output and a screen with a DP input. But not in this setup where Mini DP is the input.
__________________
“Any sufficiently advanced technology is indistinguishable from magic.” — Arthur C. Clarke —
since 2006.
Vmaatta is offline   0 Reply With Quote
Old Dec 27, 2012, 09:01 PM   #8
Vmaatta
macrumors regular
 
Join Date: Nov 2007
Quote:
Originally Posted by Vmaatta View Post
Now I'm thinking the adapter(s) could be one way: Mini DP -> DP. Meaning it would work with e.g. a Macbook Pro with Mini DP output and a screen with a DP input. But not in this setup where Mini DP is the input.
Scratch that. The adapters should go goth ways.
__________________
“Any sufficiently advanced technology is indistinguishable from magic.” — Arthur C. Clarke —
since 2006.
Vmaatta is offline   0 Reply With Quote
Old Dec 28, 2012, 08:56 AM   #9
Vmaatta
macrumors regular
 
Join Date: Nov 2007
Active DVI-D to Mini DP

Ok the active adapter arrived. Result, it kind of works but not a solution . GTX 660 kicks in on desktop as expected and actually gives an image to the Cinema Display via the DVI-D adapter. Unfortunately it starts blinking intermittently / completely blacks out. And this setup is also affected by the sleep issue, the screen wakes from sleep but blacks out immediately (~ 1 sec.).

The blinking / black out seems to be somewhat related to what application / features are active. E.g. opening Launchpad caused a black out consistently, TextMate 2 , Steam, Civ 5 blinked some and in the menus finally blacked out completely before getting to the game.
__________________
“Any sufficiently advanced technology is indistinguishable from magic.” — Arthur C. Clarke —
since 2006.
Vmaatta is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mac Pro 3,1 - 120gb ssd, 12gb ram, Nvidia GTX 680 + 30" cinema display. gochi Mac Pro 7 Nov 19, 2013 08:22 AM
Resolved: Only one screen under Boot Camp, GTX 660 Mac Pro? NOTNlCE Windows, Linux & Others on the Mac 0 Oct 23, 2013 03:07 PM
HD 7870 vs GTX 660 - Mac Pro 4,1 cell-gfx Mac Pro 0 Apr 2, 2013 05:34 PM
Upgrading to Nvidia GTX 470 on 2009 mac pro - many problems? nigel1210 Mac Pro 2 Jun 15, 2012 09:16 PM

Forum Jump

All times are GMT -5. The time now is 07:31 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC