Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Special Interests > Visual Media > Digital Video

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 29, 2012, 08:07 PM   #1
enfant terrible
macrumors newbie
 
Join Date: Dec 2012
iMovie Transitions

I have noticed that periodically when adding a transition between clips, playback is choppy/ stalled. I have tried deleting and re-adding the clips, deleting and re-adding the transitions, re-importing the thumbnails, moving the footage into a new event, and of course, restarting iMovie. Nothing I try seems to help. I have experimented with several types of transitions; it is crossfade that seems to cause the most noticeable glitch: the end of the first clip will freeze at the very end and then speed up the beginning of that which follows. When I use fade-to-black, the freezing is not quite as apparent but the black screen stays up far longer than it should if functioning normally. I attempted to tweak the transition duration as well but that actually made things worse. To reiterate, it does not happen with all clips but it is rendering otherwise complete projects unfit for viewing.

Has anyone ever had this problem? I am currently using iMovie '11 on an iMac running 10.8.2. Any suggestions would be greatly appreciated.
enfant terrible is offline   0 Reply With Quote
Old Dec 30, 2012, 02:14 AM   #2
Zwhaler
macrumors 603
 
Zwhaler's Avatar
 
Join Date: Jun 2006
What type of iMac? And does it only do this in the viewer in iMovie but not in the finished exported product?
__________________
2x2.93 24GB 25TB 2x1TB 840EVO 2x UAD OCTO, Apollo, 4-710d
Check Out My YouTube Channel~~~~~~~~~~~~~~~~~~~
Zwhaler is offline   0 Reply With Quote
Old Dec 30, 2012, 09:32 AM   #3
enfant terrible
Thread Starter
macrumors newbie
 
Join Date: Dec 2012
The latest one, with 2.9 GHz processor and 8 GB RAM. And yes, it also does this in the final product.
enfant terrible is offline   0 Reply With Quote
Old Dec 30, 2012, 02:09 PM   #4
daybreak
macrumors 6502a
 
Join Date: Sep 2009
How long is your project?. Have you imported all your clips in the same format?
How does your project play without any transitions?.
daybreak is offline   0 Reply With Quote
Old Dec 31, 2012, 08:54 PM   #5
enfant terrible
Thread Starter
macrumors newbie
 
Join Date: Dec 2012
The projects are no longer than five minutes each. They played fine before the transitions were added but I find that once the problem has arisen (and again, it's only affecting some of them), it won't go away regardless of how the clips are edited/ removed/ re-added. All of the source material is in the same format, namely .m4v. Currently I have one transition that simply will not behave; there are six others that are functioning normally.
enfant terrible is offline   0 Reply With Quote
Old Jan 1, 2013, 03:17 PM   #6
daybreak
macrumors 6502a
 
Join Date: Sep 2009
I think your m4v files are the culprit here. Is not, i think iMovie recognised, in its present state.
daybreak is offline   0 Reply With Quote
Old Jan 1, 2013, 04:05 PM   #7
Ifti
macrumors 65816
 
Join Date: Dec 2010
Location: UK
I don't think it's the source files. Most of my source files are MOV format. I used to experience similar issues. If I applied a transition to a PIP clip the transaction would mess up and not even show the PIP clip at all. Although the final exported movie was always fine, it just happened in iMovie.

I also tried restarting imovie etc, but I could never solve the issue either. This, along with the terrible export quality, made me finally ditch imovie and turn to FCPX, and to be honest its the best move I ever made!
__________________
See my YouTube Channel for reviews & tech tips!
2012 Mac Mini Server / 2.6GHz Quad i7/8GB/2x1TB HDD
2013 MBA11 1.7GHz Dual i7/8/256 - 2013 rMBP15 2.6GHz Quad i7/16/1TB/750m
TC / Lacie TB2 20TB
Ifti is offline   0 Reply With Quote
Old Jan 2, 2013, 05:52 AM   #8
daybreak
macrumors 6502a
 
Join Date: Sep 2009
Have you got any handles or space at the beginning of your clips and are they iMovie transition?
daybreak is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Visual Media > Digital Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Does GM still have slow transitions? ethan028 iOS 7 2 Sep 10, 2013 03:31 PM
iMovie '09 Transitions Greyed Out Mandychuu Mac Applications and Mac App Store 0 Mar 3, 2013 10:37 AM
iMovie 11 Time Lapse Transitions BetaNumeric Digital Video 8 Feb 17, 2013 06:37 PM
FCE transitions 22Barb Digital Video 1 Jan 6, 2013 01:25 AM
Using iMovie Themed Transitions tpj Mac Applications and Mac App Store 0 Aug 9, 2012 08:31 PM

Forum Jump

All times are GMT -5. The time now is 11:30 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC