Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 8, 2013, 10:53 AM   #1
zign
macrumors 6502
 
Join Date: Apr 2006
Location: London
Send a message via Skype™ to zign
USB ports stopped working

Hi guys,

Both of my USB ports just stopped working this morning. If I plug anything in, I can still charge devices, but none of them will get recognised. Also, this morning I got a message, that some of my USB ports was drawing too much power and was disabled. At this point I connected the USB to the second port, which stopped working shortly after.

I have done the smc and pram resets. It's a 2011 1.7GHz i5 model.

Any ideas?
__________________
13.3" MBA - 1.7GHz i5, 4GB Ram, 10.7.4 | iPhone 4S 16GB (black) | iPad 2 3G 16GB | Nexus 7 16GB | Nexus 4 16GB
www.palitsyn.com
zign is offline   0 Reply With Quote
Old Jan 8, 2013, 05:44 PM   #2
Stingray454
macrumors 6502
 
Join Date: Sep 2009
You usually don't get that message unless you try to plug three or more units in on the same USB port - I got it myself when connecting an Apple USB keyboard, and then connected a mouse and my phone charger (+ phone) to the two USB slots on the keyboard. It seems whatever you try to connect is using too much power.

If you are only plugging in a single device, I'm guessing you have some kind of short circuit either in the device or in the cable. I'd try with another cable, and if that doesn't solve it, with some other USB device (borrow one from a friend or something).

If you're really unlucky, a broken device that you tried to plug in has caused damage to the USB controller, but let's hope not.
Stingray454 is offline   0 Reply With Quote
Old Jan 8, 2013, 05:45 PM   #3
Nermal
Moderator
 
Nermal's Avatar
 
Join Date: Dec 2002
Location: Whakatane, New Zealand
Connect a mouse and reboot while holding Option to get into the Startup Manager. See whether the mouse works there.

If yes, it's a software problem. If no, hardware.
Nermal is offline   1 Reply With Quote
Old Jan 8, 2013, 06:20 PM   #4
ybz90
macrumors 6502a
 
Join Date: Jul 2009
Did you experience any trouble with it before it stopped working? My Air briefly had an issue where plugging in new USB devices caused the controller to seize up; the system was not stalled, just all USB input devices for a few moments before working. If it is a hardware problem, then it's likely you won't be able to fix it yourself and may need a new logic board.
ybz90 is offline   0 Reply With Quote
Old Jan 9, 2013, 06:03 AM   #5
zign
Thread Starter
macrumors 6502
 
Join Date: Apr 2006
Location: London
Send a message via Skype™ to zign
Well, mystery solved! I plugged a usb mouse in and it worked. Tried my iPhone and it was recognised in iTines. My nexus 4 was plugged in with a cable which doesn't seem to support data (tried a different one and the device was recognised) and my usb ethernet adopter must have died, as it's not being recognised on any other machines.

Thank you for all the suggestions!
__________________
13.3" MBA - 1.7GHz i5, 4GB Ram, 10.7.4 | iPhone 4S 16GB (black) | iPad 2 3G 16GB | Nexus 7 16GB | Nexus 4 16GB
www.palitsyn.com
zign is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:28 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC