Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 12, 2013, 09:12 AM   #1
CatsTide
macrumors 6502
 
Join Date: Sep 2012
disappearing artwork

Several of my albums,shows and movies have lost their artwork. I have searched the forum and found several posts about this but no solutions. What causes this and how can I fix it? I have literally hundreds missing. Any ideas?
CatsTide is offline   0 Reply With Quote
Old Jan 12, 2013, 09:24 AM   #2
CatsTide
Thread Starter
macrumors 6502
 
Join Date: Sep 2012
Also...When I click info and check the artwork it's still there. When I close the info the artwork comes back. Is there a way to just rescan your folder or something like that? If it matters,my library is on a separate HD and it is disconnected from time to time.
CatsTide is offline   0 Reply With Quote
Old Jan 12, 2013, 09:44 AM   #3
Omne666
macrumors 6502a
 
Join Date: Sep 2010
Location: Melbourne, Australia
Actually, something like 30% of my movies all of a sudden stopped showing their artwork, unless I brought up the info menu, then it would suddenly be there. Then when it was off screen as I scrolled away and came back, it was gone again.
This was something in excess of 300 movies. Also on the appletv nothing would show for the artwork.

Can't say I've looked in my music library so will have to check.

For the movies, I use iFlicks for the meta data tagging, and so selected all the movies that showed the issue and ran iFlicks through the services menu of iTunes redoing the metadata. Worked a treat and all the items are holding now.

Best I can offer.
__________________
One of everything. Don't forget the fries.
Omne666 is offline   0 Reply With Quote
Old Jan 12, 2013, 09:52 AM   #4
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by Omne666 View Post
Actually, something like 30% of my movies all of a sudden stopped showing their artwork, unless I brought up the info menu, then it would suddenly be there. Then when it was off screen as I scrolled away and came back, it was gone again.
This was something in excess of 300 movies. Also on the appletv nothing would show for the artwork.

Can't say I've looked in my music library so will have to check.

For the movies, I use iFlicks for the meta data tagging, and so selected all the movies that showed the issue and ran iFlicks through the services menu of iTunes redoing the metadata. Worked a treat and all the items are holding now.

Best I can offer.
Probably database corruption. Delete and add back your media and it should be ok.
__________________
17" MBP '09, 2.66 GHz, 8GB RAM; 13" MBP (Retina) '12, 2.5GHz, 8GB RAM; iPad 2, 32GB; AE; TV 3; AEBS w 1TB Seagate HDD; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Jan 12, 2013, 09:58 AM   #5
CatsTide
Thread Starter
macrumors 6502
 
Join Date: Sep 2012
Quote:
Originally Posted by mic j View Post
Probably database corruption. Delete and add back your media and it should be ok.
How do you do this mic?
CatsTide is offline   0 Reply With Quote
Old Jan 12, 2013, 10:07 AM   #6
Omne666
macrumors 6502a
 
Join Date: Sep 2010
Location: Melbourne, Australia
Quote:
Originally Posted by mic j View Post
Probably database corruption. Delete and add back your media and it should be ok.
Fixed my movies, but you say database corruption....isn't the artwork embedded in the movie file?

Also..deleting and re adding the media isn't a great thing to do as is screws up the play counts, dates, history that gets built up over time. This stuff is priceless when building up your library. Smart play lists etc can use so much of this that's lost when you do it.
__________________
One of everything. Don't forget the fries.
Omne666 is offline   0 Reply With Quote
Old Jan 12, 2013, 10:23 AM   #7
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by CatsTide View Post
How do you do this mic?
Select and delete everything in the library. Then go to File>Add to library. Navigate to the folder you have your media stored in and select it.

----------

Quote:
Originally Posted by Omne666 View Post
Fixed my movies, but you say database corruption....isn't the artwork embedded in the movie file?

Also..deleting and re adding the media isn't a great thing to do as is screws up the play counts, dates, history that gets built up over time. This stuff is priceless when building up your library. Smart play lists etc can use so much of this that's lost when you do it.
Yeah, I know it is not the ideal fix, but it is the only thing I have found to work. I don't use any of the data iTunes collects for anything, so that did not have an impact on me. I might add, that I tried fixing individually but next time I would use iTunes, others or some of the same would be missing again. This was the only way I know of to fix everything all at once and for good (knock on wood). Once fixed it has not reoccurred in over a year.

As for the metadata location, yes it is tagged on to the file but I have to figure it's how the database accesses the metadata and displays it that gets corrupted. Wish I could be more "technical" but that's about as much as I know. If you find a better fix, please post it so we can have a better method.
__________________
17" MBP '09, 2.66 GHz, 8GB RAM; 13" MBP (Retina) '12, 2.5GHz, 8GB RAM; iPad 2, 32GB; AE; TV 3; AEBS w 1TB Seagate HDD; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Jan 12, 2013, 10:32 AM   #8
Omne666
macrumors 6502a
 
Join Date: Sep 2010
Location: Melbourne, Australia
Must admit I did a partial rebuild recently when a Drobo misbehaved on me, and all my movies disappeared.

I had a 70% backup on site at the time, so, as I have iTunes organize and manage the library, I double clicked on a missing item, it brought up the cant locate menu, and I pointed it to the file where it now was, it located all the other missing ones there also, preserving a lot of the this data I like. I had to bite the bullet on the last 30%.
__________________
One of everything. Don't forget the fries.
Omne666 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Movie Artwork Keeps Disappearing BulkHedd Mac Applications and Mac App Store 0 May 23, 2014 08:41 AM
iTunes 11 has changed TV show Artwork to Audiobook Artwork! RossMcLaren iPod 1 Dec 29, 2012 02:32 PM
iTunes has artwork, phone has been synced - iOS still missing artwork petrucci666 iOS 6 19 Nov 17, 2012 08:10 PM
Disappearing folders - help! robertcoogan OS X 10.8 Mountain Lion 1 Aug 24, 2012 06:50 AM
Disappearing app malibru iPad Tips, Help and Troubleshooting 3 Jul 19, 2012 01:25 AM

Forum Jump

All times are GMT -5. The time now is 03:07 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC