Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 20, 2014, 08:29 AM   #1
woodlandtrek
macrumors member
 
Join Date: Jan 2008
Mavericks Server with Win7 clients: File locked for editing

Hi all,

I recently replaced a Snow Leopard server with a 2013 Mini running Mavericks server for a family business. Everything works fine, except for file sharing.

When one of the users has a file open, it will occasionally get "stuck" open on the server. Any future attempts to edit the file will result in the message "This file is locked for editing by another user". These are mostly microsoft office files, but the problem is not being caused by the typical $~ lock files. It appears to be somewhere in SMB.

When I run lsof | grep "smbd" | grep "REG" I get no results (when no documents are actually open).
When I run that same command under sudo, then the troublesome files show up. Restarting smbd fixes the issue temporarily, but then eventually other files get stuck in the same way.

Any advice? I've tried everything I can think of to figure out what's causing this.
woodlandtrek is offline   0 Reply With Quote
Old Jul 9, 2014, 12:33 PM   #2
satcomer
macrumors 68040
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
This happens because most Windows users think if in OS X they click the red menu bar button it will close a running application, but it won't. In OS X you must quit a program to close the program but in OS X the red button means to just close the running window, not to close the program. So a user is still running the offending application file program after they opened a program on the server.
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is offline   0 Reply With Quote
Old Jul 25, 2014, 03:47 AM   #3
joelkadeen
macrumors newbie
 
Join Date: Jun 2014
Usually things like that need a password to unlock or it was saved under a different user name. Try simply saving the file under a slightly different file name and try working from that copy.

difference between virus and trojan horse
joelkadeen is offline   0 Reply With Quote
Old Jul 25, 2014, 10:05 AM   #4
iRATs
macrumors newbie
 
Join Date: Sep 2008
Same Problem

I had this same exact issue. I've done a lot of research and contacted apple support but no resolution. Most of the research points to the upgrade from SL to Mavericks server. I plan to do a fresh install, recreate Open Directory and move the files back to the server cleanly. If that does not solve the issue I'm stumped.

Something to consider for the upcoming Yosemite also.

Has anyone else had this issue? Any resolution?
iRATs is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Windows clients cannot see server. Mac clients can. charlielowndes Mac OS X Server, Xserve, and Networking 5 Apr 3, 2014 06:28 AM
VPN problem with Win7 clients perciodechiara Mac OS X Server, Xserve, and Networking 0 Mar 11, 2014 01:37 PM
Setup/configuring a new MP 6,1 for video, editing and possibly a file server bxs Mac Pro 1 Mar 5, 2014 11:31 AM
Possible to dual boot Mavericks and Mavericks Server? TheNorthWaves Mac OS X Server, Xserve, and Networking 1 Jan 8, 2014 09:05 PM
10.8 clients with 10.6.8 server? njbrubaker Mac OS X Server, Xserve, and Networking 3 Oct 19, 2012 09:46 AM

Forum Jump

All times are GMT -5. The time now is 08:24 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC