Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 16, 2013, 08:16 AM   #1
DJLC
macrumors 6502
 
Join Date: Jul 2005
Location: Mooresville, NC
Send a message via AIM to DJLC Send a message via MSN to DJLC Send a message via Yahoo to DJLC Send a message via Skype™ to DJLC
CUPS Authentication

I work at a middle school, and I'm trying to set up our Xserve to take over print server duties. The built-in print servers on our two main laser printers just can't handle the load.

It started out working fine, until Monday when the color laser stopped accepting jobs sent from clients. The server could print, but nobody else could. I thought it'd probably make sense to just use the CUPS web interface rather than monkey around with the crippled Lion GUI. However, I can't seem to authenticate to it. I have the web interface enabled, and default auth type set to basic. I have also tried it with the auth type set to digest. I cannot login as a local admin, OD admin, or even as root. I have verified my passwords; I can even connect via AFP as root. Anyone have any idea what's going on? I can't find anyone who has had this issue since 10.3.
__________________
-John Mairs
DJLC is offline   0 Reply With Quote
Old Jan 16, 2013, 09:04 AM   #2
aarond12
macrumors 6502a
 
aarond12's Avatar
 
Join Date: May 2002
Location: Dallas, TX USA
What was the problem with Lion's GUI? You said it was crippled? Was it work not work or are you just saying it doesn't have as many options as CUPS?

Is standard print sharing working?

IIRC, I can't log into CUPS on my Lion system either. 127.0.0.1:631 asks for authentication that doesn't work so I ignored the problem. If that's what you're having problems with, I don't know the solution.
__________________
Voted "Most likely to start his own cult" by my high school class.
aarond12 is offline   0 Reply With Quote
Old Jan 16, 2013, 09:09 AM   #3
DJLC
Thread Starter
macrumors 6502
 
Join Date: Jul 2005
Location: Mooresville, NC
Send a message via AIM to DJLC Send a message via MSN to DJLC Send a message via Yahoo to DJLC Send a message via Skype™ to DJLC
For example, I want to set the default options so the B&W laser printer does double sided by default, rather than having to select it. The CUPS web interface allows this; the OS X GUI does not. Luckily I was able to set this without authenticating. The sharing options also seem to be more fine-tuned in the web interface — if only I could actually set them!

I did originally set it all up via the GUI, and this did work initially. However, the server is now apparently dropping any print jobs sent to the color laser printer. The B&W laser continues to work fine. I can send jobs directly from client to printer and from server to printer, but not client to server to printer. This would be okay, except the crappy color laser quickly gets bogged down with all the clients and print jobs can take up to 2 hours to process and print. (I asked HP about this — instead of giving me an answer, they tried to sell me a new printer. We're switching to a Xerox ColorQube soon, but in the meantime it'd be nice to use the last of our toner...)

Specifically, Apple dropped the Print Server section of Server Admin.app in Lion. Although I'm not positive, I'm pretty sure that would've been the ideal interface to use.
__________________
-John Mairs
DJLC is offline   0 Reply With Quote
Old Jan 16, 2013, 02:49 PM   #4
DJLC
Thread Starter
macrumors 6502
 
Join Date: Jul 2005
Location: Mooresville, NC
Send a message via AIM to DJLC Send a message via MSN to DJLC Send a message via Yahoo to DJLC Send a message via Skype™ to DJLC
Adding to my list of printing issues...

The color laser still doesn't work. The B&W laser is now printing 4 copies of everything that gets sent to it. I can't disable Printer Sharing, add/delete printers, or reset the printing system via System Preferences. It seems CUPS has totally crapped itself.

Any advice?
__________________
-John Mairs
DJLC is offline   0 Reply With Quote
Old Jan 17, 2013, 10:41 AM   #5
DJLC
Thread Starter
macrumors 6502
 
Join Date: Jul 2005
Location: Mooresville, NC
Send a message via AIM to DJLC Send a message via MSN to DJLC Send a message via Yahoo to DJLC Send a message via Skype™ to DJLC
Fixed.

I reverted /etc/cups/cupsd.conf to the default. Then I commented out every AuthType or Require line in the policy sections, adding "Allow localhost" along the way. I can now admin CUPS via the web interface locally, but not from elsewhere on the network.

Now I'm just working out the best way to push out the printers (again). TheOatmeal was right... printers were sent from hell to make us miserable.
__________________
-John Mairs
DJLC is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Script to set up CUPS printers Kilamite Mac Applications and Mac App Store 1 Apr 25, 2014 05:56 AM
CUPS Print Release Station Butler Trumpet Mac Peripherals 9 Jul 26, 2013 07:09 PM
CUPS on OS X Not Getting PPD Automatically Kilamite OS X 0 Jan 15, 2013 06:24 AM

Forum Jump

All times are GMT -5. The time now is 12:31 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC