Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > Mac mini

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 18, 2013, 10:51 PM   #1
dukee101
macrumors member
 
Join Date: Jan 2009
Unhappy Help! 2012 Mac Mini won't boot from external SSD

I just got my new 2012 Mac mini today and I'm having issues booting off an external USB3 SSD.

My plan is to simply replace the 1 TB HDD that shipped stock with a Crucial M4 512GB SSD. No second drives, no additional internal SATA cables, nothing. Just an in-place swap.

Knowing that these 2012 minis shipped with a special build of OS X, I decided to install OS X onto my SSD externally and confirm normal operation before I opened the mini and took everything apart.

I first attempted to use the Internet Recovery from the 1 TB stock drive (and special build of ML) to install the special build onto the external.

It found the drive, downloaded the OS, and installed it. When it was time to reboot, the system would show the "no" or "do not do this" or "do not smoke" sign and hung there.



When I rebooted back to the 1 TB drive, I checked the external SSD and saw that it did in fact install the OS (free space was lessened).

Then I tried something else: I used Carbon Copy Cloner to clone the 1 TB drive and its special OS build onto the external SSD. Again: everything cloned just fine and when I rebooted the system, used the option key to pick the external SSD, it went to the "no" or "do not do this" sign and hung.

What is going on here?

I even went out of my way to update the firmware on my Crucial M4. It's got the latest firmware. And before I did any of this, I used the same external USB-SATA adapter and connected the drive to a MacBook Air, booted 10.8.2 off of it, and made sure everything was functioning. It was perfect. This SSD and adapter are normal.

Do I have to teardown the mini and put the SSD into the SATA slot to get it to work? Is it more troublesome to boot off the external than just the primary SATA slot? What's going on here??
dukee101 is offline   0 Reply With Quote
Old Jan 18, 2013, 11:03 PM   #2
justperry
macrumors 603
 
justperry's Avatar
 
Join Date: Aug 2007
Location: 7 Km South of an active upside down (boat) volcano.
Start up from the external and hold Command-v, what does it say.

There seem to be more problems like the way you do it, it should work but one way or the other it's not working, it also seems to be happening more or only on SSD's.
justperry is offline   0 Reply With Quote
Old Jan 19, 2013, 05:42 AM   #3
ZaYoOoD
macrumors member
 
Join Date: Aug 2010
You have to either wait for 10.8.3 "which should be out soon" and put in on a Flash, then boot from it to install.
Or, do the internet recovery thing, which is what I did, but it to a LOT of time to download!
ZaYoOoD is offline   0 Reply With Quote
Old Jan 19, 2013, 06:30 AM   #4
dukee101
Thread Starter
macrumors member
 
Join Date: Jan 2009
I did a PRAM reset which did nothing. I'm still getting the "do not" symbol and can't boot into my external.

I also held option at startup, selected the external, and held CMD+V for verbose mode and got the same "do not" symbol.

Lastly, I connected my external USB3 SSD to an older MacBook Pro in the house and it booted perfectly. I got into the installation that I cloned over from the 1 TB HDD that shipped with the mini and confirmed that 10.8.2 Build 12C3103 was running.

That means one thing: something about this 2012 Mac mini won't let the external boot. What could it be? The external's got the identical OS build that shipped with the stock drive. The PRAM's reset. What's going on?? Will it work if I replace the 1 TB HDD in the primary slot with this SSD? I don't want to tear it down just to see it fail, wasting my time and effort.
dukee101 is offline   0 Reply With Quote
Old Jan 19, 2013, 07:25 AM   #5
bplein
macrumors 6502
 
Join Date: Jul 2007
Location: Austin, TX USA
If you have access to another USB external case , maybe an older USB 2.0 version, try that. It could be an incompatibility between the new Mac and the USB 3.0 case during boot. Yes, it works in another Mac, but that's how tricky compatibility issues can be.

The fact that it boots on another Mac is a really good sign. I think you'd be safe in spending the time and effort to put this one inside the new mini.
__________________
Family Macs: late 2012 iMac 27, MBP 13 and 15 Unibody, MB Air, Mac Pro 4,1, and a couple of Mac minis.
bplein is offline   0 Reply With Quote
Old Jan 19, 2013, 07:45 AM   #6
justperry
macrumors 603
 
justperry's Avatar
 
Join Date: Aug 2007
Location: 7 Km South of an active upside down (boat) volcano.
Quote:
Originally Posted by dukee101 View Post
I also held option at startup, selected the external, and held CMD+V for verbose mode and got the same "do not" symbol.
Sorry, but this does not work after you hold the Option key, this never works, even on older Macs.
It only works right after a startup.

For this to work you have to startup from the older mac and then add a boot.plist to the Systemconfiguration folder in /Library/Preferences

Normally if you can boot from the disk you add in Terminal:
nvram "boot-args= -v"

But, you can't do this and I think you can also do this with:
setenv boot-args= -v
justperry is offline   0 Reply With Quote
Old Jan 19, 2013, 09:46 AM   #7
Fishrrman
macrumors 68040
 
Join Date: Feb 2009
I read your posts above, and I don't think you mentioned specifically WHAT you are using to connect the new Crucial SSD to the Mini.

What type of enclosure or dock are you using? Manufacturer and model number please.

My -guess- (and it's only a guess) is you may be using some kind of enclosure or dock that uses a chip or controller that may not support booting with the USB3 on the Mini.

It does support booting via USB2 on an older Mac. But there may be a glitch when trying to boot from USB3.

I'm using an older USB2 "Syba Connectland" USB2/SATA docking station as my current "external boot platform". It works fine with an Intel 520 series SSD in it (though it only runs at USB2 speeds and will be replaced soon).

Oddly enough, I tried an Other World Computing "Voyager Quad" USB3/SATA dock on the Mini, and the OS will not recognize the dock as having USB3 (only USB2). I'm -guessing- it's a problem with the early controller chip inside.
Fishrrman is offline   0 Reply With Quote
Old Jan 19, 2013, 09:59 AM   #8
justperry
macrumors 603
 
justperry's Avatar
 
Join Date: Aug 2007
Location: 7 Km South of an active upside down (boat) volcano.
Quote:
Originally Posted by Fishrrman View Post
I read your posts above, and I don't think you mentioned specifically WHAT you are using to connect the new Crucial SSD to the Mini.

What type of enclosure or dock are you using? Manufacturer and model number please.

My -guess- (and it's only a guess) is you may be using some kind of enclosure or dock that uses a chip or controller that may not support booting with the USB3 on the Mini.

It does support booting via USB2 on an older Mac. But there may be a glitch when trying to boot from USB3.

I'm using an older USB2 "Syba Connectland" USB2/SATA docking station as my current "external boot platform". It works fine with an Intel 520 series SSD in it (though it only runs at USB2 speeds and will be replaced soon).

Oddly enough, I tried an Other World Computing "Voyager Quad" USB3/SATA dock on the Mini, and the OS will not recognize the dock as having USB3 (only USB2). I'm -guessing- it's a problem with the early controller chip inside.
Have to politely disagree.
Just do a search here on MR, it is most likely SSD's and 10.8.X custom builds which causes all these problems, CCC is many times involved, CCC uses OS X commands so I don't blame CCC, most likely some OS X bugs.
justperry is offline   0 Reply With Quote
Old Jan 19, 2013, 12:39 PM   #9
g4cube
macrumors 6502a
 
Join Date: Apr 2003
If you use supplied Apple Disk Utility System Restore to clone the internal drive to the external SSD, you will be one step closer to having a bootable external drive. Other cloning solutions may not be aware of the special version of OS X that ships with your mini.

Second, as another has suggested, your USB 3.0 drive dock you are using may not be compatible with the Mac mini. Make sure you have a "good" USB 3.0 cable. Some docks and chassis have marginal USB 3.0 interfaces; if you have a micro-B USB 2.0 cable (narrower than the wide micro-USB 3.0), and the more conventional A-B USB 2.0 cable, try using that to see if your computer will boot at the slower connection speed. Using the alternate cable forces the USB 2.0 connection

I have no problem booting from an external LaCie Rugged SSD drive when using either its USB 3.0 connection or its Thunderbolt connection. I used Disk Utility System Restore to clone the internal disk drive. My mini has a single HDD inside; not the Fusion drive configuration.
g4cube is offline   0 Reply With Quote
Old Jan 19, 2013, 10:03 PM   #10
dukee101
Thread Starter
macrumors member
 
Join Date: Jan 2009
Smile Problem Mostly Solved!

Quote:
Originally Posted by bplein View Post
If you have access to another USB external case , maybe an older USB 2.0 version, try that. It could be an incompatibility between the new Mac and the USB 3.0 case during boot. Yes, it works in another Mac, but that's how tricky compatibility issues can be.

The fact that it boots on another Mac is a really good sign. I think you'd be safe in spending the time and effort to put this one inside the new mini.
Thanks everyone for all the great feedback, but shout out to bplein who was the first to point out the USB-SATA mechanism as the problem: you're right!

I unplugged my M4 SSD from this Kingwin USB 3 to SATA adapter and I used this other enclosure I had lying around, a Rosewill USB 2 model, and it booted without a hitch!

Then, just to be extra-safe, I erased the cloned SSD and used the mini's Internet Recovery to re-install 10.8.2 back to the SSD, just to see if this USB-2 testbed was working, and sure enough, everything went great.

I'm now ready to tear down the mini and do the drive replacement! I will confirm for you all tomorrow when I get a chance to do that.

For now: consider this problem 95% solved! So to all those who will come ahead of me, take note, these 2012 minis are very picky about USB storage peripherals.
dukee101 is offline   0 Reply With Quote
Old Jan 20, 2013, 09:54 AM   #11
Fishrrman
macrumors 68040
 
Join Date: Feb 2009
"I unplugged my M4 SSD from this Kingwin USB 3 to SATA adapter and I used this other enclosure I had lying around, a Rosewill USB 2 model, and it booted without a hitch!
...
For now: consider this problem 95% solved! So to all those who will come ahead of me, take note, these 2012 minis are very picky about USB storage peripherals."

Now -- and this reply is aimed directly at "justperry" above -- what did I say in paragraphs 3 and 4 of reply #7 above?

The inability to boot was caused by a docking station that was incompatible with the Mini and USB3...

Switch the hardware, problem solved.
Fishrrman is offline   0 Reply With Quote
Old Jan 20, 2013, 04:34 PM   #12
dukee101
Thread Starter
macrumors member
 
Join Date: Jan 2009
Quote:
Originally Posted by Fishrrman View Post
Switch the hardware, problem solved.
Yes but will these bugs go away over time? I want to be able to use USB3 on this mini. How will I know what devices to buy? I don't expect malfunctions like that when I give Apple my $1,000.
dukee101 is offline   0 Reply With Quote
Old Jan 20, 2013, 09:27 PM   #13
g4cube
macrumors 6502a
 
Join Date: Apr 2003
Quote:
Originally Posted by dukee101 View Post
Yes but will these bugs go away over time? I want to be able to use USB3 on this mini. How will I know what devices to buy? I don't expect malfunctions like that when I give Apple my $1,000.
You gave Apple $1000 to get a good computer.

You'll need to give your $$$ to the vendor that supports USB 3.0 well. Take a look at the Apple Store to see what USB 3.0 storage products Apple is willing to sell to you.

I've had issues with some USB 3.0 products.

I've had no issue with the WD, Seagate, G-Tech, or LaCie USB 3.0 products listed at the Apple store.
g4cube is offline   0 Reply With Quote
Old Jan 20, 2013, 09:39 PM   #14
philipma1957
macrumors 603
 
Join Date: Apr 2010
Quote:
Originally Posted by dukee101 View Post
Yes but will these bugs go away over time? I want to be able to use USB3 on this mini. How will I know what devices to buy? I don't expect malfunctions like that when I give Apple my $1,000.
Thunderbolt = Reliable


USB3 = Do I feel lucky



that is just the way it is.

I have tested 6 to 8 t-bolt all were really good booters except seagate stae121 that was okay.


I have tested 4 or 5 USB3 as booters but all were only okay as booters.

I have moved on I will revisit USB3 after the 10.8.3 update drops.
philipma1957 is offline   0 Reply With Quote
Old Jan 20, 2013, 10:02 PM   #15
dukee101
Thread Starter
macrumors member
 
Join Date: Jan 2009
Smile Problem 100% Solved!

Good news everyone: just performed the drive replacement and the operation went smoothly. The SSD is now in the mini and is booting and functioning just as it should be. This confirms that any booting problems you may experience with the 2012 Mac mini are related to USB compatibility quirks.

The upgrade itself took about 45 minutes, mostly because I had to spend about 20 minutes trying to slot the drive back in (getting the two screws to slot into the the right grommets). The rest was super-easy. No logic board removal needed or anything. In fact, I've posted a detailed instruction guide for anyone else who's looking to do the drive replacement: http://forums.macrumors.com/showthread.php?p=16696502

Lastly...

Quote:
Originally Posted by philipma1957 View Post
I have moved on I will revisit USB3 after the 10.8.3 update drops.
Word to that. We'll revisit with the next ML minor release. Thanks for chiming in with your detailed feedback.

Last edited by dukee101; Jan 20, 2013 at 10:45 PM.
dukee101 is offline   0 Reply With Quote
Old Jan 20, 2013, 10:05 PM   #16
bplein
macrumors 6502
 
Join Date: Jul 2007
Location: Austin, TX USA
Quote:
Originally Posted by dukee101 View Post
Yes but will these bugs go away over time? I want to be able to use USB3 on this mini. How will I know what devices to buy? I don't expect malfunctions like that when I give Apple my $1,000.
Why are you assuming it's an Apple bug?

I work for a computer hardware company, so I've seen almost every combination of interop you can think of in my experience at the current employer as well as past companies.

This could be a case of the USB3.0 external case vendors using well known, but cheap chipsets. Apple may be sticking to the spec, and the USB case vendor is outside it. But other laptops may be more LOOSE in working with out-of-spec devices.

Alternately, Apple may be out of spec.

USB devices are almost UNIVERSALLY cheap commodity chipsets. I know of nobody who sells a high end USB3.0 external device that plays to the high end of the market by showing how their chipset is any better than any other. Most of them are coming from a small handful of chipsets.

If you look at the recent past, with USB2.0, people bought it for one of two reasons (if not both).
  • Universal compatibility across computers and Operating Systems
  • Cheaper than FireWire

Firewire 400 (not to mention 800) is SO much better than USB2.0, but there are a lot of people who refused to buy the more expensive cables and interface, even if all they used were Macs.

With USB3.0, the same crowd is buying USB devices because they are cheaper. They point at simplistic benchmarks to show that Thunderbolt isn't worth the cost. But along with "cheaper" comes "interoperability headaches".
__________________
Family Macs: late 2012 iMac 27, MBP 13 and 15 Unibody, MB Air, Mac Pro 4,1, and a couple of Mac minis.
bplein is offline   1 Reply With Quote
Old Jan 20, 2013, 10:15 PM   #17
philipma1957
macrumors 603
 
Join Date: Apr 2010
Quote:
Originally Posted by bplein View Post
Why are you assuming it's an Apple bug?

I work for a computer hardware company, so I've seen almost every combination of interop you can think of in my experience at the current employer as well as past companies.

This could be a case of the USB3.0 external case vendors using well known, but cheap chipsets. Apple may be sticking to the spec, and the USB case vendor is outside it. But other laptops may be more LOOSE in working with out-of-spec devices.

Alternately, Apple may be out of spec.

USB devices are almost UNIVERSALLY cheap commodity chipsets. I know of nobody who sells a high end USB3.0 external device that plays to the high end of the market by showing how their chipset is any better than any other. Most of them are coming from a small handful of chipsets.

If you look at the recent past, with USB2.0, people bought it for one of two reasons (if not both).
  • Universal compatibility across computers and Operating Systems
  • Cheaper than FireWire

Firewire 400 (not to mention 800) is SO much better than USB2.0, but there are a lot of people who refused to buy the more expensive cables and interface, even if all they used were Macs.

With USB3.0, the same crowd is buying USB devices because they are cheaper. They point at simplistic benchmarks to show that Thunderbolt isn't worth the cost. But along with "cheaper" comes "interoperability headaches".
I was able to use fw800 as stable booters far more often then any usb2.


In fact Sans Digital made some rock solid fw800 2 bay cases. I can list 3 great 2 bay fw800 cases.



http://www.sansdigital.com/towerstor/ts2ct.html


a great case. I built a few modded ones used by some sound engineers with 2009 mac minis.


http://eshop.macsales.com/shop/firew.../Gmax_Portable


http://eshop.macsales.com/shop/firew...W800_FW400_USB


these were really good gear. if you did not have an esata connection you could run 2x ssds as raid0 safely and while long reads and writes were okay. iops whaled so they were faster then any internal hdd (not ssd) back in 2009 and stable 100% never lost a raid0. And almost never had a crash.
philipma1957 is offline   0 Reply With Quote
Old Jan 21, 2013, 08:52 AM   #18
elolaugesen
macrumors member
 
Join Date: Aug 2008
Backup Works

The mini 2012 comes with a special OSX release. Nothing else will boot.

I ended up booting the supplied os then using the migration assistant copied all from by backup drive. I have backups going back to tiger.. Nothing booted



It worked I verified all. Ok.

ie I restored files from backup to up the new system with minimac osx(supplied os - olddata, settings, apps etcetcetc) using apple migration assistant.


Then rebooted from external osx . All works.

ONLY SPECIAL MINI 2012 OSX build willboot

Cheers ELO
elolaugesen is offline   0 Reply With Quote
Old Jan 21, 2013, 09:19 AM   #19
Fishrrman
macrumors 68040
 
Join Date: Feb 2009
"Yes but will these bugs go away over time? I want to be able to use USB3 on this mini. How will I know what devices to buy?"

You will know by taking sufficient time to properly investigate products BEFORE you buy.

I myself had problems with an Other World Computing "Voyager Quad" USB3/SATA docking station. It gave me problems with both my 2006 white Intel iMac, and again when I tried to use it with my new 2012 Mini. Probably a controller chip that exhibits incompatibility with the Mac version of USB3.

Quite a few Mac users are reporting problems with both USB3 docks and hubs. Apparently, the first iterations of USB3 on the Mac had some glitches and bugs. Seems to me that some of the software updates that have come out recently have attempted to address those problems.

A good way to check out an item you're considering purchasing is to go to amazon.com and read the user reviews, paying close attention to postings by Mac users...
Fishrrman is offline   0 Reply With Quote
Old Jan 25, 2013, 04:08 PM   #20
knujon
macrumors newbie
 
Join Date: Jul 2010
Thank you all for this thread. I was having the same problem with an SSD drive I installed internally on a dual-HD Mini Server. Couldn't boot the 2012 Mini using Lion or Mountain Lion on a variety of bootable media. Eventually attached the SSD disk to another Mac using a SATA adapter, booted it in target mode and installed ML, but still got the "prohibit sign" when I tried to set it as the Startup Disk. I even took the Mini to an Apple store but the Genius couldn't figure it out either, and never did he mention the ML installation was custom to the Mini Server. After reading this thread I cloned the system disk that shipped with the Mini to the SSD drive using CCC (including creating the Recovery partition), and it booted just fine!

So thanks again to all for solving my problem.

-Brian
knujon is offline   1 Reply With Quote
Old Jan 25, 2013, 05:11 PM   #21
elolaugesen
macrumors member
 
Join Date: Aug 2008
This problem has happened before when apple have made hardware changes. All should? ??????????? Work as normal when these changes are incorperated into the next release of OSX. ( check first)


Cheers elo

Last edited by elolaugesen; Jan 25, 2013 at 05:12 PM. Reason: Spelling using my IPAD one less mac sale????
elolaugesen is offline   0 Reply With Quote
Old Jan 21, 2014, 04:44 PM   #22
nj3a
macrumors newbie
 
Join Date: Jan 2014
Not enough power from 'USB3

Ran into the same/similar problem. Wanted to erase an SSD I replaced using the USB3 to SATA connection cable..Mac Mini didn't recognize it. Had to use my cloning dock with USB3 connection, with power supply to have it recognized by USB3 on the Mac Mini. Once I added power..there it was in the finder. Could easily erase using disk utilities after that.
nj3a is offline   0 Reply With Quote
Old Jan 21, 2014, 06:15 PM   #23
paulrbeers
macrumors 68040
 
Join Date: Dec 2009
Quote:
Originally Posted by nj3a View Post
Ran into the same/similar problem. Wanted to erase an SSD I replaced using the USB3 to SATA connection cable..Mac Mini didn't recognize it. Had to use my cloning dock with USB3 connection, with power supply to have it recognized by USB3 on the Mac Mini. Once I added power..there it was in the finder. Could easily erase using disk utilities after that.
Many SSDs over 256gb use more power than USB can provide. This has been showing up more than ever now that 500gb SSDs are actually becoming reasonable.
paulrbeers is offline   1 Reply With Quote
Old Jan 21, 2014, 09:41 PM   #24
g4cube
macrumors 6502a
 
Join Date: Apr 2003
USB 2.0 ports provide 2.5watts while USB 3.0 ports supply 4.5watts.

That is the usual reason why some have issues with older Macs.

Some Macs (and PCs) can provide more than 2.5watts, but this is not guaranteed.
g4cube is offline   0 Reply With Quote
Old Jan 22, 2014, 12:44 PM   #25
ElectronGuru
macrumors 6502a
 
Join Date: Sep 2013
Location: Oregon, USA
Can you add a powered USB hub?
__________________
MBP, IM, MM, IPM, IP, AT
ElectronGuru is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > Mac mini

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mac Mini 2012 SSD Internal or External for Boot Drive? ianjh Mac mini 4 Jan 3, 2014 03:38 AM
2012 Mac mini won’t internally boot to SSD. Rickmini Mac mini 0 Oct 31, 2013 01:17 PM
External SSD Boot Drive on 2012 Mini? Cyndane Mac Peripherals 4 Apr 7, 2013 09:25 AM
2012 Mac Mini won't recognize external HD... help! Molson1020 Mac mini 1 Nov 14, 2012 12:29 AM
2012 Mac mini can't boot from iMac SSD off of TB MrXiro Mac mini 5 Nov 3, 2012 12:00 PM

Forum Jump

All times are GMT -5. The time now is 06:41 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC