Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 23, 2013, 09:16 PM   #1
Kyle N
macrumors newbie
 
Join Date: Mar 2012
'07 imac taking a dump (random slow performance)

Ok so I have had my computer since new. The original HDD went out last summer, so I replaced it with a 1 Tb (reformatted). The drive went out because I dropped the computer. Installed Snow Leopard and Microsoft Office, Matlab and thats about it. And all system updates.

I have been running it like this for months, like 5, it's been fine.

Like said, I did drop the computer, I was surprised I revived it. BUT because it has been running fine since, I don't have strong reason to believe this has anything to do with the problems.

I will say, though, after the system install, I encountered some issues. I ran Disc Utility. Some stuff just couldn't be cleaned. I dont know why, did it twice. But fixed the hiccups, although there were unrepairable issues in the background.



NOW...

Start it up. Works fine. The next day, downhill. So now it gives me the good-ol beach ball relatively frequently. This is with ONLY Safari ~or~ Image Preview open. Other programs like MS Excel or Firefox just give me the finger and that error message like below. Sometimes Image Preview randomly closes and the same with Itunes. Itunes doesnt open now. Says it unexpectadely quit, doesnt even pop up the window. Then some report to Apple screen with a bunch of code giberish.

Process: iTunes [417]
Path: /Applications/iTunes.app/Contents/MacOS/iTunes
Identifier: com.apple.iTunes
Version: 11.0 (11.0)
Build Info: iTunes-1100099063000000~1
Code Type: X86 (Native)
Parent Process: launchd [88]

Date/Time: 2013-01-23 22:02:45.278 -0500.................................
..................................................................................................

I have downloaded or installed ABSOLUTELY NOTHING over the past several weeks. And even didn't even operate the computer for 5 days before (moved from Oregon to New York. And no, it was not damaged in the travel. Although Nevada did drop to 1 overnight. But that shouldn't be an issue.


So these random beachballs...

Basically running jack, the cpu slows down. I opened activity monitor to check background, and nothing was there loading it up (as expected). I ran the monitor while using Safari. It locked up, as expected, beachball and the monitor completely stopped. After the beachball finished and the cpu came back to its senses, everything continued like the thing was on pause.

It seems to only want to run bare bones programs. According to the Monitor, it isn't even loading the CPU very much. Just the monitor taking like 0.6% with everything else on idle.

Given this....any input folks? I have reformatted this thing as few times. And yes, I was able to run Disc Utility again yesterday to dry and fix it. No avail...

THanks, Kyle.

(I really dont want to have to dig my format discs out of a box in a storage unit right now!)
Kyle N is offline   0 Reply With Quote
Old Jan 23, 2013, 09:22 PM   #2
Intell
macrumors P6
 
Intell's Avatar
 
Join Date: Jan 2010
Location: Inside
There are a few things that cannot be fixed by Disk Utility and are best left as they are and safe to ignore. When you're looking at Activity Monitor, are you looking at all of the processes and not just your own? Could you post a complete crash log? You can remove lines that contain personal stuff like an IP address, username, serial number, and what ever else you want. But the more the better. Have you gotten any kernel panics or only crashes?
__________________
Last edited by Intell; Yesterday at 3:16 AM.
Intell is offline   0 Reply With Quote
Old Jan 24, 2013, 08:16 AM   #3
Kyle N
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
Hmm I don't know the difference so I will look into that. I think a simple way to determine if it is a non HDD problem is to boot from the installation disc and run some stuff. See how it performs. If still **** then it may be a HDD problem. By install or actual quality.

Thanks.
Kyle N is offline   0 Reply With Quote
Old Jan 24, 2013, 08:27 AM   #4
forty2j
macrumors 68030
 
forty2j's Avatar
 
Join Date: Jul 2008
Location: NJ
If you have the original disks, your best bet right now is Apple Hardware Test.
__________________
 2012 iMac 3.2GHz 27" 680MX Fusion  iPhone 6  Apple TV 2  iPad Air 
forty2j is offline   0 Reply With Quote
Old Jan 24, 2013, 04:59 PM   #5
Kyle N
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
As of 9 days ago I had the original discs. They were boxed up, as I moved across the country. I just spent an hour in 10 air searching for them in storage unit. And go figure, my external HDD is missing as well. Which should be in the same location.

$#$&^%$

This computer is running slower and slower. I am thinking the HDD is on its way out. Ugh. It is thinking as much as someone high napping in class. As I type this, I am literally typing several sentences before the text even shows up on the screen.
Kyle N is offline   0 Reply With Quote
Old Jan 24, 2013, 05:19 PM   #6
keysofanxiety
macrumors 65816
 
keysofanxiety's Avatar
 
Join Date: Nov 2011
Location: In a house that defies physics by being colder than absolute zero.
Red face

Have you tried repairing the disk through Single User Mode? I've found on SL that it tends to work a bit better than the DU on the DVD. Maybe it's just old habits though; I guess it's the same thing as Disk Utility without the GUI.

Also for Apple Extended Hardware Test, simply hold 'D' key on boot when plugged in via Ethernet. Seems to work on SL machines as well, which I found out to my surprise (thought it was only Lion onwards). Mind you, in my experience the AEHT isn't really that useful.

Long story short, if DU comes with any 'red' writing when doing the verification, that really isn't okay. Although that's quite a simple way to look at it.

Is it possible that the new drive you got for it is DOA?

----------

Quote:
Originally Posted by Kyle N View Post
As of 9 days ago I had the original discs. They were boxed up, as I moved across the country. I just spent an hour in 10 air searching for them in storage unit. And go figure, my external HDD is missing as well. Which should be in the same location.

$#$&^%$

This computer is running slower and slower. I am thinking the HDD is on its way out. Ugh. It is thinking as much as someone high napping in class. As I type this, I am literally typing several sentences before the text even shows up on the screen.
Sorry to spam this, just to add; don't worry about the original DVDs and the like. If you've got an external HDD/working Mac, just 'acquire' an iso of SL and mount it to one of the partitions on the external HDD. You'll easily be able to boot from that to do exactly the same things.

Alternatively if anybody you know has a Time Machine backup from Lion onwards, you can also boot into the Time Machine backup on startup and it has all your Disk Utility features and everything else you might need. Don't worry if you've lost the DVDs because there are plenty of other ways you can go about it, should you need to repair disk/reinstall.

Hope I'm answering the question rather than just rambling
keysofanxiety is offline   0 Reply With Quote
Old Jan 24, 2013, 05:31 PM   #7
Intell
macrumors P6
 
Intell's Avatar
 
Join Date: Jan 2010
Location: Inside
Quote:
Originally Posted by keysofanxiety View Post
Also for Apple Extended Hardware Test, simply hold 'D' key on boot when plugged in via Ethernet. Seems to work on SL machines as well, which I found out to my surprise (thought it was only Lion onwards). Mind you, in my experience the AEHT isn't really that useful.
The Apple Hardware Tests for the '07 iMac only test the ram. They are also only available on the original installation of Mac OS X or an installation of Mac OS X installed by the original restore discs or an installation of Mac OS X that was upgraded from one of the previous two mentioned installations. Pressing D while having an Ethernet cable plugged in won't do anything as this model iMac does not have the ability to use the Internet Diagnostics or Restore that newer iMacs has. What the OP needs to properly test his machine are the Apple Service Discs which are only giving to Apple Technicians.
__________________
Last edited by Intell; Yesterday at 3:16 AM.
Intell is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Slow iMac performance SSD 840 Pro choupimab iMac 24 Mar 23, 2014 12:55 PM
Random slow shutdowns AeroZ MacBook Pro 5 Aug 9, 2013 03:11 PM
iMac 2.93 27-Inch (Mid-2010) Bios Chip Dump rendezo iMac 9 Mar 20, 2013 03:28 PM
Random performance issues on rMBP smeegers MacBook Pro 3 Feb 3, 2013 04:58 PM
Will Thunderbolt affect random performance of ext. SSD? wmy5 iMac 3 Dec 2, 2012 01:51 PM

Forum Jump

All times are GMT -5. The time now is 03:18 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC