Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 29, 2013, 02:46 AM   #1
MrXiro
macrumors 68030
 
MrXiro's Avatar
 
Join Date: Nov 2007
Location: Los Angeles
Apple TV 5.2 Update doesn't fix airplay latency issue

Not sure if anyone has noticed this... but ever since Atv had been updated to 5.1 (iOS 6) there has been a latency issue which one wouldn't notice right off the bat, but if you go to iTunes and turn on the Multiple Speakers setting and have it playing on all of your speakers (computer, airplay speaker, Airport Express audio out, AppleTV) only the Atv will not be in synch with the other speakers. The computer and all of my other Airplay audio speakers are in perfect harmony but on my Atv there is about a .5 second delay. Also if you're streaming something from the web and Airplay mirroring it to the Atv the audio and video on the Atv will be out of sync from the Computer's display (I use a Mac Mini)

Just wanted to note that and see if anyone else has noticed this issue. But it is from before iOS 6 came out.
__________________
Whole lotta , very little $.

Last edited by MrXiro; Jan 29, 2013 at 07:58 PM.
MrXiro is offline   0 Reply With Quote
Old Jan 29, 2013, 12:20 PM   #2
waw74
macrumors 68020
 
Join Date: May 2008
i stream in perfect sync to multiple devices
just tried to confirm using an TV3*, express with speakers, and a pair of standalone airplay speakers. all in sync.

*TV is updated with the brand new firmware.

also, the video is being converted, and then transmitted over the network. a small delay is to be expected, it's not just with web video, it's everything. Open a finder window, and close it, same delay.
waw74 is offline   0 Reply With Quote
Old Jan 29, 2013, 01:12 PM   #3
paulrbeers
macrumors 68040
 
Join Date: Dec 2009
Quote:
Originally Posted by MrXiro View Post
Not sure if anyone has noticed this... but ever since Atv had been updated to 5.1 (iOS 6) there has been a latency issue which one wouldn't notice right off the bat, but if you go to iTunes and turn on the Multiple Speakers setting and have it playing on all of your speakers (computer, airplay speaker, Airport Express audio out, AppleTV) only the Atv will not be in synch with the other speakers. The computer and all of my other Airplay audio speakers are in perfect harmony but on my Atv there is about a .5 second delay. Also if you're streaming something from the web and Airplay mirroring it to the Atv the audio and video on the Atv will be out of sync from the Computer's display (I use a Mac Mini)

Just wanted to note that and see if anyone else has noticed this issue.
Since the ATV has no speakers, are you sure the delay isn't from whatever is playing back the audio? I am not sure I have an ATV in ear shot of any of my Airport Expresses so I can't speak and/or test any audio delay compared to other Airplay devices.

Edit: And yes of course there is a delay from what is playing on your mac mini to what is finally put up on your screen. I figure if I am using Airplay mirroring, I don't intend to be sitting in front of my mac to notice.
__________________
rMBP 11,2 15" 2.0Ghz w/ 256GB SSD
MBA 6,2 13" 1.7Ghz w/ 256GB SSD
Mac Mini 6,2 2.3ghz w/ 240GB SSD + 1TB
Mac Pro 1,1 w/ 8 cores @ 2.66 w/ 240GB SSD
paulrbeers is online now   0 Reply With Quote
Old Jan 29, 2013, 07:46 PM   #4
MrXiro
Thread Starter
macrumors 68030
 
MrXiro's Avatar
 
Join Date: Nov 2007
Location: Los Angeles
Hmm... I'll have to look into this further.
__________________
Whole lotta , very little $.

Last edited by MrXiro; Jan 29, 2013 at 07:58 PM.
MrXiro is offline   0 Reply With Quote
Old Feb 8, 2013, 07:04 AM   #5
snowbaked
macrumors newbie
 
Join Date: Oct 2011
I'm getting a delay using airplay going from Apple TV to Sonos via an Airport Express (connected to the Sonos using an ethernet cable).

I'm not sure if this is expected or my set-up - probably expected. The delay is quite short, and much more if I connect the airport to sonos via my wi-fi network.
snowbaked is offline   0 Reply With Quote
Old Feb 8, 2013, 09:22 AM   #6
waw74
macrumors 68020
 
Join Date: May 2008
Quote:
Originally Posted by snowbaked View Post
I'm getting a delay using airplay going from Apple TV to Sonos via an Airport Express (connected to the Sonos using an ethernet cable).

I'm not sure if this is expected or my set-up - probably expected. The delay is quite short, and much more if I connect the airport to sonos via my wi-fi network.
a delay in starting?
all audio airplay* has a delay in starting, there is a small buffer built in, it normally runs about 2 seconds behind.
in iTunes, and iOS devices, this delay is also applied to the interface, so that it all matches up.
(you can test this, play a song in iTunes on the computer speakers only and skip to the next track, now switch to airplay speakers and skip again, locally it's almost instant, remote there is a small pause)

the OP was referring to streaming to multiple speakers at the same time, and one of them being out of sync with the others.

*video airplay is handled a bit differently.
waw74 is offline   0 Reply With Quote
Old May 16, 2013, 10:51 PM   #7
dfcster
macrumors newbie
 
Join Date: Mar 2009
Exclamation Delay = Out of Sync

I have the same issues with multiple AirPlay devices, iMac, other iMac, MacMini, Airport Express all play in Sync; AppleTV latest Generation (with all updates) is out of Sync with all the other Airplay devices; not by much just a tiny fraction, but noticeable and it's very annoying! (Actually un-useable).

I hope Apple fix this; was a problem with my ATV2 and still a problem with the ATV3.

Last edited by dfcster; May 16, 2013 at 10:59 PM.
dfcster is offline   0 Reply With Quote
Old May 17, 2013, 12:09 AM   #8
linds15
macrumors 6502a
 
Join Date: Oct 2012
Location: Great White North
Quote:
Originally Posted by dfcster View Post
I have the same issues with multiple AirPlay devices, iMac, other iMac, MacMini, Airport Express all play in Sync; AppleTV latest Generation (with all updates) is out of Sync with all the other Airplay devices; not by much just a tiny fraction, but noticeable and it's very annoying! (Actually un-useable).

I hope Apple fix this; was a problem with my ATV2 and still a problem with the ATV3.
try a restore and start from scratch? could help
__________________
2012 Mac Mini 2.6, 16GB Crucial Ram, 256 Samsung 830 SSD 2012 MBA 1.8Ghz, 4GB Ram, 128SSD JB iPhone 5 32GB JB iPad 2 32GB ATV3
Cord Cutter w/NBA, NHL, & NFL
linds15 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Issue with Airplay mirroring to Apple TV doubledge OS X Mavericks (10.9) 0 Oct 25, 2013 05:17 AM
Apple Releases 'Mac Wi-Fi Update 1.0' to Fix 5GHz Wi-Fi Issue MacRumors Mac Blog Discussion 18 Dec 19, 2012 04:11 AM
Can Software Update Fix Bluetooth Issue? polythene iPhone 7 Oct 2, 2012 03:03 PM
Can A Software Update Fix the iPhone 5 Bluetooth Issue? polythene iPhone Tips, Help and Troubleshooting 0 Oct 2, 2012 12:44 AM
If Apple doesn't fix my battery davyvfr MacBook Pro 16 Sep 5, 2012 10:12 PM

Forum Jump

All times are GMT -5. The time now is 06:33 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC