Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 31, 2013, 12:01 AM   #1
gursis11
macrumors member
 
Join Date: Oct 2011
Can't make iPhone simulator locate (using Debug > Location >Apple)

This happens after I tell it to zoom in onto the location, before this, it works fine. I tried this on the app I'm developing and also in the stock Apple Maps. Google Maps on Safari can locate though.
Any help would be much appreciated.

PS. I'm pretty new and am following this tutorial: http://www.appcoda.com/ios-programmi...th-mapkit-api/
so, if there seems that there's anything wrong, do correct me.

Thanks!
gursis11 is offline   0 Reply With Quote
Old Jan 31, 2013, 04:32 PM   #2
ianray
macrumors 6502
 
Join Date: Jun 2010
Location: @
You haven't given many details, but I assume you figured out that in those instructions MyLocationViewController is actually ViewController?

Is 'Shows User Location' ticked in Map View properties?

What happens if you set a breakpoint on mapView:didUpdateUserLocation: ?
__________________
My App Store Apps: Dashometer, Exinf, Score&Grade
ianray is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Tags
location, maps, simulator, xcode

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:38 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC