Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 5, 2013, 12:40 PM   #1
desismokerz
macrumors newbie
 
Join Date: Jun 2011
Location: Luton, England
Safari Problem

why some of the youtube videos are not working in safari whereas are working in chrome???Click image for larger version

Name:	Screen Shot 2013-02-05 at 18.36.36.png
Views:	52
Size:	496.0 KB
ID:	394666 every time i click on a video this screen comes up...

anybody please tell me whats the problem and how to resolve this...?
Many thanks
desismokerz is offline   0 Reply With Quote
Old Feb 5, 2013, 12:44 PM   #2
GGJstudios
macrumors Westmere
 
Join Date: May 2008
That works fine for me on Safari. Check to see what extensions, plug-ins and ad-blockers you may have installed that may be interfering.

I use Flash on Safari with ClickToFlash to control which content plays, and I have zero issues with it. Generally speaking, Flash is notorious for consuming system resources, raising temps and decreasing battery life. For Flash-related issues:
  • Find your Flash version and make sure it's the latest version available. Never install or update Flash from a pop-up on a website. Always go to Adobe's site to get Flash or updates.
  • Install ClickToFlash (Safari), Flashblock (Firefox) or FlashBlock (Chrome) to control which Flash content plays on websites.
  • Install ClickToPlugin (Safari) to prevent Safari from launching plug-ins automatically, resulting in faster browsing, reduced fan usage, and increased battery life. It can also replace many plug-in-based media players with Safariís native HTML5 media player.
  • Try using the YouTube HTML5 Video Player to watch YouTube videos, when available. (May impact fullscreen viewing. See link for details.) Some have reported better performance with HTML5, while some have reported worse. Try it and find out what works best for you.
GGJstudios is offline   0 Reply With Quote
Old Feb 5, 2013, 01:53 PM   #3
desismokerz
Thread Starter
macrumors newbie
 
Join Date: Jun 2011
Location: Luton, England
still it don't solves the problem...
desismokerz is offline   0 Reply With Quote
Old Feb 5, 2013, 02:01 PM   #4
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Quote:
Originally Posted by desismokerz View Post
still it don't solves the problem...
So you've tried the YouTube HTML5 player and it doesn't work?
GGJstudios is offline   0 Reply With Quote
Old Feb 5, 2013, 02:01 PM   #5
xShane
macrumors 6502a
 
xShane's Avatar
 
Join Date: Nov 2012
Location: United States
Quote:
Originally Posted by desismokerz View Post
why some of the youtube videos are not working in safari whereas are working in chrome???Attachment 394666 every time i click on a video this screen comes up...

anybody please tell me whats the problem and how to resolve this...?
Many thanks
It seems like I've seen this issue before.

It seems like something to do with Youtube not streaming to you (the client) properly. Try resetting your Sarari cache and cookies.

You also mentioned that it's only some of the videos. This could most likely just be a fault on Youtube's end. Try the same videos later on (i.e. a few hours or even tomorrow/days), and they will likely work.
__________________
Macbook Pro 15" 2.6, 8GB, 750GB, 1GB VRAM
"Everything for the people, nothing by the people."

"Be the change that you wish to see in the world."
xShane is offline   0 Reply With Quote
Old Feb 5, 2013, 03:34 PM   #6
desismokerz
Thread Starter
macrumors newbie
 
Join Date: Jun 2011
Location: Luton, England
Quote:
Originally Posted by GGJstudios View Post
So you've tried the YouTube HTML5 player and it doesn't work?
no i installed clicktoflash and problem is still there and i know its not youtube problem coz problem is been for last week....and 'some' is like 3 out of 10 are not working...
desismokerz is offline   0 Reply With Quote
Old Feb 5, 2013, 03:36 PM   #7
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Quote:
Originally Posted by desismokerz View Post
no i installed clicktoflash and problem is still there and i know its not youtube problem coz problem is been for last week....and 'some' is like 3 out of 10 are not working...
Try the HTML trial for YouTube, as suggested.
GGJstudios is offline   0 Reply With Quote
Old Feb 7, 2014, 02:19 PM   #8
lindner
macrumors newbie
 
Join Date: Feb 2014
I have had exactly the same problem over the last couple of days.

I've noticed that all videos from the U.K. work fine but all those that have been uploaded from other countries will not play. Incidentally I have played every one of these overseas videos countless times before without any problems. The videos all still play back OK on my iphone and smart TV.

Am really at a loss now as to what has gone wrong.

Quote:
Originally Posted by desismokerz View Post
no i installed clicktoflash and problem is still there and i know its not youtube problem coz problem is been for last week....and 'some' is like 3 out of 10 are not working...
lindner is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Safari problem rocat1997 iOS 7 2 Apr 17, 2014 06:38 PM
Problem with safari flimzy Mac Basics and Help 1 Jan 19, 2014 09:10 PM
Safari problem benfica35 Mac mini 0 Dec 20, 2012 04:23 PM
iPhone: Safari Problem Futhark iOS 6 5 Oct 24, 2012 09:23 AM
Safari problem - "Safari canít save the file" GeorgeTheBest Web Design and Development 0 Jun 14, 2012 03:37 AM

Forum Jump

All times are GMT -5. The time now is 08:14 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC