Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 22, 2013, 02:27 AM   #1
micke1967
macrumors member
 
Join Date: Nov 2012
Garageband and M-Audio Fast Track USB music interface

Hi All
I am totally new to OS X and just got my fist iMac (so very happy) even though I have worked with computers for about 20 years in different ways.

Now I also play some guitar...

So I bought myself a M-Audio Fast Track music interface.
And I installed its drivers and also the Pro Tools that came along.
but have some issues or questions...

First off..when I plug the music interface into the iMac via the usb cable it does not show up as a unit/disc image on my desktop or in finder as does all other usb hard drives and similar...Is it not supposed to?? or is something wrong??

Secondly, and this might very well being a fact of that Ive not understood correctly...
If I want to just plug in my guitar to the musical interface and then hear my guitar through the iMAC - how would I do that??

I assume I need to do it via Garageband but how exactly??

And in this case I dont nessiscarily want to record but simply play my guitar and hear it amplified through the musical interface and the iMac and also being able to use the different amplifiers present in garageband...

Now is that at all possible and if so how???

Or if I simply want to plug the guitar and play is there other software that does amplify and offers different amplifiers and effects in a simpler or better way than Garageband?? on an iMac...

I hope theres someone out ther that could help me out on this...
Best regards Micael From sweden...
micke1967 is offline   0 Reply With Quote
Old Feb 22, 2013, 02:52 AM   #2
Jessica Lares
macrumors 603
 
Jessica Lares's Avatar
 
Join Date: Oct 2009
Location: Near Dallas, Texas, USA
Why aren't you using Pro Tools?
__________________
Have You Hugged Your Mac Today?
Daily Expressions | iMac G4 | Late 2011 13" MacBook Pro | iPod Nano (7G) | iPad Mini | iPod Touch (5G) | iPhone 5S
Jessica Lares is offline   0 Reply With Quote
Old Feb 22, 2013, 02:56 AM   #3
dan1eln1el5en
macrumors regular
 
Join Date: Jan 2012
Hey I got same setup at home.

Now I'm not sitting in front of my mac, so from memmory.

No, the sound card will not popup as a harddrive (since it doesn't have any space on it), you go to System settings, sound and under input/output the M-audio will be available to choose in the list.

in regards to Garageband it doesn't use the system settings, you have to go into Garagebands settings and pick the input device.

Greetings from Daniel in Denmark
dan1eln1el5en is offline   0 Reply With Quote
Old Feb 22, 2013, 09:31 AM   #4
Fishrrman
macrumors 68040
 
Join Date: Feb 2009
Open Audio/MIDI Setup (it's in the Utilities folder).

Do you see the "presence" of the audio interface in A/M's window?
Fishrrman is offline   0 Reply With Quote
Old Feb 22, 2013, 11:27 AM   #5
micke1967
Thread Starter
macrumors member
 
Join Date: Nov 2012
Hi an thanks for your reply.
And NO I only see 2 entries there for 2 built in microphones...could that be it??
I have tried for example this:'
1) Launch GarageBand and go into the GarageBand menu.
2) Select Preferences and then AUDIO/MIDI
3) Set the input and output driver as the Fast Track USB
4) Close the Preferences and Create a New Music Project
5) Go to the Track menu and select New Track
6) Create a Real Instrument Track and the Track Info pane will open at the right side of the screen.
7) At the bottom of the Track Info pane click on Input Source and select MONO 1 (M-Audio Fast Track for the XLR Mic input and MONO 2 M-Audio Fast Track for the guitar input)
8) Turn Monitor ON
9) Click the record button in the transport and try recording.

and also tried it like this video exactly but no sound...
http://www.youtube.com/watch?v=dAU3XVAgVJ4

help please...
best regards micael
micke1967 is offline   0 Reply With Quote
Old Feb 22, 2013, 11:49 AM   #6
micke1967
Thread Starter
macrumors member
 
Join Date: Nov 2012
HI I now downloaded new driver from www.avid.com and I now can see my unit in audio/midi...and I hear sound...horray...

However I get a snapping sound in the speakers when playin my fender guitar...like small short firecracker sounds almost..hard to describe...
Anyone who knows how I can get rid of them??

And F many thansk you got me forward on this...
best regards micke
micke1967 is offline   0 Reply With Quote
Old Feb 22, 2013, 11:59 AM   #7
micke1967
Thread Starter
macrumors member
 
Join Date: Nov 2012
the sound i hear now I dont like is almost like when you listen to a really old very much played vinyl record...

anyone know what it could be??
guitar cable??
micke1967 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Yet Another Fast Track Pro audio issue Prodo123 Digital Audio 4 Sep 21, 2013 03:12 PM
How to get the sound working with M-Audio Fast Track to my internal speakers. busterflex Mac Basics and Help 2 Apr 10, 2013 01:27 PM
How do I uninstall drivers for M Audio Fast Track micke1967 Mac Applications and Mac App Store 2 Mar 1, 2013 09:12 AM
Mac and M Audio Fast Track Pro ironsideo Mac Pro 3 Oct 3, 2012 12:21 AM

Forum Jump

All times are GMT -5. The time now is 06:39 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC