Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 19, 2013, 11:25 AM   #1
mazzano4
macrumors newbie
 
Join Date: Feb 2012
Macbook Air Mid 2011 Start up issue

Hi all,

Hope someone can give me some constructive answers please.

I have a Macbook Air Mid 2011, Its a year or so old, with Applecare warranty
till Sept 14. I had only had this a few weeks when it took a light water spillage.
Wouldn't then start up, as i expected, needless to say my son got a good telling off. I tried the old taking it into Compuserve here in Ireland and they were having none of it and wouldn't do the repair, new logic board they said, They didnt even try to power it up, i was there.

Anyway i claimed another on my house insurance so all good, I left it to dry out in a spare room and forgot all about it as i work away alot and had my new machine. Well this is over a year later and i realised i still had this thing and found it and tried to power it up, so i plugged in the magsafe and the magsafe light was flashing from green to red then green then red and so on, Low and behold the bloody thing started up. The magsafe then went to green, Machine booted up... for about 2 minutes,,,, then powered off.

I did alot of research online, so i took off the back cover, and had a look at the Logic Board, there were only 2 tiny bits of corrosion which i gently removed with isopropol 90 odd percent alcohol and put it all back together and left it to dry out again. Just tried it again today and it did the same thing. Came on for a couple of mins then switched off.

There is no charge in the battery, its seems to get a minimal charge into the battery then power itself up, the machine is fine, everything works, Screen, Keyboard, Keyboard back light, all the keys work, everything, but just wont charge the battery and then it powers off again, I have done all the different kinds of reset key combinations, smc, nvram,pram.

Before i spend any money on it would anyone thing it could be the I/O Board.

I have removed the battery and plugged it in, had the back off whilst i did this, and the fan spins a tiny bit with a little squeak noise but NO Startup this time, only starts up with the battery in and it seems to do it on its own when it has drawn some power with the magsafe switching from red to green.

Any ideas anyone. I wouldbe delighted if its the I/O board as they are cheap enough to get and i can do that myself.

Thanks.
mazzano4 is offline   0 Reply With Quote
Old Mar 20, 2013, 10:11 AM   #2
mazzano4
Thread Starter
macrumors newbie
 
Join Date: Feb 2012
Anyone help ?
mazzano4 is offline   0 Reply With Quote
Old Mar 20, 2013, 10:55 AM   #3
Weaselboy
macrumors G5
 
Weaselboy's Avatar
 
Join Date: Jan 2005
Quote:
Originally Posted by mazzano4 View Post
Anyone help ?
I think everybody would just be guessing like me... given your description, I suspect you are correct it is the logic board. But who knows.
Weaselboy is offline   0 Reply With Quote
Old Mar 20, 2013, 12:28 PM   #4
mazzano4
Thread Starter
macrumors newbie
 
Join Date: Feb 2012
I meant the power I/O board, not logic board, I thought I gave a very good description, ah well never mind eh, thanks for taking the time to reply. Can't believe so many views and no one prepared to hazard a bit of foresight
mazzano4 is offline   0 Reply With Quote
Old Mar 20, 2013, 03:17 PM   #5
shakysam
macrumors newbie
 
Join Date: Oct 2008
Location: England
Hard to say definitively, but it's probably the logic board.

If the MagSafe LED is illuminated then the MagSafe adapter is talking to the logic board. Thus, if the MagSafe LED is still illuminated when the machine powers off then it's unlikely to be a fault with the I/O board.
__________________
ACMT
shakysam is offline   0 Reply With Quote
Old Mar 20, 2013, 03:28 PM   #6
mazzano4
Thread Starter
macrumors newbie
 
Join Date: Feb 2012
Yes, I unplugged the ribbon that goes from the power board to logic board and no light on MagSafe but when I plug the ribbon connector back into logic board it just flashes green to orange continuously. So it's the logic board then ?
mazzano4 is offline   0 Reply With Quote
Old Mar 20, 2013, 03:47 PM   #7
shakysam
macrumors newbie
 
Join Date: Oct 2008
Location: England
90% sure. Sorry!
__________________
ACMT
shakysam is offline   0 Reply With Quote
Old Mar 20, 2013, 04:16 PM   #8
mazzano4
Thread Starter
macrumors newbie
 
Join Date: Feb 2012
Strange. The light green only now, started up but went off after a munite. Plus it showed the batter symbol at top right hand corner. There was a little cross through it I think.
mazzano4 is offline   0 Reply With Quote
Old Mar 20, 2013, 04:48 PM   #9
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Light going back and forth means the energy system is unstable for some reason. The fact that u can power on for a couple of minutes, I guess because it's borderline failure (no solid, the easier diagnose kind) and the firmware does a few retries then finally gives up.

If the IO power board is inexpensive go for it. Up to you risk tolerance.

This board is full of regular users, I don't think we have a hard core hardware person here, that I've observed.
__________________
Solution: FREE, Explanation: Is gonna cost ya.
Mrbobb is offline   0 Reply With Quote
Old Mar 20, 2013, 04:52 PM   #10
mazzano4
Thread Starter
macrumors newbie
 
Join Date: Feb 2012
Solid green light only now. Will start sometimes when I press power button.
mazzano4 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
macbook air 2011 mid, apt-x oginome MacBook Air 1 Mar 20, 2014 12:41 AM
Mid 2011 MacBook Air-- Questions HIMAN1998 MacBook Air 4 Feb 13, 2014 01:32 PM
Price Advice: Macbook Air 13 (mid-2011) Bauer24 Buying Tips and Advice 8 Aug 24, 2012 09:25 AM

Forum Jump

All times are GMT -5. The time now is 04:40 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC