Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 20, 2013, 04:30 PM   #1
Wha?
macrumors newbie
 
Join Date: Mar 2013
Pismo Shutting Off With Pressure On Screen Hinge

Hi all, new to this forum but have used the great advice here many times in the past but this query is pretty specific and having searched this and other forums to no avail I think a new thread is needed. I have a Pismo G3 which I bought in 2000 and has since been upgraded from 400 to 500 MHz (standard apple cpu/daughterboard) with 1 GB of RAM, 100 GB HD, a slot loading DVD drive/writer and a PCI slot Belkin wireless card. It's running OSX 10.4.11 and still going pretty strong. It has died many a death and I have always managed to revive it with this or that replacement component. It's had most of it's major parts replaced at some point in time DC board, Logic Board, HD, CPU, screen with the exception of parts like modem, fan, speakers, inverter only the power management board hasn't been replaced. I've used it static in a studio as a sequencing/recording device so moving it has never been an issue. However now I'm giving it to my 7 year old daughter to use so it kind of needs to be reliable. Since it's last rebuild a couple of years ago it works fine apart from when pressure is applied to the area at the left of the screen hinge where it meets the perforated speaker housing just above the screen brightness controls. I can simply shut the thing off (not shut down, just shut off) by just pressing here. Moving it around can make this happen. Does anyone have an idea what this might be? The screen cable runs directly under this area and there is, if I remember correctly, a speaker cable which goes under the screen hinge cover to feed the left speaker. Given that the speaker is linked to the DC board, could this be the problem? For what it's worth there is one strip of dead pixels on the right side of the LCD if in any way the screen cable may have an influence and the only other noteworthy thing to say is that the PRAM battery is dead and disconnected. Otherwise everything works as it should. Any suggestions greatly appreciated. Thanks.
Wha? is offline   0 Reply With Quote
Old Mar 27, 2013, 08:17 PM   #2
California
macrumors 68040
 
California's Avatar
 
Join Date: Aug 2004
Quote:
Originally Posted by Wha? View Post
Hi all, new to this forum but have used the great advice here many times in the past but this query is pretty specific and having searched this and other forums to no avail I think a new thread is needed. I have a Pismo G3 which I bought in 2000 and has since been upgraded from 400 to 500 MHz (standard apple cpu/daughterboard) with 1 GB of RAM, 100 GB HD, a slot loading DVD drive/writer and a PCI slot Belkin wireless card. It's running OSX 10.4.11 and still going pretty strong. It has died many a death and I have always managed to revive it with this or that replacement component. It's had most of it's major parts replaced at some point in time DC board, Logic Board, HD, CPU, screen with the exception of parts like modem, fan, speakers, inverter only the power management board hasn't been replaced. I've used it static in a studio as a sequencing/recording device so moving it has never been an issue. However now I'm giving it to my 7 year old daughter to use so it kind of needs to be reliable. Since it's last rebuild a couple of years ago it works fine apart from when pressure is applied to the area at the left of the screen hinge where it meets the perforated speaker housing just above the screen brightness controls. I can simply shut the thing off (not shut down, just shut off) by just pressing here. Moving it around can make this happen. Does anyone have an idea what this might be? The screen cable runs directly under this area and there is, if I remember correctly, a speaker cable which goes under the screen hinge cover to feed the left speaker. Given that the speaker is linked to the DC board, could this be the problem? For what it's worth there is one strip of dead pixels on the right side of the LCD if in any way the screen cable may have an influence and the only other noteworthy thing to say is that the PRAM battery is dead and disconnected. Otherwise everything works as it should. Any suggestions greatly appreciated. Thanks.
That's what it sounds like to me. Pick up a cheap Pismo with a good screen and swap it out.
__________________
2.66ghz 13" MBP/1.67ghz Powerbook G5 15" DLHR/iPhone 16gb/30" ACD
California is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPad: Hinge Method on Screen Protector? 6thDAY iPad Accessories 12 Jul 2, 2014 12:35 PM
iPhone 5s screen causing eyestrain/pressure behind eyes? lawlbringer iPhone 4 Oct 22, 2013 05:34 PM
How to prevent a loose screen hinge? nazopo MacBook Air 4 Jul 11, 2013 06:52 AM
2010 17" MacBook Pro - Screen Pressure Point ryannazaretian MacBook Pro 2 Feb 9, 2013 12:53 PM
Does the screen hinge loosen over time? rgr555 MacBook Pro 1 Oct 2, 2012 05:11 PM

Forum Jump

All times are GMT -5. The time now is 01:56 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC