Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 20, 2013, 10:02 AM   #1
LithePanther
macrumors 6502
 
Join Date: Sep 2011
No Notification Sounds

Ok, so for the past few days I've been having some notification issues.

For all the iOS stuff (Phone, texts, mail) the alerts come through, and some 3rd party apps (Tweetbot, WWF) also come through. But then I have a lot of other apps (CNN, ABC, Zynga Poker, Facebook) whose notification sounds don't come through.

They all have sound enabled in the notifications list. I get the push notifications, I just don't get the sound. It's not muted because other notifications work.

My tweaks are:

Activator
AskToCall
Badge Customizer
BiteSMS
Blackout
BrowseInApp
BrowserChooser
Calendar Pro for NC
ChromeURL
Cyntact
DisplayCandy
FolderEnhancer
Gridlock
ISX
Jellylock
Mail Enhancer Pro
Multiiconmover
Multistorey
NCBettterSwipe
QuickStore
Springtomize 2
SwipeShiftCaret
ThumbsUp
BatteryDoctorPro
2x2 Folder Icons

All the notification sounds work on my iPhone 4, and they worked on my iPhone until a few days ago.

The only thing that changed since then was:

Added: BrowserChooser, ChromeURL, Jellylock, Quickstore, and BatteryDoctorPro.

Also, I installed Flusterless and used it for a day. Then I removed it. But i feel like the no sound started when I used flusterless to turn on DND (it is no longer on). I'm wondering if that might have corrupted any app that sent a notification while it was enabled?
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 03:12 PM   #2
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Bump. 600 views and nothing? You're hurting my feelings
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 04:30 PM   #3
BumpyFlatline
macrumors 68030
 
BumpyFlatline's Avatar
 
Join Date: Apr 2012
Silly question but any chance they somehow got disabled in settings>notifications?
BumpyFlatline is offline   0 Reply With Quote
Old Apr 20, 2013, 04:39 PM   #4
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
"They all have sound enabled in the notifications list."

Everything is set up correctly. Which is why this is so baffling.

I decided to uninstall and reinstall CNN to see if that might fix the issue. Instead, I think it isn't getting any push notifications at all (none in 6 hours) which is unusual for the time I've used the app but I have no way of seeing if they just didn't push anything today either.
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 06:23 PM   #5
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Anyone at all? I'm so desperate to fix this. I just bought the phone. I can't guarantee I can get another with 6.1.2
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 09:34 PM   #6
lukejc1
macrumors 6502
 
Join Date: Feb 2013
Location: Wisconsin
I know that CNN doesn't make sounds by design. Same with Facebook for everything except private messages.
lukejc1 is offline   0 Reply With Quote
Old Apr 20, 2013, 09:40 PM   #7
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Every notification I got from CNN and FB dinged. I only get notifications from 8 apps and if some of them didn't ding I would have noticed right away. This was a new development

Last edited by LithePanther; Apr 20, 2013 at 09:48 PM.
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 09:56 PM   #8
kirb
macrumors newbie
 
Join Date: Mar 2013
Location: Australia
 
Sounds like something changed the stock Messages sound (apps use this by default if they don't have their own sounds). Go to /System/Library/Audio/UISounds in iFile and make sure that sms-received1.caf exists and plays the sound when you tap it. If that works and you use WinterBoard, a theme has possibly overridden it with a silent sound - go to /Library/Themes and look through your themes for UISounds/sms-received1.caf; delete any that are silent. (It's also possible that a tweak is disabling it accidentally; if the above doesn't work, try uninstalling tweaks one by one until you find the culprit)
kirb is offline   0 Reply With Quote
Old Apr 20, 2013, 10:04 PM   #9
philip in al
macrumors regular
 
Join Date: Jun 2010
I'm having the same exact issue as lithepanther
philip in al is offline   0 Reply With Quote
Old Apr 20, 2013, 10:11 PM   #10
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Quote:
Originally Posted by kirb View Post
Sounds like something changed the stock Messages sound (apps use this by default if they don't have their own sounds). Go to /System/Library/Audio/UISounds in iFile and make sure that sms-received1.caf exists and plays the sound when you tap it. If that works and you use WinterBoard, a theme has possibly overridden it with a silent sound - go to /Library/Themes and look through your themes for UISounds/sms-received1.caf; delete any that are silent. (It's also possible that a tweak is disabling it accidentally; if the above doesn't work, try uninstalling tweaks one by one until you find the culprit)
I don't use winterboard themes but i'll definetely check with iFile.

I've already uninstalled all my tweaks

My SMS DOES work though
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 10:23 PM   #11
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Quote:
Originally Posted by philip in al View Post
I'm having the same exact issue as lithepanther
Any chance you've used flusterless?
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 10:36 PM   #12
eyoungren
macrumors 603
 
eyoungren's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ USA
Send a message via AIM to eyoungren Send a message via MSN to eyoungren Send a message via Yahoo to eyoungren Send a message via Skype™ to eyoungren
Just a thought, and probably won't help at all, but have you tried cycling Do Not Disturb? As in turn it on, then back off?

There are some battery saving tweaks out there that after removal often cause loss of cellular connection. Cycling the cellular button has restored the connection more than once. I'm applying that logic to this problem. Again, maybe not helpful but might be worth a shot if you haven't tried it already.
__________________
PowerMac G4 QuickSilver - 1.6Ghz DP | Sprint iPhone 5 - iOS 7.1.2 / Eclipse Black
Sprint iPhone owners, THERE IS NO DOMESTIC UNLOCK!
eyoungren is offline   0 Reply With Quote
Old Apr 20, 2013, 10:37 PM   #13
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Quote:
Originally Posted by eyoungren View Post
Just a thought, and probably won't help at all, but have you tried cycling Do Not Disturb? As in turn it on, then back off?

There are some battery saving tweaks out there that after install cause often cause loss of cellular connection. Cycling the cellular button has restore the connection more than once. I'm applying that logic to this problem. Again, maybe not helpful but might be worth a shot if you haven't tried it already.
I'll try it. Would you think installing flusterless and using that would also be something to try?
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 10:44 PM   #14
eyoungren
macrumors 603
 
eyoungren's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ USA
Send a message via AIM to eyoungren Send a message via MSN to eyoungren Send a message via Yahoo to eyoungren Send a message via Skype™ to eyoungren
Quote:
Originally Posted by LithePanther View Post
I'll try it. Would you think installing flusterless and using that would also be something to try?
That would have been my next suggestion. If this does not work and you reinstall Flusterless and your sound comes back you know that the issue is with Flusterless.
__________________
PowerMac G4 QuickSilver - 1.6Ghz DP | Sprint iPhone 5 - iOS 7.1.2 / Eclipse Black
Sprint iPhone owners, THERE IS NO DOMESTIC UNLOCK!
eyoungren is offline   0 Reply With Quote
Old Apr 20, 2013, 10:49 PM   #15
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Quote:
Originally Posted by eyoungren View Post
That would have been my next suggestion. If this does not work and you reinstall Flusterless and your sound comes back you know that the issue is with Flusterless.
Sounds like a plan
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 11:01 PM   #16
LithePanther
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Didn't seem to help any. Tried multiple times.
LithePanther is offline   0 Reply With Quote
Old Apr 20, 2013, 11:45 PM   #17
eyoungren
macrumors 603
 
eyoungren's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ USA
Send a message via AIM to eyoungren Send a message via MSN to eyoungren Send a message via Yahoo to eyoungren Send a message via Skype™ to eyoungren
Quote:
Originally Posted by LithePanther View Post
Didn't seem to help any. Tried multiple times.
Sorry, that was my shot at it. Don't know what else to suggest.
__________________
PowerMac G4 QuickSilver - 1.6Ghz DP | Sprint iPhone 5 - iOS 7.1.2 / Eclipse Black
Sprint iPhone owners, THERE IS NO DOMESTIC UNLOCK!
eyoungren is offline   0 Reply With Quote
Old Apr 21, 2013, 12:33 AM   #18
fizz7283
macrumors 6502a
 
Join Date: Jul 2010
I also have this problem with certain apps like draw something and Facebook. They have the option for playing sounds when receiving notifications, that option is enabled, but I never actually get a sound played when I get a notification.

I've never been able to figure out why and its very annoying.
fizz7283 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
notification sounds tomwvr iMac 1 Feb 4, 2014 02:25 PM
Notification sounds Bzyb iPad Tips, Help and Troubleshooting 1 May 13, 2013 01:24 PM
iPhone: Notification Sounds Pared3s Jailbreaks and iOS Hacks 0 Feb 8, 2013 07:27 PM
No notification sounds Matt-Man-Plus iOS 6 2 Sep 21, 2012 01:02 PM
Notification sounds skipping? paulie6978 iOS 5 and earlier 3 Jul 9, 2012 05:12 AM

Forum Jump

All times are GMT -5. The time now is 11:34 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC