Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 21, 2013, 03:09 AM   #1
cowbellallen
macrumors regular
 
Join Date: Jan 2007
Old contact still showing up in text message drafts

I have a contact that has been deleted from my iPhone for about 6 months. Whenever I draft a new text message and type in the first letter of the old contact's name, their info and phone number still appears. This is driving me nuts because I have a different contact with the same name and don't want to have the old contact still listed.

When I do this, I have no saved text messages at all. The contact is definitely gone from my iPhone everywhere else but here.

I have even assigned the old contact's number to a new contact I named 'gonad'. When I saved the number and typed in the old contact name into a text message draft, the old contact is gone! But when I delete the new contact, the number and old contact reappear when I try to draft again.

I have tried restoring and backing up, not to mention look for anyone that has successfully been able to do it. Please let me know if you've had success with this issue.

To recap:

A contact was deleted 6 months ago
The phone number is no longer saved anywhere
I have no saved text messages on my iPhone
I can only get rid of the contact by assigning the phone number to a new contact, which I don't want to do. I just want it gone!
cowbellallen is offline   0 Reply With Quote
Old Apr 22, 2013, 10:40 AM   #2
VSMacOne
macrumors 68030
 
VSMacOne's Avatar
 
Join Date: Oct 2008
Have you tried just doing a Reset All Settings? That might take care of it.
__________________
- iBelong to Jesus -
VSMacOne is offline   0 Reply With Quote
Old Apr 22, 2013, 10:46 AM   #3
Gav2k
macrumors 603
 
Gav2k's Avatar
 
Join Date: Jul 2009
Settings > general > spotlight search.

Turn everything off exit the menu restart your phone and try typing it again. If its solved you can choose to turn spotlight on
Gav2k is offline   0 Reply With Quote
Old Apr 22, 2013, 11:49 AM   #4
CharismaticNerd
macrumors regular
 
Join Date: Feb 2013
Location: Dallas, TX
Quote:
Originally Posted by Gav2k View Post
Settings > general > spotlight search.

Turn everything off exit the menu restart your phone and try typing it again. If its solved you can choose to turn spotlight on
That doesn't make sense?
CharismaticNerd is offline   0 Reply With Quote
Old Apr 22, 2013, 12:21 PM   #5
Gav2k
macrumors 603
 
Gav2k's Avatar
 
Join Date: Jul 2009
Quote:
Originally Posted by CharismaticNerd View Post
That doesn't make sense?
Once you've turned spotlight search off and restarted the phone try entering that contact again. It should be gone.
Gav2k is offline   0 Reply With Quote
Old Apr 22, 2013, 02:52 PM   #6
CharismaticNerd
macrumors regular
 
Join Date: Feb 2013
Location: Dallas, TX
Quote:
Originally Posted by Gav2k View Post
Once you've turned spotlight search off and restarted the phone try entering that contact again. It should be gone.
Turning it off would render nothing searchable are you saying we should re enable it at any point in time?
CharismaticNerd is offline   0 Reply With Quote
Old Apr 22, 2013, 10:01 PM   #7
Gav2k
macrumors 603
 
Gav2k's Avatar
 
Join Date: Jul 2009
Quote:
Originally Posted by CharismaticNerd View Post
Turning it off would render nothing searchable are you saying we should re enable it at any point in time?
That is what I said in my first post
Gav2k is offline   0 Reply With Quote
Old May 12, 2013, 01:47 PM   #8
cowbellallen
Thread Starter
macrumors regular
 
Join Date: Jan 2007
Quote:
Originally Posted by Gav2k View Post
Settings > general > spotlight search.

Turn everything off exit the menu restart your phone and try typing it again. If its solved you can choose to turn spotlight on

This did nothing. Any other tips? I keep accidentally sending texts to this number my sister no longer has!
cowbellallen is offline   0 Reply With Quote
Old May 13, 2013, 02:19 AM   #9
cowbellallen
Thread Starter
macrumors regular
 
Join Date: Jan 2007
Quote:
Originally Posted by procrastinator1 View Post
How many people have you texted in the last 6 months? im not asking the number of texts but how many people have you texted. Just write "this is a test message" and send it to 20-25 people... the recent contact should be gone this way. It's a recent contacts list, which just records the numbers you have texted in the past.
Ah, really? I only text the same 13-16 people MAX at any given time. And as I always accidentally message my sister's old number, I guess it stays on the contact list?
cowbellallen is offline   0 Reply With Quote
Old May 27, 2013, 09:47 AM   #10
jer04
macrumors regular
 
Join Date: Nov 2012
Location: Australia
I have the same issue. It's very annoying since the problem has been there for a really long time and apple is not doing anything to fix it. I have been googling about it and the only solution seems to be restoring as new.
jer04 is offline   0 Reply With Quote
Old May 27, 2013, 09:48 PM   #11
Daniibabbyy
macrumors newbie
 
Join Date: May 2013
Same issue here! I find it incredibly annoying!!
Daniibabbyy is offline   0 Reply With Quote
Old May 28, 2013, 01:09 AM   #12
jer04
macrumors regular
 
Join Date: Nov 2012
Location: Australia
Quote:
Originally Posted by simonpqqe View Post
Turn everything off exit the menu restart your phone and try typing it again.Image
Just tried this and it didn't work for me at least.
jer04 is offline   0 Reply With Quote
Old May 28, 2013, 02:38 AM   #13
Ocean20
macrumors newbie
 
Join Date: Dec 2012
The phone stores this information in cache memory. The only way to get rid of it is to restore the phone as new but given time the issue will appear again. I suggest you just ignore this and with time the memory will be overwritten
Ocean20 is offline   1 Reply With Quote
Old May 31, 2013, 12:31 AM   #14
ParadisA330
macrumors newbie
 
Join Date: May 2013
Yes, it's very annoying. It seems it would be a simple fix and I don't want to keep resetting my phone and reentering all my contacts when I want to delete someone.
ParadisA330 is offline   0 Reply With Quote
Old May 31, 2013, 01:24 AM   #15
Birdmagnus
macrumors member
 
Join Date: Sep 2012
I fixed this on my iphone yesterday by erasing all content and setting and then setting it up as a new iphone. Once you have it set-up, go to icloud and turn on contacts and they should be automatically ported over. Don't restore it from a backup.

Or at least thats what happened with mine, but i would recommend writing your contacts and phone number on a piece of paper before just in case something happens.
Birdmagnus is offline   0 Reply With Quote
Old Jun 18, 2013, 05:44 PM   #16
iPaddude
macrumors newbie
 
Join Date: Mar 2011
Location: In England on the outside edge of Sherwood Forest
So the only way is to delete all data? It's crazy!
iPaddude is offline   0 Reply With Quote
Old Jul 3, 2013, 12:50 PM   #17
Thornb24
macrumors newbie
 
Join Date: Jul 2013
Not a fix but work around.

This is not really a fix but kind of a work around to stop you from sending to the wrong person.
Create a new contact with a name like "void" or anything really, with the old number as the number for that newly created contact. Now when you create a new draft and start typing the name of who you want to send to, the old number will still come up but will not have the same name so you won't click that one.
Thornb24 is offline   1 Reply With Quote
Old Jul 28, 2013, 02:23 PM   #18
iPaddude
macrumors newbie
 
Join Date: Mar 2011
Location: In England on the outside edge of Sherwood Forest
Quote:
Originally Posted by Thornb24 View Post
This is not really a fix but kind of a work around to stop you from sending to the wrong person.
Create a new contact with a name like "void" or anything really, with the old number as the number for that newly created contact. Now when you create a new draft and start typing the name of who you want to send to, the old number will still come up but will not have the same name so you won't click that one.
Brilliant. I did this and it helps. I used the "void" lol
iPaddude is offline   0 Reply With Quote
Old Aug 1, 2013, 02:10 PM   #19
Communicator
macrumors newbie
 
Join Date: Mar 2013
I found that workaround too.

I made a new contact called Xxxxxxxxxx ( I don't have any contacts starting with one X, never mind a series of them! ) and I assigned the old number to that.

Then I sent a text to that old number.

Then I deleted the new Xxxxxxxxxx contact, and the text message I sent.

The old number no longer troubles me, even though still in the message cache, because it has been reassigned to a deleted contact beginning with Xxxxxxxxxx, and that's a name I'll never be texting to again.

Great to be rid of what became a real pain, with seemingly no solution, other than setting the phone up again as a new handset.

Hopefully the folks at Apple tech. can sort this in iOS 7!


Communicator
Communicator is offline   0 Reply With Quote
Old Nov 15, 2013, 04:38 AM   #20
oVerboost
macrumors 6502a
 
Join Date: Sep 2013
Location: United Kingdom
If I'm reading this correctly, this problem is simple! When on the new text message screen and you type in their name it will have a circled i next to it, click this and then go down to remove from list. Then it's gone...
oVerboost is offline   3 Reply With Quote
Old Dec 22, 2013, 12:24 PM   #21
guicho69
macrumors newbie
 
Join Date: Dec 2013
Removing old contacts

There is an easy way to make sure they do not appear any longer. Once you have deleted the phone number from your contacts, send a text to the number you deleted from your contacts and hit the contact on the upper right hand corner, there you will see the Phone icon, the facetime icon and the i icon...press the (i) icon and you will see the words (REMOVE FROM RECENTS) in red...remove and that is it...try and let me know...It has worked for me every time
guicho69 is offline   1 Reply With Quote
Old Dec 22, 2013, 11:47 PM   #22
macsation
macrumors member
 
Join Date: Apr 2009
Location: Washington, DC
Quote:
Originally Posted by guicho69 View Post
There is an easy way to make sure they do not appear any longer. Once you have deleted the phone number from your contacts, send a text to the number you deleted from your contacts and hit the contact on the upper right hand corner, there you will see the Phone icon, the facetime icon and the i icon...press the (i) icon and you will see the words (REMOVE FROM RECENTS) in red...remove and that is it...try and let me know...It has worked for me every time
Thanks so much for posting this. It works!
macsation is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iOS 7 GM: share anything via Message: only sends via text message. pnutx007 iOS 7 4 Oct 31, 2013 05:28 AM
Text showing message... cherokeexj iPhone Tips, Help and Troubleshooting 1 Nov 26, 2012 08:18 PM
Why can't you italicize text in a text message? TH55 iPhone 19 Nov 14, 2012 05:26 PM
Text message fb contact without a phone #? How? Where? cybermonkey iOS 6 5 Oct 7, 2012 07:40 AM
Text message icon not showing new messages tbourne iPhone 1 Jun 23, 2012 02:19 AM

Forum Jump

All times are GMT -5. The time now is 11:40 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC