Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old May 10, 2013, 08:19 AM   #1
chaznsc
macrumors newbie
 
Join Date: May 2013
MBA Boot Frustration

Ive been chasing a persistent issue with boooting my MBA. Finally recovered the data, ordered DiskWarrior and cannot boot to the DW DVD. Support now tells me that DW wont boot with my version of the MBA and I need to boot to an external disk. So here is what i have done:

Prepared an external USB connected hard disk, installed Lion and it boots up from my Mac Mini.

Connect same drive to MBA, go into Restore mode, and select the BOOT DISK option, select the external drive, and it fires off. But it stops there, I get a white screen with a slash thru a circle. What gives? I know the drive is good.

If I boot using the OPTIONS key, the external drive and its recovery sibling show up. When selected, I get rejected (sorry, i couldnt help it)

If I do the same on my MacMini, boots right up.

Formatted and installed Lion on a flash drive, Mac Mini boots, no dice on the MBA. It sees the drive, but when its selected as the boot drive, slashed circle immediately appears and MBA shuts down in about 10 seconds.

The only thing I can think of is maybe my devices arent USB 2.0 but I have no way of knowing how to check the connection dongle.

I am beyond frustrated.
chaznsc is offline   0 Reply With Quote
Old May 10, 2013, 08:51 AM   #2
Bear
macrumors G3
 
Join Date: Jul 2002
Location: Sol III - Terra
You left out some critical bits of information...
- What model MacBook Air (including year)
- Did you install Lion patches on the USB drive you installed Lion on. Or was it up to date?
- Where did you prepare the USB drive? From the mini or the Air? If it was from the mini, it's possible that th Lion that was installed was customized for the mini.

If you installed on the USB drive from the mini, and the software is up to date, try installing the 10.7.5 Combo update and see what happens from there with the Air and booting from it.
__________________
-----Bear
Bear is offline   0 Reply With Quote
Old May 10, 2013, 09:03 AM   #3
chaznsc
Thread Starter
macrumors newbie
 
Join Date: May 2013
Quote:
Originally Posted by Bear View Post
You left out some critical bits of information...
- What model MacBook Air (including year)
- Did you install Lion patches on the USB drive you installed Lion on. Or was it up to date?
- Where did you prepare the USB drive? From the mini or the Air? If it was from the mini, it's possible that th Lion that was installed was customized for the mini.

If you installed on the USB drive from the mini, and the software is up to date, try installing the 10.7.5 Combo update and see what happens from there with the Air and booting from it.
My apologies for firing off an incomplete request.

MacBook Air 4.2 (Purchased in 2012)
Lion was NOT updated, just installed. <If this is the issue, why does that matter?>
USB and USB Disk Drive were created on the Mini, but the Lion is the same Lion I used to set up the MBA when Lion came out.
chaznsc is offline   0 Reply With Quote
Old May 10, 2013, 09:14 AM   #4
Bear
macrumors G3
 
Join Date: Jul 2002
Location: Sol III - Terra
Quote:
Originally Posted by chaznsc View Post
My apologies for firing off an incomplete request.

MacBook Air 4.2 (Purchased in 2012)
Lion was NOT updated, just installed. <If this is the issue, why does that matter?>
USB and USB Disk Drive were created on the Mini, but the Lion is the same Lion I used to set up the MBA when Lion came out.
A 2012 MBA would require 10.7.4 (if not 10.7.5) to run. As yours is a 2011 MBA and version of Lion should work.

So based on your problem description (red circle and slash) you either installed a version of OS X that didn't have the drivers for the MBA in it and sometimes applying the combo update can fix that. Or you have other issues with your Air and you need to run hardware diagnostics and not just disk warrior.
__________________
-----Bear
Bear is offline   0 Reply With Quote
Old May 10, 2013, 09:19 AM   #5
chaznsc
Thread Starter
macrumors newbie
 
Join Date: May 2013
Quote:
Originally Posted by Bear View Post
A 2012 MBA would require 10.7.4 (if not 10.7.5) to run. As yours is a 2011 MBA and version of Lion should work.

So based on your problem description (red circle and slash) you either installed a version of OS X that didn't have the drivers for the MBA in it and sometimes applying the combo update can fix that. Or you have other issues with your Air and you need to run hardware diagnostics and not just disk warrior.
I get a white/gray circle with a slash thru it. I have run the hardware diagnostics with only successful results.
chaznsc is offline   0 Reply With Quote
Old May 10, 2013, 09:32 AM   #6
Bear
macrumors G3
 
Join Date: Jul 2002
Location: Sol III - Terra
Quote:
Originally Posted by chaznsc View Post
I get a white/gray circle with a slash thru it. I have run the hardware diagnostics with only successful results.
Don't know why I thought it was red. In any case, I still recommend you make sure it's patched up to date and if necessary try the combo updater.
__________________
-----Bear
Bear is offline   0 Reply With Quote
Old May 10, 2013, 12:48 PM   #7
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Not absolutely sure Mini and Air 100% compatibly.

Can't do Internet restore to External?
__________________
Solution: FREE, Explanation: Is gonna cost ya.
Mrbobb is offline   0 Reply With Quote
Old May 10, 2013, 01:01 PM   #8
chaznsc
Thread Starter
macrumors newbie
 
Join Date: May 2013
Quote:
Originally Posted by Mrbobb View Post
Not absolutely sure Mini and Air 100% compatibly.

Can't do Internet restore to External?
I can try this.

Im also wondering if the devices I have are USB 1.0 or USB 2.0. Support at The DiskWarrior site specifically said to boot from a USB 2.0 device. Ive picked up a USB 2.0 flash drive and may test that as well. The reason I say this is that the "failure" is instantaneous, there is no way the system looks at the OS that quickly. Its as if the drive isnt there.

I'm fairly green to the Mac so my brain is hardwired to think how a Windows machine would operate. I will have to say I'd been long since done with a Windows box. But thats 20+ years in the trenches with that OS.
chaznsc is offline   0 Reply With Quote
Old May 10, 2013, 01:34 PM   #9
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Would be totally silly of vendor (and sometimes they are) to stop doing its deed if it detects USB1, sure it may take a WHOLE day instead of 30 minutes but is not THEIR time. USB2 label maybe just a suggestion, We want you to do this so you won't come back and ask, how come it's taking so long?

Maybe useful to install something, say a mini-unix, if there such a thing, which will take no time to see if the boot mechanism works. Am thinking like on a Wintel box, if I can boot into DOS, the chances are, the hardware is working and my copy of Windows is suspect.
__________________
Solution: FREE, Explanation: Is gonna cost ya.
Mrbobb is offline   0 Reply With Quote
Old May 12, 2013, 03:45 PM   #10
chaznsc
Thread Starter
macrumors newbie
 
Join Date: May 2013
Well, thank you to all who chipped in. I ended up updating my external drive with the recommended patch for Lion and was able to boot. I never got the Internet restore thing to work.

Diskwarrior was able to get my system back on its feet, however, I am plagued with file permission issues. I've got 6 or so files that aren't "right" according to DU, it "repairs" and then I rescan only to get the same results.

I'm thinking I should just wipe this and start over, I just hate to reinstall all my applications.

Thanks again to all you who helped, it's was a good learning experience for me.
chaznsc is offline   0 Reply With Quote
Old May 12, 2013, 03:56 PM   #11
Bear
macrumors G3
 
Join Date: Jul 2002
Location: Sol III - Terra
Quote:
Originally Posted by chaznsc View Post
...
Diskwarrior was able to get my system back on its feet, however, I am plagued with file permission issues. I've got 6 or so files that aren't "right" according to DU, it "repairs" and then I rescan only to get the same results.

I'm thinking I should just wipe this and start over, I just hate to reinstall all my applications.
...
The disk permissions issue is a common issue. Certain files never really get fixed. If you want to double check... what files is Disk Utility reporting with the wrong permissions?
__________________
-----Bear
Bear is offline   0 Reply With Quote
Old May 12, 2013, 06:22 PM   #12
chaznsc
Thread Starter
macrumors newbie
 
Join Date: May 2013
Quote:
Originally Posted by Bear View Post
The disk permissions issue is a common issue. Certain files never really get fixed. If you want to double check... what files is Disk Utility reporting with the wrong permissions?
Yesterday it was just a few files, today it's a whole string of them, and this is after a repair.



===== Sunday, May 12, 2013 7:16:04 PM Eastern Daylight Time =====
2013-05-12 19:16:08 -0400: Verifying permissions for “Macintosh HD”
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/Dutch.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/French.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/German.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/Italian.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/Japanese.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/da.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/fi.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/hr.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/ko.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/no.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/pl.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/pt.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/pt_PT.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/ru.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/sk.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/sv.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/zh_CN.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:11 -0400: Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resources/zh_TW.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
2013-05-12 19:16:13 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane”; should be drwxr-xr-x ; they are lrwxr-xr-x .
2013-05-12 19:16:28 -0400: Permissions differ on “System/Library/CoreServices/Menu Extras/Displays.menu”; should be drwxr-xr-x ; they are lrwxr-xr-x .
2013-05-12 19:16:33 -0400: Permissions differ on “System/Library/MonitorPanels/Arrange.monitorPanel”; should be drwxr-xr-x ; they are lrwxr-xr-x .
2013-05-12 19:16:33 -0400: Permissions differ on “System/Library/MonitorPanels/Display.monitorPanel”; should be drwxr-xr-x ; they are lrwxr-xr-x .
2013-05-12 19:16:33 -0400: Permissions differ on “System/Library/MonitorPanels/Profile.monitorPanel”; should be drwxr-xr-x ; they are lrwxr-xr-x .
2013-05-12 19:16:33 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/hr.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:33 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/sk.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:40 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/pl.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:41 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/pt_PT.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:42 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/zh_TW.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:42 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/zh_CN.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:43 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/pt.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:44 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/sv.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:45 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/ru.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:45 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/no.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:46 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/ko.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:47 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/fi.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:48 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/da.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:49 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/Dutch.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:49 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/Italian.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:51 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/French.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:52 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/German.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:16:53 -0400: Permissions differ on “System/Library/PreferencePanes/Displays.prefPane/Contents/Resources/Japanese.lproj/DisplaysPref.nib”; should be drwxr-xr-x ; they are -rwxr-xr-x .
2013-05-12 19:17:19 -0400:
2013-05-12 19:17:19 -0400: Permissions verification complete
2013-05-12 19:17:19 -0400:
2013-05-12 19:17:19 -0400:
chaznsc is offline   0 Reply With Quote
Old May 12, 2013, 07:20 PM   #13
Bear
macrumors G3
 
Join Date: Jul 2002
Location: Sol III - Terra
Quote:
Originally Posted by chaznsc View Post
Yesterday it was just a few files, today it's a whole string of them, and this is after a repair.
...
That looks about right. Don't worry about it.
__________________
-----Bear
Bear is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Boot Camp Frustration/HOW to dual boot Mac/Windows calvindsy Windows, Linux & Others on the Mac 18 Aug 17, 2013 05:41 PM
Please help, new MBA but can't boot from USB likemyorbs MacBook Air 6 Jun 26, 2013 05:56 PM
new MBA cannot boot from USB hehe299792458 MacBook Air 7 Jun 16, 2013 12:40 PM
Possible to boot iMac from MBA SSD? rpg51 Mac Basics and Help 0 Nov 8, 2012 08:07 PM
iMac with MBA as boot ssd? kjid iMac 6 Jul 5, 2012 03:46 AM

Forum Jump

All times are GMT -5. The time now is 11:59 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps